Ubuntu

Keytouch not working anymore in 8.10

Reported by _dan_ on 2008-11-02
42
This bug affects 5 people
Affects Status Importance Assigned to Milestone
keytouch (Ubuntu)
Undecided
Unassigned
Declined for Jaunty by Steve Langasek

Bug Description

Binary package hint: keytouch

Since i upgraded a few hours back, keytouch stopped working. Launches fine but when i press buttons nothing happens at all. I have loaded the correct (same as in hardy) config file, tried to edit the buttons myself but its a no go.

I have no clue what so ever why this is happening.

Does this provide a clue?:

dan@sued0r:~$ keytouch-editor
keytouch-editor: No event devices are available in /dev/input/.

Makrie (mark-grassmoon) wrote :

Same problem here, with a Microsoft Digital Media Keyboard.

Fredrik Wahlberg (wahlis) wrote :

I have the same problem with a Microsoft Digital Media Pro. If I press Play or Forward keytouch launches a new instance for every keypress.

keytouch-editor gives the same response about no event devices.

_dan_ (dan-void) wrote :

I got a Logitech mx 3000.
When i press they special keys, nothing happens at all, not even config windows of keytouch showing up like it did before.

gorneman (domenico-di-misa) wrote :

I have a BTC9000 on Xubuntu 8.10.
In hardy, Keytouch worked without problem.
In Intrepid, it doesn't accept changing in the default sound channel (master to PCM) and Keytouch-editor don't recognise special keys when i push it.
Keytouch 2.4.1 don't fix the problem.

Ron S (ronshere-people) wrote :

Same problem here after upgrade with Microsoft multimedia keyboard. The only keys working are those configured with the keyboard shortcuts program. Keytouch has no effect at all.

Running keytouchd in console gives

Warning: Not all keys can be grabbed by this program. This
         can be caused by another program which is already
         grabbing these keys.

midas_republic (jjbrophy) wrote :

I have the same issue, upgraded to Ubuntu 8.10 and Keytouch has stopped working, everything seems to be ok on the surface, it the app opens fine and does not crash, but doesn't seem to be capturing the keypresses at all. I am using a Microsoft Digital Media Pro Keyboard. and have done a complete package removal and reinstalation from the repos.. no joy.. I get the same message as Ron S when i run it from terminal.

Sparky432 (sparky432) wrote :

I have the same issue, or at least one very similar. Fresh install of Ubuntu 8.10 with keytouch & keytouch-editor packages from repo. Hardware is a Logitech MX3000 cordless desktop. Selecting the correct keyboard in keytouch does not work i.e. the extra function keys are not mapped correctly. When attempting to use keytouch-editor it does not detect any of the extra function keys when when the initial "Press key" window pops up, no matter which event device is selected or whether the keyboard is connected via USB or PS/2.

Tomasz Rzepecki (nub) wrote :

i've logitech corded wave, and the same issue. when i run keytouch-editor from terminal, it says there're not devices in /dev/input, and if i run it from /system/preferences it lists some devices (and it lists the keyboard twice), and asks me to press some function buttons on the keyboard, but it doesn't respond no matter what i press. on the other hand, intrepid seems to identify some of the keys automagically, but isn't too smart about it (for example, it maps the email client to evolution, which i have long since uninstalled in favor of thunderbird - which seems weird, shouldn't it just map to default mail client, if anything?).

Tomasz Rzepecki (nub) wrote :

oh, i found out that the terminal issue can be solved by runing keytouch with sudo.. then it acts just as it does when run from preferences.. still, it fails to detect the keyboard properly.

Ron S (ronshere-people) wrote :

After searching other bug reports I'm beginning to believe this is a problem could be with the new kernel as keytouch worked just fine in hardy . https://bugs.launchpad.net/bugs/281993 shows there seems to be a problem with multimedia keyboards.

tremby (tremby) wrote :

in my case (Logitech Internet Navigator, plugged in with PS2 -- not all the buttons used to work when it was plugged in with USB), the buttons are doing the wrong things. in particular:

media does what back should do
mute does what messenger should do
stop does what volume down should do
shopping does what search should do
favourites does what stop should do
f2 does what f10 should do
f7 does what f4 should do

all of the others do nothing.

that's a full list. produced it by setting each key to run the command echo [keyname], then kill keytouchd and restart it in a terminal, then press each key.

i noticed when running xev that each media button which actually does something causes a FocusOut, then the command is run (i see for example "f10" in the console), then there's a FocusIn, then KeymapNotify, then KeyRelease. for the buttons which do nothing i get only KeyPress and then KeyRelease. for normal buttons (letters etc) there is only KeyPress and KeyRelease. i have no idea if this is relevant.

things are actually worse when plugged into a USB port -- some of the semi-working keys do not work this way.

Fabián Rodríguez (magicfab) wrote :

@Ron S: yes, input devices are now handled differently since Intrepid. Initiall Keytouch's author had indicated he wouldn't be updating Ketouch to work with >Intrepid. For native multimedia keys support in >Intrepid, please subscribe/comment Bug #281993.

However, from the Keytouch website ( http://keytouch.sourceforge.net/ ):
"You can now use all your extra function keys on a USB keyboard too. All required kernel patches are included since Linux kernel 2.6.24. Use this kernel (or a later version) in combination with keyTouch-editor 3.2.0 beta to create keyboard files for your USB keyboard. The created keyboard file can then be imported in the latest beta verion of keyTouch (version 2.4.0 beta). KeyTouch-editor 3.2.0 beta allows you to create one keyboard file for both a PS/2 and USB connection. So after you have added all the keys to the keyboard file while the keyboard was connected via USB, you can then connect the keyboard via PS/2 and set the PS/2 scancode of the key too. If discover any bugs in keyTouch-editor or keyTouch please report them. "

Can anyone try keyTouch (version 2.4.0 beta) and KeyTouch-editor 3.2.0 beta and report back ?

Smurphy (smurphy-linux) wrote :

I did actually subscribe to Bug #281993 and tried all they have proposed. Even the solution which works with the Microsoft Keyboards. It does not work with my MX700 - so it's not the same bug.
It rather looks like this one: Bug 321740
where I also have uploaded some details and informations in that bug.
Problem is - that xev shows absolutely nothing.

One thing you can do - is actually unplug and replug (USB) the receiver - and then suddenly many (but not all) of the Multimedia keys start working again. So - IMHO something is not running clean here.

Smurphy (smurphy-linux) wrote :

BTW - on the mainpage of keytouch:
 When your keyboard is connected via USB you may have noticed that some extra function keys don't work. Note that most keyboard files in keyTouch are for a PS/2 connection and if a keyboard file is for a USB connection the name of the keyboard file will contain "(USB)". But still even if you are using the right keyboard file, some keys may not work. This is because the current USB input driver in the Linux kernel does not allow us to get these keys working. Currently I am modifying this driver so that we can get all keys working. This modification will be applied to the Linux kernel.
 So at the moment I recommend you to connect your keyboard via PS/2 and wait for a new version of the USB input driver. I will also write a new version of keyTouch that will work perfectly together with the new driver.

So yes - it's a Bug - and hopefully new version will fix it.

Fabián Rodríguez (magicfab) wrote :

I couldn't build the beta keytouch editor in Intrepid. I reported this upstream:
https://sourceforge.net/tracker2/index.php?func=detail&aid=2543078&group_id=111201&atid=658554

Phillip Susi (psusi) wrote :

This package has been removed from Ubuntu. Closing all related bugs.

Changed in keytouch (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.