keystone has a missing dep on python-prettytable

Bug #922954 reported by Justin Shepherd on 2012-01-28
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
keystone (Ubuntu)
Undecided
Vincent Ladeuil

Bug Description

# apt-cache policy keystone
keystone:
  Installed: 2012.1~e3-0ubuntu1
  Candidate: 2012.1~e3-0ubuntu1
  Version table:
 *** 2012.1~e3-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/status

# keystone-manage list_users
Traceback (most recent call last):
  File "/usr/bin/keystone-manage", line 35, in <module>
    keystone.manage2.main()
  File "/usr/lib/python2.7/dist-packages/keystone/manage2/__init__.py", line 94, in main
    module = load_module(module_name)
  File "/usr/lib/python2.7/dist-packages/keystone/manage2/__init__.py", line 32, in load_module
    module = loader.load_module(name)
  File "/usr/lib/python2.7/pkgutil.py", line 246, in load_module
    mod = imp.load_module(fullname, self.file, self.filename, self.etc)
  File "/usr/lib/python2.7/dist-packages/keystone/manage2/commands/create_credential.py", line 3, in <module>
    from keystone.manage2 import mixins
  File "/usr/lib/python2.7/dist-packages/keystone/manage2/mixins.py", line 2, in <module>
    import prettytable
ImportError: No module named prettytable

-----

This error is resolved by installing python-prettytable

# apt-get install python-prettytable
--snip--
# keystone-manage list_users
WARNING:root:Database (sqlite:////var/lib/keystone/keystone.db) is not version controlled; run `keystone-manage sync_database` or override your migrate version manually (see docs)
+----+------+-------+-------------------+---------+
| ID | Name | Email | Default Tenant ID | Enabled |
+----+------+-------+-------------------+---------+
+----+------+-------+-------------------+---------+

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in keystone (Ubuntu):
status: New → Confirmed
Changed in keystone (Ubuntu):
assignee: nobody → Daniel Polehn (dpolehn-gmail)
tags: added: bitesize
Changed in keystone (Ubuntu):
status: Confirmed → In Progress
Dave Walker (davewalker) on 2012-01-30
Changed in keystone (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package keystone - 2012.1~e4~20120203.1574-0ubuntu1

---------------
keystone (2012.1~e4~20120203.1574-0ubuntu1) precise; urgency=low

  [Chuck Short]
  * New upstream release.
  * Dropped debian/patches/temp_fix_keystone_manage.patch: No longer needed.

  [Daniel Polehn]
  * Fix bad manpage formatting causng missing spaces.
    (LP: #907206)
  * Adding python-prettytable to dependency. (LP: #922954)
 -- Chuck Short <email address hidden> Thu, 26 Jan 2012 10:53:46 -0500

Changed in keystone (Ubuntu):
status: Fix Committed → Fix Released
Vincent Ladeuil (vila) wrote :

Please re-open this bug as the dependency was added to the wrong section, see https://code.launchpad.net/~vila/ubuntu/precise/keystone/fix-922954/+merge/91457 for an hopefully proper fix.

Changed in keystone (Ubuntu):
status: Fix Released → Incomplete
Daniel Polehn (dpolehn-gmail) wrote :

Marked this as "in progress" Vincent thanks for catching this and submitting a fix feel free to assign yourself to this bug. Thanks

Changed in keystone (Ubuntu):
status: Incomplete → In Progress
assignee: Daniel Polehn (dpolehn-gmail) → nobody
Vincent Ladeuil (vila) on 2012-02-07
Changed in keystone (Ubuntu):
assignee: nobody → Vincent Ladeuil (vila)
Chuck Short (zulcss) wrote :

This was fixed in the last upload.

Changed in keystone (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers