[SRU] mitaka point releases

Bug #1592865 reported by David Della Vecchia on 2016-06-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
keystone (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

New point releases for misc openstack components for the mitaka release:

keystone 9.0.2

Changed in keystone (Ubuntu):
status: New → Invalid
Martin Pitt (pitti) wrote :

The changes look reasonable and there are corresponding test cases. Please still add a a test plan (or link to that) how you make sure to not regress existing installations with new upgrades. (I figure this won't be the last update for 16.04 LTS)

Changed in keystone (Ubuntu Xenial):
status: New → Incomplete
Corey Bryant (corey.bryant) wrote :

Hello Martin,

For all stable point releases, we perform regression testing by juju deploying two openstack clouds, one against -proposed and one against -updates, and we then run tempest integration smoke tests[1] to verify those deployed clouds, and evaluate any differences in results.

[1] https://github.com/openstack/tempest/blob/master/README.rst

Thanks,
Corey

tags: added: verification-done
Corey Bryant (corey.bryant) wrote :

Moving this back to verification-needed since it's not been accepted into -proposed yet.

tags: added: verification-needed
removed: verification-done

Hello David, or anyone else affected,

Accepted keystone into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/keystone/2:9.0.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in keystone (Ubuntu Xenial):
status: Incomplete → Fix Committed
Corey Bryant (corey.bryant) wrote :

Hello Brian,

keystone 2:9.0.2-0ubuntu1 has been tested successfully.

Thanks,
Corey

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package keystone - 2:9.0.2-0ubuntu1

---------------
keystone (2:9.0.2-0ubuntu1) xenial; urgency=medium

  * New upstream point release for OpenStack Mitaka (LP: #1592865).
  * d/p/sql_connection.patch: Rebased.
  * d/p/add-version-info.patch: Rebased.
  * d/p/default-log-dir.patch: Rebased.

 -- David Della Vecchia <email address hidden> Fri, 17 Jun 2016 13:40:58 -0400

Changed in keystone (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for keystone has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers