Ubuntu

KeyJnote failing Error: pdftoppm produced an unreadable file (page 1)

Reported by ari häyrinen on 2007-10-02
18
Affects Status Importance Assigned to Milestone
keyjnote (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: keyjnote

None of the pdf files seem to work with keyjnote. Maybe related to this?
https://bugs.launchpad.net/ubuntu/+source/xournal/+bug/137944

error:
Welcome to KeyJnote version 0.10.0
Detected screen size: 1280x1024 pixels
Using GL_ARB_texture_rectangle.
Error: pdftoppm produced an unreadable file (page 1)
Error: pdftoppm produced an unreadable file (page 2)
...

OS: Gutsy

Tim (liquid-haveheart) wrote :

This will fix it for you. I've sent this to the author as well.

Tim (liquid-haveheart) wrote :

btw, that patch is against 0.10.1 not 0.10, it will probably apply with fuzz though.

pliz (pliz) wrote :

So is the bug going to be corrected in Gutsy?

Tobias Doerffel (tobydox) wrote :

Same problem here. Can someone please include this patch or some other solutions to fix this? The bug renders the whole package unusable!!

@Tim:
Your patch works here with manually installed KeyJNote. Would be nice if the error gets fixed before Gutsy will be released in 2 days.

Martin Zuther (mzuther) wrote :

Confirmed on my Ubuntu Gutsy.

Changed in keyjnote:
status: New → Confirmed
Martin Zuther (mzuther) wrote :

Hi!

Not knowing much more than that Python is a scripting language, I just managed to adapt the patch to KeyJNote 10.0 (the current version in Gutsy). Maybe someone should look over it, but it works fine for me... ;)

All the best,

Martin

P.S.: Could someone please set this bug to "important" / fix it? This bug renders "keyjnote" completely unusable in Gutsy...

Marc Carson (baggageclaim) wrote :

This is quite a bug! It took me a while to figure out what was happening, because KeyJNote is just broken. I didn't know what a .patch file was until I tried the "patch" command...so, if you want to download Martin's patch above, and try it, go to the folder where you've installed KeyJNote (I did a manual install from the KeyJNote site, just out of let's-see-ishness) and type:

patch keyjnote.py keyjnote_v10.0.patch

Then run KeyJNote again and it should work. Hope to see this bug fixed in the repos soon. :-)

Martin Zuther (mzuther) wrote :

If you can't adapt Marc's command for yourself, then download the patch, move it to your home directory, open the shell ("Terminal") and type:

  cd /usr/share/keyjnote
  sudo patch --backup keyjnote.py ~/keyjnote_v10.0.patch

You have to run "patch" as superuser (sudo), otherwise you'll get an error. This command also creates a backup of the original file (--backup), which is always a good idea if things go wrong, and loads the patch file from your home directory (~). :)

Martin

Thanks, the patch works fine!

Since there now is a working patch, would it be possible to get a patched package into gutsy-updates? A broken application should be reason enough to provide an updated package, I think.

The patch is working here too.

Thanks for the fix.

Richard Johnson (nixternal) wrote :

It is working in Hardy I just noticed. I stopped using it a few months back when I noticed this same issue. Version in Hardy is 0.10.2-1. Finally some cool presentation effects once again!

Changed in keyjnote:
status: Confirmed → Fix Released
Fabio Zanini (iosonofabio) wrote :

I'm using Ubuntu 7.10 Gutsy and keyjnote 0.10.0-1 .

I installed keyjnote from the repos and couldn't get it work. I installed patch from the repos and applied the patch of Tim using Martin Zuther's commands, but I got the following error message:

NameError: global name 'RealPage' is not defined

Then, following bug #178429 in keyjnote, created by Siep Kroonenberg, I opened keyjnote.py with gedit and substituted "RealPage" with "page" (without "") on line 1050.

Now it works for me. I still had some rendering problems which I resolved by using parameter -e. My synthax is thus:

keyjnote -e MYFILE.pdf

and everything's ok!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers