Ubuntu

Always kexecs on shutdown/reboot

Reported by Matt Zimmerman on 2008-07-23
62
This bug affects 6 people
Affects Status Importance Assigned to Milestone
kexec-tools (Ubuntu)
Medium
Andy Whitcroft
Intrepid
Undecided
Unassigned
Jaunty
Medium
Andy Whitcroft

Bug Description

Binary package hint: kexec-tools

When I have kexec-tools installed, it seems to trigger a kexec whenever I shut down or reboot. This doesn't seem like sensible default behavior, and my reading of the init script seems to indicate that it's not intentional. It happens nonetheless, though.

===

SRU Justification [Jaunty]

Impact: when kexec-tools is installed reboot is optimised using kexec, the user no longer drops to bios nor sees their bootloader menus. this should be an opt-in change as the user may install kexec to get crash dump functionality and is not expecting reboot to be altered.

Fix Description: change the default to disable use of kexec for reboot by default for new installations, for upgrades from versions before this fix switch it off.

Patch: http://launchpadlibrarian.net/26123164/kexec-tools-jaunty-default-off-and-turn-off-KEXEC_LOAD-on-upgrade

Risks: the change of default may affect previous installs

TEST CASE: install kexec-tools and reboot, the bios and bootloader are skipped before this fix, but should not be skipped after it. Please also make sure to test upgrades from a system that already had kexec-tools installed.

Matt Zimmerman (mdz) wrote :

Targeting for intrepid, as this makes linux-crashdump unusable

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kexec-tools - 20070330-4ubuntu6

---------------
kexec-tools (20070330-4ubuntu6) intrepid; urgency=low

  * Do no load kernel for kexec by default. People who install this package
    don't always want this feature automatically. LP: #251242

 -- Ben Collins <email address hidden> Tue, 05 Aug 2008 15:24:45 -0400

Changed in kexec-tools:
status: New → Fix Released
Hernando Torque (htorque) wrote :

This also happens with

kexec-tools:
  Installed: 20090000-2.0.0ubuntu2
  Candidate: 20090000-2.0.0ubuntu2
  Version table:
 *** 20090000-2.0.0ubuntu2 0
        500 http://archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

carrerasg (carrerag) wrote :

I'm seeing this also with 20090000-2.0.0ubuntu3. Is there a workaround I can apply?

Hernando Torque (htorque) wrote :

Replace "KEXEC_LOAD=true" with "KEXEC_LOAD=false" in /etc/default/kexec.

Changed in kexec-tools (Ubuntu):
status: Fix Released → Confirmed
Matt Zimmerman (mdz) on 2009-04-12
Changed in kexec-tools (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Andy Whitcroft (apw) wrote :

This does appear to have been fixed in the Intrepid code base but not fixed in Jaunty and later. Attached is debdiff for Jaunty to change the default there also.

Changed in kexec-tools (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: Triaged → In Progress
Andy Whitcroft (apw) on 2009-04-27
description: updated
Andy Whitcroft (apw) on 2009-04-27
tags: added: regression-release
Changed in kexec-tools (Ubuntu Jaunty):
assignee: nobody → Andy Whitcroft (apw)
status: New → In Progress
description: updated
Andy Whitcroft (apw) on 2009-04-27
Changed in kexec-tools (Ubuntu Jaunty):
importance: Undecided → Medium
Andy Whitcroft (apw) wrote :

i am looking for a main-sponsor for this upload to jaunty-proposed.

Colin Watson (cjwatson) wrote :

Sponsorship in progress.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kexec-tools - 20090000-2.0.0ubuntu4

---------------
kexec-tools (20090000-2.0.0ubuntu4) karmic; urgency=low

  * kexec based reboot triggers a number of semantic changes which
    are visible to the user, it should be opt-in by default. Adjust
    kexec.default to disable kexec by default. LP: #251242

 -- Andy Whitcroft <email address hidden> Mon, 27 Apr 2009 10:32:46 +0100

Changed in kexec-tools (Ubuntu):
status: In Progress → Fix Released
Colin Watson (cjwatson) on 2009-04-28
description: updated
Colin Watson (cjwatson) wrote :

Please disregard this jaunty-proposed upload for the moment. As discussed on #ubuntu-devel, this needs some more work.

Andy Whitcroft (apw) wrote :

Discussed this upload with Colin Watson, he indicates there policy violation in the handling of the configuration files which will lead to different behaviour from dpkg and apt-get installs of the package, I have filed a new bug for that issue, bug #368745. It was also felt appropriate that we should update older installs to disable the kexec reboot. I will prepare new debdiffs for this.

Changed in kexec-tools (Ubuntu):
status: Fix Released → In Progress
Andy Whitcroft (apw) wrote :

This patch is a second debdiff for Karmic applying the default on upgrade and fixing the policy violation from bug #368745.

Andy Whitcroft (apw) wrote :

(Updated to include the correct bug numbers). This patch is a second debdiff for Karmic applying the default on upgrade and fixing the policy violation from bug #368745.

Andy Whitcroft (apw) wrote :

(... and the right patch, whimper). This patch is a second debdiff for Karmic applying the default on upgrade and fixing the policy violation from bug #368745.

Andy Whitcroft (apw) wrote :

This should be the combined patch biringng all of the changes above for Jaunty.

Martin Pitt (pitti) wrote :

Rejected the first upload. Colin, since you discussed that with Andy, would you mind reviewing and sponsoring the followup patch? Thanks!

Andy Whitcroft (apw) on 2009-05-11
description: updated
Colin Watson (cjwatson) wrote :

Yes, I think this is fine now (sorry for the delay). I'll upload these.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kexec-tools - 20090000-2.0.0ubuntu5

---------------
kexec-tools (20090000-2.0.0ubuntu5) karmic; urgency=low

  * debian policy forbids dpkg conffile handling and maintainer script
    configuration in the same package as this leads to inconsistant behaviour
    between apt-get install and dpkg -i installs of the same package. Switch
    wholy to the maintainer script. LP: #368745
  * kexec reboot has been enabled by default whereas it should have been
    opt-in, it is therefore appropriate to force this off for upgrades from
    older versions. LP: #251242

 -- Andy Whitcroft <email address hidden> Tue, 28 Apr 2009 19:21:30 +0100

Changed in kexec-tools (Ubuntu):
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

Accepted kexec-tools into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in kexec-tools (Ubuntu Jaunty):
status: In Progress → Fix Committed
tags: added: verification-needed
Max Lemieux (max-lemieux) wrote :

Thank you - I've installed the latest jaunty-proposed update for this package (20090000-2.0.0ubuntu3.1) and rebooting works normally again, as before the intrepid-to-jaunty upgrade.

Martin Pitt (pitti) on 2009-06-05
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kexec-tools - 20090000-2.0.0ubuntu3.1

---------------
kexec-tools (20090000-2.0.0ubuntu3.1) jaunty-proposed; urgency=low

  * debian policy forbids dpkg conffile handling and maintainer script
    configuration in the same package as this leads to inconsistant behaviour
    between apt-get install and dpkg -i installs of the same package. Switch
    wholy to the maintainer script. LP: #368745
  * kexec reboot has been enabled by default whereas it should have been
    opt-in, it is therefore appropriate to force this off for upgrades from
    older versions. LP: #251242
  * kexec based reboot triggers a number of semanatic changes which
    are visible to the user, it should be opt-in by default. Adjust
    kexec.default to disable kexec by default. LP: #251242

 -- Andy Whitcroft <email address hidden> Mon, 27 Apr 2009 10:32:46 +0100

Changed in kexec-tools (Ubuntu Jaunty):
status: Fix Committed → Fix Released

I've just been bitten by this interesting feature on a current Jaunty system.

I installed linux-crashdump, and now all my alterations to /boot/grub/menu.lst are ignored.
I spent ages trying to discover why /proc/cmdline was an old version that didn't exist any more in my menu.lst
[I didn't see that the system wasn't going via grub, because this is a remote server.]

May I recommend:

 (1) If linux boots via a kexec, please, please put something in dmesg (or /var/log/messages) to that effect.

 (2) /etc/rc6.d/S85kexec should do a kexec reboot of the default kernel and kernel-commandline by parsing
     /boot/grub/menu.lst. In many cases, this will be equivalent to "reboot the current kernel, with the current
     cmdline", but if the user has edited menu.lst, then that is what the user wants to get. In other words:
        * parse menu.lst [or possibly lilo.conf?] , to pull out the user's current preference for default kernel and cmdline
        * if they are the same as we're currently running, do a kexec -e
        * otherwise, use kexec -l... and/or kexec --command-line=... before the kexec -e.

  (3) I know about /etc/default/kexec, but it's simply not right to have a different configuration in two places.

I expect the system to come up in _exactly_ the same state, whether I started it with "shutdown -r now"
or "shutdown -h now" followed by pressing the power button. At the moment, wildly different things happen!

(I do really like the increased reboot speed though :-) ).

Andy Whitcroft (apw) wrote :

@Richard --- if you installed linux-crashdump and it turned on kexec by default that sounds wrong. We would expect you to have to opt in to the automatic kexec behaviour on reboot. Please file a bug on linux-crashdump and reference this one in the description. Thanks.

Martin-Éric Racine (q-funk) wrote :

This bug seems to be back in Karmic since a few days. Normal reboot has been replaced by kexec, which is counter-intuitive, because it doesn't allow e.g. selecting a different kernel via GRUB's boot menu if needed.

Hernando Torque (htorque) wrote :

Not for me. I just installed kexec-tools (20090000-2.0.0ubuntu12) and /etc/default/kexec stills says "KEXEC_LOAD=false".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers