kerneloops new notification dialog

Bug #344377 reported by Cody Russell on 2009-03-17
8
Affects Status Importance Assigned to Milestone
kerneloops (Ubuntu)
Medium
Ken VanDine

Bug Description

Binary package hint: kerneloops

When there is a kernel oops, a notification bubble appears asking if you want to send the error to the Kernel Oops Web site, containing five buttons: “Always”, “Yes”, “No”, or “Never”, and “Details”. Instead, this should be an alert box with four buttons, and an expandable section to show the error log.

We should:
 1/ Make this a dialog rather than a notification
 2/ Rename the buttons from Always / Yes / No / Never / Show Details
                                    to Always / Never / Don't send / Send / [Show Details]

The above items will be a first patch. Once that is done a second patch should:

 1/ Remove the 'Show Details' button, and move the details into a textview under an expander.

For h0t pix, see https://wiki.ubuntu.com/NotifyOSD#kerneloops

(Originally reported as bug 340773.)

Cody Russell (bratsche) wrote :
Cody Russell (bratsche) wrote :
Cody Russell (bratsche) wrote :
Cody Russell (bratsche) wrote :

I removed the bold text that said "Your system had a kernel failure" and added a window title that says "Kernel Failure".

Cody Russell (bratsche) wrote :

Updated patch.

Cody Russell (bratsche) wrote :
Matthew Paul Thomas (mpt) wrote :

Nice work! Minor tweaks if you feel like it:

* "Don't send" should be "Don’t Send".

* Either "Send" or "Don’t Send" should be the default button. (Probably "Send", assuming that if you didn't want to submit the reports you wouldn't have kerneloops installed in the first place.)

* The message text, the disclosure triangle, and the left edge of the "Always" button should be flush left. (If the window is enlarged to show more details, the "Always" and "Never" buttons should stick to the left, while the "Don’t Send" and "Send" buttons stick to the right.)

Cody Russell (bratsche) wrote :

* Fixed capitalization for "Don't Send"
* Set "Send" as the default response

- Did not change the layout, such as the alignment of widgets according to dialog edges. That would take a little bit more poking around inside the dialog's contents than I feel is worth doing right now. If someone else wants to do this, go for it.

Cody Russell (bratsche) wrote :

mpt asked me to remove the window icon in the titlebar. This patch does that.

Changed in kerneloops (Ubuntu):
assignee: nobody → bratsche
importance: Undecided → Medium
status: New → Confirmed
Cody Russell (bratsche) wrote :
Changed in kerneloops:
assignee: bratsche → ken-vandine
status: Confirmed → In Progress
Ken VanDine (ken-vandine) wrote :

Attached debdiff with patch

Changed in kerneloops (Ubuntu):
milestone: none → ubuntu-9.04-beta
Ken VanDine (ken-vandine) wrote :

Updated debdiff with the patch inline

Ken VanDine (ken-vandine) wrote :

Updated debdiff, removing test/*dbg

Martin Pitt (pitti) on 2009-03-19
Changed in kerneloops (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kerneloops - 0.12-0ubuntu4

---------------
kerneloops (0.12-0ubuntu4) jaunty; urgency=low

  [ Ken VanDine ]
  * debian/applied-patches/kerneloops-applet.c.patch: Convert notification to
    a dialog. Applied inline, since package has no patch system. (LP: #344377)
  * debian/rules: Remove test/*dbg, these should be cleaned by the Makefile
  * debian/applied-patches/submit.c.patch: Fix the config parser so that it
    will actually work with apport. Thanks to Matt Zimmerman for the patch!
    (LP: #344813)

  [ Martin Pitt ]
  * Moved *.patch to debian/applied-patches/, to be a little less confusing.

 -- Ken VanDine <email address hidden> Thu, 19 Mar 2009 08:48:36 -0400

Changed in kerneloops:
status: Fix Committed → Fix Released
description: updated
Cody Russell (bratsche) wrote :

Hey, I made a small mistake in the dialog. Attaching a patch next.

Cody Russell (bratsche) on 2009-03-21
Changed in kerneloops:
status: Fix Released → Confirmed
Martin Olsson (mnemo) wrote :

I was about to open a bug on the incorrect box packing just now when I found Cody's patch in the comment above. I've tested the patch and it works perfectly (I'm on xorg-edgers so I get at least one kerneloops per boot up).

Ken, will you merge this patch for jaunty?

Ken VanDine (ken-vandine) wrote :

New debdiff with Cody's patch included

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kerneloops - 0.12-0ubuntu5

---------------
kerneloops (0.12-0ubuntu5) jaunty; urgency=low

  * debian/applied-patches/kerneloops-applet.c.patch: Updated patch to include
    a fix for box packing so expander fills and expands submitted by Cody
    Russell. (LP: #344377)

 -- Ken VanDine <email address hidden> Wed, 25 Mar 2009 15:27:17 -0400

Changed in kerneloops (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers