kernel images build by kernel-package, silently file to make initrd images upon install

Bug #546277 reported by Arturas K
This bug affects 7 people
Affects Status Importance Assigned to Milestone
kernel-package (Ubuntu)

Bug Description

Binary package hint: kernel-package

package: kernel-package
version: 12.032
arch: amd64

1) make-kpkg --initrd --revision=0.$NOW kernel-image && make-kpkg --initrd --revision=0.$NOW kernel-headers

2) installed the packages, no initrd image found, in grub config root device was pointed by sda2, but not by uuid

3) fixed the problem with:

update-initramfs -c -k && update-grub

p.s. why such a handy tool is downgraded from main into universe?

Revision history for this message
Kirill Kabardin (kkabardin) wrote :

make-kpkg not only doesn't create initrd image, but also generates broken grub config.

Revision history for this message
Lorenzo Bettini (bettini) wrote :

I confirm the same problem for x86 32

and the manual creation of initrd fixes the problem

Revision history for this message
Lorenzo Bettini (bettini) wrote :

it seems (finally) fixed in Maverik, kernel package

Version: 12.033

but it's really sad that it had never been fixed in Lucid (it wasn't even assigned!)

Revision history for this message
Juan Simón (simonbcn) wrote :

I have updated kernel-package to Maverick version but this doesn't solve the problem.
I solved it with a manual update of initrd.
I have installed Lucid version because is a LTS but, finally, I think that was a bad idea. The bugs are solved in newer versions but not in Lucid. :-(

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.