[PATCH] Support i386 Xen subarch

Bug #40088 reported by Tom Hibbert on 2006-04-19
14
Affects Status Importance Assigned to Milestone
kernel-package (Ubuntu)
Medium
Unassigned

Bug Description

Xen 3.0.2 drops Xen as an architecture, implementing as a subarch of i386 instead. kernel-package needs to be updated to support this.

Manoj Srivasta made changes to upstream, but they could not easily be ported into the Ubuntu version at this time. Therefore, I have backported Manoj's changes to the Ubuntu version.

Derived (you could almost say Inspired) from Manoj Srivasta's upstream changes to kernel-package (http://<email address hidden>/kernel-package--devel--9.0--patch-143?log?expand)

Current Status:

Build Xen0 kernel: Yes
Install Xen0 kernel: Yes
Update Grub menu.lst automatically: No

Build i386 plain kernel: Untested

Thanks in advance

Tom

Patrick Jordan-Smith (pjs) wrote :

Can we get some movement on this bug? I would like to be able to build kernels in the normal way for my machines.

Patrick Jordan-Smith (pjs) wrote :

I also cannot build kernels for Xen

Changed in kernel-package:
status: Unconfirmed → Confirmed
Herman Bos (hbos) wrote :

I think it work be really nice to have this for dapper. especially since it lasts a while. Doesn't look too tricky, but its probably to late to get it in?

Ben Collins (ben-collins) wrote :

In edgy. In fact, we'll have xen kernels in edgy as well.

Changed in kernel-package:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers