Ubuntu

Unable to restore KeePassX window, once it's minimized to tray

Reported by Bruce Doan on 2011-09-05
196
This bug affects 37 people
Affects Status Importance Assigned to Milestone
keepassx (Ubuntu)
High
Unassigned
sni-qt (Ubuntu)
Undecided
Unassigned

Bug Description

I can lock/unlock workspace, but unable to see the main window

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: keepassx 0.4.3-1ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Tue Sep 6 06:16:32 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
SourcePackage: keepassx
UpgradeStatus: Upgraded to oneiric on 2011-09-03 (2 days ago)

Bruce Doan (rgv151) wrote :
Bruce Doan (rgv151) on 2011-09-05
summary: - Unable to restore KeePassX window, once it's minimized
+ Unable to restore KeePassX window, once it's minimized to tray
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in keepassx (Ubuntu):
status: New → Confirmed
Lafiir Abhriel (lafiir) wrote :

If you previously had KeePassX set to minimize on start, here is a quick way to regain access to your passwords until this bug is fixed.
Open ~/.config/keepassx/config.ini and change the following:

MinimizeToTray=false
MinimizeTray=false
StartMinimized=false

Changed in keepassx (Ubuntu):
importance: Undecided → High
Felix Geyer (debfx) wrote :

keepassx needs to be added the need-activate-action list of sni-qt.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sni-qt (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package keepassx - 0.4.3-1ubuntu2

---------------
keepassx (0.4.3-1ubuntu2) precise; urgency=low

  * Build-depend on libmagickcore-extra instead of librsvg2-bin so imagemagick
    correctly renders svg images. (LP: #979340)
  * Disable the tray icon when running on Unity. (LP: #842224)
 -- Felix Geyer <email address hidden> Mon, 16 Apr 2012 12:14:22 +0200

Changed in keepassx (Ubuntu):
status: Confirmed → Fix Released
Taras Cavin (tasc) wrote :

I'm sorry but disabling tray minimization is NOT an acceptable solution. This is the content of my ~/.config/sni-qt.conf:

[need-activate-action]
keepassx=1

It's been working just fine under oneiric and now in precise, once I rebuild keepassx to enable the tray icon. Why the package cannot create/edit the same file, I don't know, but it seems silly to disable the tray icon altogether, when such a solution exists.

Oleg Shparber (trollixx) wrote :

Why disable tray icon instead of adding keepassx to sni-qt.conf?

disabling tray minimization is a very weird, imho. i can't even imagine, how may this be considered a valid bugfix. it looks more like a new bug. i agree with guys above, the most acceptable fix here is adding keepassx to a sni-qt.conf

Felix Geyer (debfx) wrote :

Unity doesn't allow applications to have tray icons with left click actions (e.g. left click to show window).
This is by design.
If you don't like that you are free to create your own local workarounds or consider switching to another desktop environment.
I will certainly not teach keepassx to override design decision of desktop environments.

Sven Hergenhahn (svenxy) wrote :

adding keepassx to sni-qt.conf fixes the problem of not being able to show the main window in xfce on 12.04 as well, but it would be much more intuitive if it just opened on tray-icon left-click...

relgames (relgames) wrote :

Another way would be to add a new menu item, something like "Show / Hide".

i have just built keepassx from sources... after removing sni-qt package all qt applications appear in classic tray, which distinguishes LMB and RMB, so i can use keepassx the way i've used it years before. building from source looks weird and not user-friendly, well, but this is the most reasonable solution for me

David Fraser (davidf) wrote :

In the mean time, if you have a window that has disappeared with changes to the file, and you need to recover it, select "Quit" from the menu, then "Cancel" when asked if you want to save changes - this will restore the window.

David Fraser (davidf) wrote :

I've attached a patch to sni-qt that fixes this

The attachment "Attached patch to sni-qt that sets need-activate-option for keepassx by default" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Tamas Papp (tompos) wrote :

OK, systray icon has gone now.
If I understand well, the sni-qt patch above will fix the misbehaviour

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers