[SRU] keepalived v1.2.24

Bug #1783583 reported by Corey Bryant on 2018-07-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
keepalived (Ubuntu)
Undecided
Unassigned
Xenial
High
Unassigned

Bug Description

[Impact]
This release sports mostly bug-fixes and we would like to make sure all of our supported customers have access to these improvements.

[Test Case]
The following SRU process was followed:
https://wiki.ubuntu.com/OpenStackUpdates

In order to avoid regression of existing consumers, the OpenStack team will run their continuous integration test against the packages that are in -proposed. A successful run of all available tests will be required before the proposed packages can be let into -updates.

The OpenStack team will be in charge of attaching the output summary of the executed tests. The OpenStack team members will not mark ‘verification-done’ until this has happened.

This SRU will also get/require additional testing alongside https://bugs.launchpad.net/ubuntu/+source/neutron/+bug/1744062.

[Regression Potential]
In order to mitigate the regression potential, the results of the
aforementioned tests are attached to this bug.

[Discussion]

description: updated
Corey Bryant (corey.bryant) wrote :

I've uploaded keepalived 1:1.2.24-1ubuntu0.16.04.1 to the xenial review queue where it is awaiting SRU team review.

Changed in keepalived (Ubuntu):
status: New → Invalid
Changed in keepalived (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → High
Łukasz Zemczak (sil2100) wrote :

keepalived is not part of the aforementioned SRU exception so formally we cannot treat it as acceptable on terms of the approved MRE. But seeing that keepalived's only real reverse-depends is from the OpenStack set, I informally approve of the use of the procedures defined in the OpenStackUpdates MRE to verify the package.

Changed in keepalived (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-xenial

Hello Corey, or anyone else affected,

Accepted keepalived into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/keepalived/1:1.2.24-1ubuntu0.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Edward Hope-Morley (hopem) wrote :

Hi Łukasz I actually did the testing and commentary for this in bug 1744062 since it seems the announcement was made in both. So please refer to comment https://bugs.launchpad.net/ubuntu/+source/keepalived/+bug/1744062/comments/29 and in short this package works for me.

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Edward Hope-Morley (hopem) wrote :

Corey, are we going to add this to the Trusty Mitaka UCA as well?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package keepalived - 1:1.2.24-1ubuntu0.16.04.1

---------------
keepalived (1:1.2.24-1ubuntu0.16.04.1) xenial; urgency=medium

  * New upstream version for Ubuntu 16.04 (LP: #1783583).
  * d/p/fix_message_truncation_with_large_pagesizes.patch: Rebased.
  * d/p/fix-removing-left-over-addresses-if-keepalived-abort.patch:
    Cherry-picked from upstream to ensure left-over VIPs and eVIPs are
    properly removed on restart if keepalived terminates abonormally. This
    fix is from the upstream 1.4.0 release (LP: #1744062).

keepalived (1:1.2.24-1) unstable; urgency=medium

  * [d378a6f] New upstream version 1.2.24

keepalived (1:1.2.23-1) unstable; urgency=medium

  * [94beb84] Imported Upstream version 1.2.23
    (Closes: #821941)
    - fix some segfaults (Closes: #830955)

keepalived (1:1.2.20-1) unstable; urgency=medium

  * [2a22d69] Imported Upstream version 1.2.20
    enable support for:
     - nfnetlink
     - ipset
     - iptc
     - snmp rfcv2 and rfcv3

 -- Corey Bryant <email address hidden> Wed, 25 Jul 2018 10:52:54 -0400

Changed in keepalived (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for keepalived has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers