keepalived doesn't load any ipv6 virtual servers

Bug #1300739 reported by David Peall on 2014-04-01
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
keepalived
New
Undecided
Unassigned
keepalived (Ubuntu)
High
Unassigned
Trusty
Undecided
Unassigned
Utopic
High
Unassigned
linux (Ubuntu)
High
Dave Chiluk
Trusty
Undecided
Dave Chiluk
Utopic
High
Dave Chiluk

Bug Description

SRU Justification:
Impact: Keepalived is no longer able to load any IPv6 virtual servers for load balancing purposes.
Fix: Re-enable CONFIG_IP_VS_IPV6=y
Testcase: Attempt to load ipv6 virtual servers.

_____________________________________________________________________________

I've upgraded from 12.04 to 14.04 and the keepalived no longer loads any IPv6 virtual servers.

I get the following message when trying to list a virtual service:
ipvsadm -L -t [2001:xxxx:xxxx::xxx]:xxx
Resource temporarily unavailable

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: keepalived 1:1.2.7-1ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-20.42-generic 3.13.7
Uname: Linux 3.13.0-20-generic x86_64
ApportVersion: 2.14-0ubuntu1
Architecture: amd64
Date: Tue Apr 1 13:45:51 2014
ProcEnviron:
 TERM=screen
 PATH=(custom, no user)
 LANG=en_ZA.UTF-8
 SHELL=/bin/bash
SourcePackage: keepalived
UpgradeStatus: Upgraded to trusty on 2014-03-31 (0 days ago)

David Peall (dkpeall) wrote :
Theo (launchpad-flame) wrote :

+1

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in keepalived (Ubuntu):
status: New → Confirmed
David Peall (dkpeall) wrote :

This seems to be a kernel issue, I've rolled back to 3.2.56-030256 and its working again. I tried 3.13.8 and 3.14.0 they are also broken.

It renders essential functionality of the package (or a dependent one) broken.

Changed in keepalived (Ubuntu):
importance: Undecided → High
masterpe (michiel-y) wrote :

ipvsadm requires CONFIG_IP_VS_IPV6 in the kernel to be active.

This option has been set in the v3.6.10-raring kernel and the v3.6.11-raring kernel has been disabled.

michielp@michielppro:/tmp$ grep CONFIG_IP_VS_IPV6 linux-image-3.6.1*/boot/config*
linux-image-3.6.10/boot/config-3.6.10-030610-generic:CONFIG_IP_VS_IPV6=y
linux-image-3.6.11/boot/config-3.6.11-030611-generic:# CONFIG_IP_VS_IPV6 is not set

David Peall (dkpeall) wrote :

I've tried setting the option:
/boot/config-3.6.11-030611-generic:CONFIG_IP_VS_IPV6=y

I've rebooted and its still not working. Does this need to be set at kernel compile time?

masterpe (michiel-y) wrote :

You need to recomple the kernel to fix this issue. The config files in /boot/ are the settings files with what the kernel is compiled. So it is 'only' for documentation.

David Peall (dkpeall) wrote :

Ok then I have to ask surely this is an error, I shouldn't have to recompile a kernel for IPv6 VS to work?

Philipp Kern (pkern) wrote :

So the IPv6 support works as expected as soon as you enable CONFIG_IP_VS_IPV6=y in the kernel config and recompile it. This is an issue purely in the kernel and not in ipvsadm. I'd like to ask the kernel maintainers to turn on that configuration option, as it also breaks IPv6 load balancing using ipvs even if keepalived is not in use.

Changed in keepalived (Ubuntu):
status: Confirmed → Invalid

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1300739

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Philipp Kern (pkern) wrote :

There is no crash to collect and this is a feature request to reenable something that was apparently enabled before and then broke.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: kernel-key
Dave Chiluk (chiluk) wrote :

pkern-k that comment is from a bot that monitors all bugs open against linux.

This was modified by c28f49fd37b during the ubuntu-raring kernel timeframe, due to a configuration review.

We are looking into this.

Dave Chiluk (chiluk) on 2014-06-02
Changed in linux (Ubuntu):
assignee: nobody → Dave Chiluk (chiluk)
Dave Chiluk (chiluk) on 2014-06-02
description: updated
Dave Chiluk (chiluk) wrote :

Change has been submitted to both Trusty, and Utopic trees.

Tim Gardner (timg-tpi) on 2014-06-02
Changed in linux (Ubuntu Trusty):
assignee: nobody → Dave Chiluk (chiluk)
status: New → Fix Committed
status: Fix Committed → In Progress
Changed in linux (Ubuntu Utopic):
status: Confirmed → Fix Committed
Tim Gardner (timg-tpi) on 2014-06-02
Changed in linux (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: removed: kernel-key
Philipp Kern (pkern) wrote :

Dave, when is this change going out approximately?

Dave Chiluk (chiluk) wrote :

Assuming the schedule holds, and there aren't any unforseen CVE's or test regressions, we should see it in about 4 weeks.

Launchpad Janitor (janitor) wrote :
Download full text (8.4 KiB)

This bug was fixed in the package linux - 3.15.0-6.11

---------------
linux (3.15.0-6.11) utopic; urgency=low

  [ Adam Conrad ]

  * Enable building the sata-modules udeb on ppc64el.
    - LP: #1323980
  * [Packaging] Set bootloader and loader on ppc64el to grub

  [ Adam Lee ]

  * SAUCE: (no-up) rtlwifi: rtl8723be: disable MSI interrupts mode
    - LP: #1310512, #1320070

  [ Alex Hung ]

  * SAUCE: (no-up) dell-led: add mic mute led interface
    - LP: #1308297

  [ Andy Whitcroft ]

  * [Config] d-i -- add hyperv_keyboard to serial-modules udeb
    - LP: #1285434
  * [Config] tools -- enable cpupower on ppc64el
  * [Config] ppc64el -- enable perf tools
  * [Config] powerpc -- enable perf tools
  * [Config] ppc64el -- reduce MAX_ORDER with 64k pages
  * [Config] arm64 -- enable tools
    - LP: #1326050
  * [Config] switch hyper-keyboard to virtual
    - LP: #1325306
  * [Config] fix up Breaks/Replaces on linux-cloud-tools-common to fix
    upgrades
  * SAUCE: kvm: BIOS disabled kvm support should be a warning
    - LP: #1300247
  * SAUCE: nouveau: missing outputs should be warnings
    - LP: #1300244
  * [Config] d-i -- add nvme devices to block-modules udeb
    - LP: #1303710

  [ Anton Blanchard ]

  * SAUCE: (no-up) powerpc: 64bit sendfile is capped at 2GB
    - LP: #1328230

  [ Colin Ian King ]

  * SAUCE: intel_pstate: inform user that thermald is worth considering

  [ Dave Chiluk ]

  * [Config] Enable CONFIG_IP_VS_IPV6=y
    - LP: #1300739

  [ Paolo Pisati ]

  * [Config] build vexpress a9 dtb
    - LP: #1303657

  [ Tetsuo Handa ]

  * SAUCE: kthread: Do not leave kthread_create() immediately upon SIGKILL.

  [ Tim Gardner ]

  * Release Tracking Bug
    - LP: #1329045
  * [Debian] Treat vdso install as an environment variable
    - LP: #1325713
  * [Config] Treat vdso install as an environment variable
    - LP: #1325713
  * [config] Set IPMI suppoort default to "y"
  * [Config] powerpc -- CONFIG_SCSI_IBMVSCSI=y
  * [Config] CONFIG_RT_GROUP_SCHED=n
    - LP: #1284731
  * [Config] ppc64el -- switch to 64K system pages
  * [Config] CONFIG_MICROCODE_EARLY=y
  * [Config] SND_DAVINCI_SOC && SND_AM33XX_SOC_EVM =m
  * [Config] armhf: DRM_TILCDC=m
  * SAUCE: (no-up) mei_me: Add module parameter to disable MSI
  * [Config] arm64: KVM=y
  * [Config] armhf: LEDS_TRIGGER_HEARTBEAT=y
  * [Config] armhf: generic: disable CPU_IDLE
  * [Config] armhf: CPU_FREQ=y
  * [Config] Add new mlx modules to d-i
  * [Config] Added Muti-Arch support for linux-headers-PKGVER-ABINUM, linux-tools-common, and linux-cloud-tools-common
    - LP: #1295112
  * [Config] CONFIG_EXYNOS_ADC=n, CONFIG_HW_RANDOM_EXYNOS=n, CONFIG_MMC_DW_EXYNOS=n, CONFIG_USB_DWC3_EXYNOS=n
    - LP: #1294353
  * [Config] CONFIG_ABX500_CORE=y for ppc64el
  * [Config] CONFIG_ALX=m for powerpc
  * [Config] CONFIG_ACENIC_OMIT_TIGON_I=n for ppc64el
  * [Config] CONFIG_ACORN_PARTITION_*=n for ppc64el
  * [Config] CONFIG_ANDROID=n for powerpc
  * [Config] CONFIG_ASYNC_RAID6_TEST=m for ppc64el
  * [Config] CONFIG_BIG_KEYS=y for ppc64el
  * [Config] CONFIG_BSD_PROCESS_ACCT=y for ppc64el
  * rebase to v3.15
  * [Config] CONFIG_PHY_XGENE=y
  * [Config] CONFIG_MLX4_DEBUG=y
    - LP: #1328256
  * [C...

Read more...

Changed in linux (Ubuntu Utopic):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
David Peall (dkpeall) wrote :

I've added the following:
deb http://archive.ubuntu.com/ubuntu/ trusty-proposed restricted main multiverse universe

apt-get update
apt-get dist-upgrade

But I don't see a new kernel?

Philipp Kern (pkern) wrote :

This should also go into precise-proposed through the LTS backport. I mainly need it there. ;-)

I installed the trusty kernel from -proposed on precise directly and it works.

Philipp Kern (pkern) wrote :

FWIW, it's 3.13.0-30-generic with 3.13.0-30.54.

Dave Chiluk (chiluk) wrote :

@pkern, it is already in proposed for precise. Make sure you enable -proposed from a mirror that has already synced with the main archives *(i.e. mirroring usually happens nightly, so it may not be on your mirror yet).

The lts-trusty kernels in precise are basically mirrors of the ubuntu-trusty.git repository built within precise.

Changed in keepalived (Ubuntu Trusty):
status: New → Invalid
David Peall (dkpeall) wrote :

I'm running trusty so not sure how a precise-proposed is going to help?

Philipp Kern (pkern) wrote :

Thanks, Dave. I'm deploying it from there then. :)

@dkpeall: It's in trusty-proposed, too.

Adam Conrad (adconrad) wrote :

03:36 < pkern> infinity: I tried the trusty kernel on precise and I tried the lts-trusty kernel on precise. Both worked fine.

tags: added: verification-done-trusty
removed: verification-needed-trusty
Launchpad Janitor (janitor) wrote :
Download full text (19.3 KiB)

This bug was fixed in the package linux - 3.13.0-30.54

---------------
linux (3.13.0-30.54) trusty; urgency=low

  [ Adam Conrad ]

  * [Config] Enable building the sata-modules udeb on ppc64el.
    - LP: #1323980

  [ Anton Blanchard ]

  * SAUCE: (no-up) powerpc: 64bit sendfile is capped at 2GB
    - LP: #1328230

  [ Ben Widawsky ]

  * SAUCE: i915_bdw: drm/i915: Fix PSR programming
    - LP: #1321729
  * SAUCE: i915_bdw: drm/i915: Correct PPGTT total size
    - LP: #1321729

  [ Chris Wilson ]

  * SAUCE: i915_bdw: drm/i915: Broadwell expands ACTHD to 64bit
    - LP: #1321729

  [ Damien Lespiau ]

  * SAUCE: i915_bdw: drm/i915/bdw: Implement
    Wa4x4STCOptimizationDisable:bdw
    - LP: #1321729

  [ Dave Chiluk ]

  * [Config] Enable CONFIG_IP_VS_IPV6=y
    - LP: #1300739

  [ Kamal Mostafa ]

  * [Config] add debian/gbp.conf
  * Release Tracking Bug
    - LP: #1328286

  [ Mika Kuoppala ]

  * SAUCE: i915_bdw: drm/i915: add render state initialization
    - LP: #1321729

  [ Paulo Zanoni ]

  * SAUCE: i915_bdw: drm/i915: fix assert_cursor on BDW
    - LP: #1321729

  [ Steven Rostedt ]

  * SAUCE: i915_bdw: drm/i915: Do not dereference pointers from ring buffer
    in evict event
    - LP: #1321729

  [ Tim Gardner ]

  * [Config] CONFIG_POWERNV_CPUFREQ=y for ppc64el
    - LP: #1324571
  * [Debian] Treat vdso install as an environment variable
  * [Config] Treat vdso install as an environment variable
  * [Config] CONFIG_MLX4_DEBUG=y
    - LP: #1328256
  * [Config] CONFIG_I40EVF=m, CONFIG_I40E_DCB=y, CONFIG_I40E_VXLAN=y
    - LP: #1328037

  [ Timo Aaltonen ]

  * SAUCE: i915_bdw: Rebase to drm-intel-next-2014-03-07 + fixes
    - LP: #1321729
  * SAUCE: i915_bdw: Add BDW specific power well calls
    - LP: #1317865

  [ Upstream Kernel Changes ]

  * drm: expose subpixel order name routine v3
  * drm: dp helper: Add DP test sink CRC definition.
  * drm: export cmdline and preferred mode functions from fb helper
  * hugetlb: ensure hugepage access is denied if hugepages are not
    supported
    - LP: #1328251
  * powerpc/powernv: Move SG list structure to header file
    - LP: #1326015
  * powerpc/powernv: Read OPAL error log and export it through sysfs
    - LP: #1326015
  * powerpc/powernv Platform dump interface
    - LP: #1326015
  * pci_regs.h: Add PCI bus link speed and width defines
    - LP: #1328037
  * net_tstamp: Add SIOCGHWTSTAMP ioctl to match SIOCSHWTSTAMP
    - LP: #1328037
  * PCI/MSI: Add pci_enable_msi_range() and pci_enable_msix_range()
    - LP: #1328037
  * net: Change skb_get_rxhash to skb_get_hash
    - LP: #1328037
  * net: Add utility functions to clear rxhash
    - LP: #1328037
  * net: Add function to set the rxhash
    - LP: #1328037
  * i40e: set pf_id based on device and function numbers
    - LP: #1328037
  * i40e: register file updates
    - LP: #1328037
  * i40e: clear AQ head and tail registers
    - LP: #1328037
  * i40e: simplify aq head-tail-len setups
    - LP: #1328037
  * i40e: firmware version fields offsets update
    - LP: #1328037
  * i40e: allow one more vector for VFs
    - LP: #1328037
  * i40e: select reset counters correctly
    - LP: #1328037
  * i40e: retry call on timeout
    - LP: #...

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers