CMake should be a required dependency.

Bug #807386 reported by Richard Wilson
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KDevelop
Unknown
High
kdevelop (Ubuntu)
Medium
Unassigned

Bug Description

KDevelop uses CMake to build its' project yet the dependency is only suggested. Should it not be changed to required? KDevelop asks for the CMake binary path on project creation.

Sorry if I am asking in ignorance.

Revision history for this message
Harald Sitter (apachelogger) wrote :

You could also import projects with a different buildsystem and in theory have different templates.
So, depends is certainly the wrong package relation here.

Recommends might be something to consider though.

Revision history for this message
In , Sven-leo-w (sven-leo-w) wrote :

After creating a new Simple CMake-based C++ application these error-messages appear:

"Could not load project management plugin KDevCMakeManager"

followed by:

"project import plugin (KDevCMakeManager) does not support the IProjectFileManager interface."

Then the process stops, it won't ask me for build settings, and there is also no project in the project-viewer.

Reproducible: Always

Steps to Reproduce:
1. Follow these steps to create a new C++ project shown here http://userbase.kde.org/KDevelop4/FAQ#How_do_I_do_start_new_console_application.3F
2. Clicking "Finish" makes the error messages appear
Actual Results:
error-messages:

"Could not load project management plugin KDevCMakeManager"

followed by:

"project import plugin (KDevCMakeManager) does not support the IProjectFileManager interface."

Expected Results:
ask for build settings, add project to projects list

Set-up:

- Freshly set up Kubuntu 14.04 64bit system from completely formatted hard-drive
- KDELibs ver. 4.13.0
- KDevelop 4.6.0 (Installed from the Muon Discover Software Center)
- KDE Development Platform 4.13.0
- There is noting else on this machine, but Kubuntu, Wifi and NVIDIA drivers, and KDevelop!

Revision history for this message
In , Kevin Funk (kfunk) wrote :

Try running "sudo kbuildsycoca4 --global" or just "kbuildsycoca4" as user.

Probably something went wrong while kdevelop got installed (did you interrupt the install?).

Revision history for this message
In , Sven-leo-w (sven-leo-w) wrote :

(In reply to comment #1)
> Try running "sudo kbuildsycoca4 --global" or just "kbuildsycoca4" as user.
>
> Probably something went wrong while kdevelop got installed (did you
> interrupt the install?).

No, I did not interrupt the installation process, which finished without any problems.

I ran the command which printed "kbuildsycoca4 running..." but nothing changed after that. Still the same error messages

Revision history for this message
In , Harald Sitter (apachelogger) wrote :

The error message is just crap and doesn't say what is actually going on.

It is caused by there being no cmake installed on the system, also see https://bugs.launchpad.net/ubuntu/+source/kdevelop/+bug/807386.

You can run
  sudo apt-get install cmake
to fix this issue.

Revision history for this message
Harald Sitter (apachelogger) wrote :

It appears that nowadays project creation will throw errors when no cmake is present - much meh...

https://bugs.kde.org/show_bug.cgi?id=334053

Perhaps a dependency relationship is in order after all to prevent that error.

Changed in kdevelop (Ubuntu):
importance: Undecided → Medium
milestone: none → ubuntu-14.10
status: New → Triaged
Revision history for this message
In , Denis Kniazhev (denis-k1985) wrote :

@Harald Sitter (comment #3): thanks a lot, installing cmake fixed it.
The error message is awful indeed.

Changed in kdevelop4:
importance: Unknown → High
Revision history for this message
In , Giovanni Escobar Sosa (mu-tazila) wrote :

In my case, the project was created, but a very simple and incomplete one that couldn't be built. Installing cmake fixed the problem.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdevelop - 4:4.6.0-0ubuntu4

---------------
kdevelop (4:4.6.0-0ubuntu4) utopic; urgency=medium

  * Add cmake to recommends as it is needed for cmake projects and kdevelop
    will fail with an excitingly pointless error message if it is not found.
    Kdevelop can technically also be used without cmake, so cmake
    certainly does not qualify as Dependency.
    LP: #807386
 -- Harald Sitter <email address hidden> Mon, 02 Jun 2014 10:05:32 +0200

Changed in kdevelop (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.