Crash while re-loading project on startup (possibly svn integration)

Bug #51288 reported by Joe Kilner on 2006-06-29
2
Affects Status Importance Assigned to Milestone
kdevelop (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: kdevelop

Kdevelop often crashes while re-loading the last project on startup.

The call stack appears to be in the file tree code somewhere which makes me suspect that it is the svn integration that is the culprit.

The problem can be fixed by editing the ~/.kde/share/config/kdevelop3.rc file and removing the lastproject line from the general options section, however this is obviously less than optimal. Once this is done the project can be loaded manually with no problems.

The problem is intermittent and svn is working fine from the command line.

This affects multiple versions of kdevelop, including compiling the upstream source directly and 3.4 branch builds. My investigation also shows this to be an svn problem. Talking to folks on irc, the bug seems affect only certain distros, so it is the subversion/kdevelop mix that somehow is the issue. The bug also occurred in dapper.

Changed in kdevelop:
status: Unconfirmed → Confirmed
Ralph Janke (txwikinger) on 2008-06-09
Changed in kdevelop:
importance: Undecided → Medium
Joe Kilner (joekilner) wrote :

I no longer see this bug

    Joe

Changed in kdevelop:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers