Can't adjust brightness or volume with my laptop fn keys in KDE4

Bug #223643 reported by TeeAhr1 on 2008-04-28
20
Affects Status Importance Assigned to Milestone
guidance-power-manager (Ubuntu)
Undecided
Unassigned
kdemultimedia (Ubuntu)
Undecided
Unassigned
kdeutils-kde4 (Ubuntu)
Medium
Unassigned
kubuntu-kde4-meta (Ubuntu)
Undecided
Unassigned

Bug Description

My laptop: Lenovo Ideapad Y510.

My volume up/down is mapped to fn+left/right arrow, the brightness to fn+up/down arrow. These keys are mapped in gnome, but not KDE4. Ditto my volume slider on the right of my keyboard. I haven't tried the play/pause etc. keys, but I would presume the same thing. If there's any more information I can provide, plz ask.

Yuriy Kozlov (yuriy-kozlov) wrote :

I can confirm that the volume keys (Fn+F10-12) on my Asus V6J don't work.
Brightness is a separate issue, as that should be taken care of by guidance-powermanager. However, that is not installed in kubuntu-kde4 by default. Could you try installing kde-guidance and running guidance-power-manager and see if the brightness keys work?

xevix (aikawarazuni) wrote :

Confirmed on Hardy 8.04 KDE 4.0.3, Lenovo Thinkpad T61p. The brightness controls will work if you use KDE 3's kpowersave, but the volume controls don't work. The turning on/off of bluetooth/wireless works.

Harald Sitter (apachelogger) wrote :

Invalid for kde4-meta, as this is primarily due to missing keymapping in kmilo (although kmilo is going to be removed in 4.1, so I don't know what we should do to fix this issue).

Changed in kubuntu-kde4-meta:
status: New → Invalid
Changed in kdeutils-kde4:
importance: Undecided → Medium
status: New → Triaged
Arthur Schiwon (blizzz) wrote :

Confirmed on Hardy KDE 4 Beta on Lenovo Thinkpad R61i.
(But no further cognitions)

Jose Bernardo (bernardo-bandos) wrote :

kmilo is now in the unmaintained branch in kde 4.1. Unless a maintainer appears for kmilo, the chances for this being fixed are slim.

Yuriy Kozlov (yuriy-kozlov) wrote :

This won't be fixed in Hardy, but for Intrepid this needs to be done in the power manager for brightness keys and elsewhere (kmix?) for volume keys.

Changed in kdeutils-kde4:
status: Triaged → Won't Fix
Jonathan Thomas (echidnaman) wrote :

Fixed in kdemultimedia in Intrepid with kdemultimedia 4.1.0-0ubuntu3
https://edge.launchpad.net/ubuntu/+source/kdemultimedia/4:4.1.0-0ubuntu3

Changed in kdemultimedia:
status: New → Fix Released
Earle Martin (earlemartin) wrote :

Is this actually fixed? I'm still unable to use my brightness keys. Lenovo Thinkpad R61i.

$ lsb_release -rd
Description: Ubuntu 8.10
Release: 8.10
$ uname -a
Linux nebula 2.6.27-13-generic #1 SMP Thu Feb 26 07:26:43 UTC 2009 i686 GNU/Linu

Jonathan Thomas (echidnaman) wrote :

Guidance unmaintained -> won't fixing its task.

Changed in guidance-power-manager (Ubuntu):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers