kdesu fails with intl keyboard layout variants

Bug #54564 reported by jcfp on 2006-07-30
2
Affects Status Importance Assigned to Milestone
kdesudo (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdebase-bin

with a "generic 102-key" keyboard model, and settings in "Regional % Acc. -> Keyboard Layout" as follows:
Layout: US English
Keymap: us
Layout variant: intl or alt-intl

kdesu will fail when the password contains certain characters like ' or ". Upon pressing such keys, two stars (**) appear at once in the kdesu password dialog, and the password always fails.

Normally, with this keyboard layout, for getting these characters one needs to hit ' or " key followed by the SpaceBar, and thus nothing would be shown after just one key stroke (anticipating a key like o, a, e, i, to form the likes of ò, â, é, ï, etc).

All other applications work fine with this layout variant, including gksu and sudo from konsole.

Problem probably includes all "special" characters for these layouts (didn't test), and is the same with both 102-, 104-, and 105-key generic keyboards.

jcfp (jcfp) wrote :

Still exists in a fresh install of Kubuntu 6.10; severely impacts usability of system as it forces me to start every application that asks for the password from the console!

jcfp (jcfp) wrote :

Appears to be (finally!) fixed with KDE 3.5.6

Changed in kdebase:
status: Unconfirmed → Fix Released
jcfp (jcfp) wrote :

Once again malfunctions in kubuntu intredpid (kde 4.1.3), password field fails to use us-intl.

Changed in kdebase:
status: Fix Released → New
Gaetan Nadon (memsize) wrote :

Problem reproduced, moving to Confirm

Changed in kdesudo:
status: New → Confirmed
Gaetan Nadon (memsize) wrote :

Bug reproduced on kubuntu-8.10-alternate-amd64.iso

TEST CASE

Set keyboard layout as outlined by the bug reporter at top.
Create a new userid, say, testkde with any valid password
Using konsole and passwd, change password so it contains a single quote, that is, press the key labeled ' and then press the space bar.
From any other userid issue the following command:
   kdesudo -u testkde ls
You will be prompted for this userid password. It will not accept the password you set previously when you created testkde as kdesudo treats the keyboard input differently.

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

BugSquad

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers