kdesudo seems to be broken in system setting in hardy

Bug #173319 reported by Dave Morley on 2007-12-01
32
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kdesudo (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdesudo

I wanted to check the setting on my display.

So I clicked on System settings and Graphics and Display and clicked on Administrator mode I got a warning message about kdesudo and nothing else.

I tried on other settings and the same thing happened.

Related branches

Ralph Janke (txwikinger) wrote :

Thanks for reporting this problem.

Could you please give the exact warning message here. It would also help if you could give us the version of kdesu (can be retrieved with "dpkg-query -l kdesudo". Best paste the result in here).

Thanks

Changed in kdesudo:
assignee: nobody → txwikinger
status: New → Incomplete
Dave Morley (davmor2) wrote :

Certainly.

Error - KdeSudo
command not found!

kdesudo 1.4-0ubuntu1

If there is anything else please ask.

Ralph Janke (txwikinger) wrote :

Is the package really installed? I.e. with output of "dpkg-query -l kdesudo" has "ii" at the beginning of the line.

Thanks

Dave Morley (davmor2) wrote :

Yes sorry the full line reads....

ii kdesudo 1.4-0ubuntu1 sudo frontend for KDE

Ralph Janke (txwikinger) wrote :

Could you please run systemsettings from the commandline terminal. Reproduce the problem, and then please paste the output from the terminal in here.

Thanks

Gertrude (ubuntu-the-dairy) wrote :

Hi Ralph

I am also having this problem.
The error that appears after you click on "Administrator Mode" at the bottom of the screen is as follows -
sudo: /usr/bin/kcmshell kcm_knetworkconfmodule --embed-proxy 23070231 --lang en_GB: command not found

Incidently, I also have the same problem with the Monitor and Display area of System Settings with the error this time being -
sudo: /usr/bin/kcmshell Peripherals/displayconfig --embed-proxy 23071036 --lang en_GB: command not found

Gertrude (ubuntu-the-dairy) wrote :

Just a thought.
Should there be a colon after sudo at the begining of the command?
I I remove the colon and enter the command in the command line it works fine!

G

Paul Stadler (paul-stadler) wrote :

I was playing around with this a little bit, from the command line the following works:

The following works with sudo:

p@m$ sudo /usr/bin/kcmshell kcm_knetworkconfmodule --embed-proxy 54527261 --lang en_US

But this fails with kdesudo

p@m$ kdesudo /usr/bin/kcmshell kcm_knetworkconfmodule --embed-proxy 54527261 --lang en_US

It seems that kdesudo is trying to parse the '--embed-proxy' command line option in this case.

The next natural thing to try was using quotes -- none of the commands work at all with quotes. It seems that they're trying to locate an executable with the name of the entire string or something.

Using quotes on this command line will allow you to reproduce the "Command not found" error.

Ralph Janke (txwikinger) on 2007-12-04
Changed in kdesudo:
status: Incomplete → Confirmed
Ralph Janke (txwikinger) on 2007-12-06
Changed in kdesudo:
assignee: txwikinger → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdesudo - 2.0-0ubuntu1

---------------
kdesudo (2.0-0ubuntu1) hardy; urgency=low

  * New upstream release :
    - Closes LP: #157043, #162823, #144970, #148255,#172749, #173319
  * Fixed packaging to divert both binary and manpage.

 -- Anthony Mercatante <tonio@kubuntu> Tue, 04 Dec 2007 16:41:58 +0100

Changed in kdesudo:
status: Confirmed → Fix Released
pbardet (pbardet) wrote :

I have the same issue with anything that runs from the KDE menu bar on Gutsy.

dpkg-query -l kdesudo
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-========================-========================-================================================================
ii kdesudo 1.1-0ubuntu2.2 sudo frontend for KDE

But if I run systemsettings from the command line, everything works fine. Same if I run adept_updater from the command line.
It's only when I run something from an icon in the kde environment. This problem has been here since I upgraded from Feisty to Gutsy.

I even tried to remove all my personal files related to kde in order to get a fresh kde panel, but it did not help.

Matt Edwards (mwedwards) wrote :

pbardet: I can reproduce this behavior in hardy/kde4, but not sure how to go about debugging the kde4 application launcher.

In addition, the following errors are logged to auth.log:

pam_unix(su:auth): authentication failure; logname= uid=1000 euid=0 tty=pts/5 ruser=me rhost= user=root
pam_authenticate: Authentication failure

This all works fine from konsole.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers