kate is using english keyboard layout when CTRL key is pressed

Bug #72619 reported by tchize on 2006-11-20
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kdesdk (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: kate

In the French version of kate, the following keystroke are defined in kate/kwrite menu

ctrl-a: select all
ctrl-q: quit
ctrl-z: undo
ctrl-w: close window

However, when user keyboard is defined like this:

setxkbmap -model pc101 -layout us,be -variant ,nodeadkeys

The a-q and z-w keys are exchanged in kate when CTRL key is down. As a result i get those effective keystrokes:

ctrl-q: select all
ctrl-a: quit
ctrl-w: undo
ctrl-z: close window

You want to select all document (ctrl-a)? you close kate!
You want to undo a change (ctrl-z)? you close current window!

If i remove the us part of layout (it's a check box named 'include latin variant' in the kde keyboard config panel) i do not get this behaviour, but it's not a viable work around, as some characters are then impossible to make with my keyboard)

This bug does not produce in other applications. In konqueror, for example, hitting ctrl-a on my keyboard does effectively 'select all'

tchize (tchize) wrote :

Someone there?

Yuriy Kozlov (yuriy-kozlov) wrote :

Interesting, in my experience using the russian phonetic keyboard layout occasionally, shortcuts don't work at all in any application and I have to switch back to the US layout to use them. This is using the module in System Settings to set the keyboard layout and variant.

thomas coopman (tmske) wrote :

I have this problem to but not only in kate, but I think in almost all kde programs (konqueror, amarok, system settings,....)
It is very annoying.
Also things like ¨e ^e don't work like they should.
I'm using kubuntu feisty herd5

Changed in kdebase:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
thomas coopman (tmske) wrote :

I've solved my problem with the command:
setxkbmap be

David Faure (faure) wrote :

Any solution that can be done inside the kxkb settings?

Note: this doesn't only affect kate, it also affects the kmail composer window for instance.

David Faure (faure) wrote :

Ok, unchecking "include latin layout" fixes the problem. It changes the command from "-layout us,fr" to "-layout fr".
This checkbox seems very counterintuitive if it has such bad side effects. But this is an upstream bug then (kxkb, or Xorg).

Jonathan Thomas (echidnaman) wrote :

Still an issue in Intrepid?

Changed in kdebase:
status: Confirmed → Incomplete
Jonathan Thomas (echidnaman) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in kdesdk:
status: Incomplete → Invalid
gb38 (godfried-borremans) wrote :

this bug still exists/returned in Ubuntu 12.10 quantal,
Linux 3.5.0-26-generic #42-Ubuntu SMP Fri Mar 8 23:18:20 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Kate Version 3.9.5 Using KDE Development Platform 4.9.5
on a pc with Belgian keyboard with English as Kate application language .
Press Ctrl-A causes Kate to quit instead of selecting all text.
The workaround of thomas coopman (tmske), on 2007-03-26 (#4): setxkbmap be
solves the problem.

Changed in kdesdk (Ubuntu):
status: Invalid → New

For me this is enough to mark this bug as confirmed. Thank you for taking time!

Changed in kdesdk (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers