Created file doesn't appear on "Open recent" list unless opened through konqueror

Bug #41651 reported by Matti Viljanen on 2006-04-26
60
This bug affects 5 people
Affects Status Importance Assigned to Milestone
KDE Software Development Kit
Fix Released
Medium
kate (Ubuntu)
Undecided
Unassigned
kdesdk (Ubuntu)
Low
Unassigned

Bug Description

1. Open kate
2. Write text
3. Save
(repeating 2 and 3 doesn't help)
4. Close kate
5. Open kate again
6. Check File - Open recent (or something, I use Finnish) and notice the file you created from scratch doesn't appear on the list.

kate 2.5.2, kde 3.5.2, Kubuntu 6.06 Beta, no updates

How odd.

If you open the file from within kate, this bug occurs.

Yet, if you click on the file (from your desktop or from konqueror), the bug does not occur, and it behaves as expected.

Changed in kdebase:
status: Unconfirmed → Confirmed
Yuriy Kozlov (yuriy-kozlov) wrote :

I get the bug when saving a file as in the original report, but when opening a file from within kate it works fine.

Related bugs
http://bugs.kde.org/show_bug.cgi?id=85654
http://bugs.kde.org/show_bug.cgi?id=99171

According to the second one, this should be fixed.

Jonathan Thomas (echidnaman) wrote :

Still valid for KDE 4.1.1. Needs an upstream report.

ben van 't ende (benvantende) wrote :

I can confirm this for KDE 4.1.1

I can confirm the bug for KDE 4.1.2.

Ubuntu release: Kubuntu Intrepid 8.10 beta (All packages up-to-date)
Packages versions: kate-4.1.2-0ubuntu1, kdebase-4.1.2-0ubuntu4

Best regards.

Javier Jardón (jjardon) on 2009-01-11
Changed in kdesdk:
importance: Undecided → Unknown
status: New → Unknown
Changed in kdesdk:
status: Unknown → Invalid
Matti Viljanen (direc85) wrote :

This bug has been reported in KDE bug tracking system. Still not fixed.

http://bugs.kde.org/show_bug.cgi?id=123958

Changed in kdesdk:
status: Invalid → Unknown
Changed in kdesdk:
status: Unknown → Confirmed
Changed in kdesdk:
status: Confirmed → Triaged

I can confirm this kate bug on Kununtu Jaunty upgraded from Intrepid. Please fix this anomaly; kile does not suffer from it.

bub (bub-deactivatedaccount) wrote :

You can try this:

kate -> settings -> sessions

Then choose:

Load last-used session

and

Save session

Best regards.

Matti Viljanen (direc85) wrote :

Francesco, what's the outcome of doing that? Does the file now appear on the recent menu? I'm not planning to download/install/try Kubuntu, so I can't try it... Also, the bug is also in KDE bugs (see Remote bug watches). Also, the actions you mentioned - should it work - seems to only be a workaround... The behavior would still be non-intuitive, so the code still needs to be fixed.

bub (bub-deactivatedaccount) wrote :

@Matti

Yes, the recent files can now be found in the recent files menu.

I don't know if the problem is a bug or a non-intuitive behaviour
of kate sessions. The default settings are maybe not optimal.
I don't know if this should be fixed in the kate code or
in linux distribution specific settings.

@Matti @Francesco

Yes, Francesco's solution solves partially the problem as I understand. The issue is that Kate (or KDE, or Linux, whatever) uses a different approach to the "Recent documents" functionality as one is used to. See OpenOffice for example.

As I understand, the "Recent documents" are associated with a session. So if you configure Kate to create a new session every time, the "Recent documents" will always be empty after just opening the editor, hence the "bug" (between quotes, because it might be the intended behavior according to the developers).

Having Kate reopen the same session as before brings back the "Recent documents" from the last session, but also automatically opens any documents which were open before. Personally, that's not the behavior I want. I want it to work like OpenOffice, for instance: when you start it, it comes with a blank document but the "Recent documents" menu is filled with the documents I opened in the previous sessions.

Furthermore, this workaround of "Load last-used session" doesn't work if Kate is opened via double-click on a text file. When you do that, Kate will start a new session and the only document on the "Recent documents" list will be the one you've just opened. Again, that is not how OpenOffice (and many other editors) work.

Although this is not a deal breaker and I'm 50% content with the "Load last-used session" solution, I do hope KDE developers change the behavior of the "Recent documents" list to be like OpenOffice. That's the intuitive meaning of this menu for me. They could even create two menus: "Recent documents" and "Session documents", for instance.

bub (bub-deactivatedaccount) wrote :

@Vítor

kate opens a new session if not specified.

Look in

~/.kde/share/apps/kate/sessions/

to see the name of the session you want to use. It's probably called

default.katesession

or let say

whatever.katesession

Then go to your file browser and right-click on the icon you want to open
and choose

open with

then find kate

and modify the command

kate %U -> kate -s whatever %U

Apply this eventually globally and for every file type you want to open with kate and this session.

Kate is perhaps too much configurable. The ability of choosing sessions
is useful if you work on a lot of documents in different projects. You can
then open a specified session with a given file type.

@Francesco:

Good to know. Sessions are indeed a useful feature for a lot of people.

However, for me it would be best if it behaved the "intuitive" way by default and allow for other behaviors through configuration.

I confess, though, that "intuitive" is a matter for (a long) discussion, for which this is not the place.

Thanks for the tip!

Allochtoon (marcovd) wrote :

@Vítor Souza wrote on 2009-10-08: #13
However, for me it would be best if it behaved the "intuitive" way by default and allow for other behaviors through configuration.

I agree completely, as long as every little project has its own idea of 'workflow' and 'modus operandi' we get nowhere.

Let me say that i love Kate to the bone.

Is there any way to make it behave with a simple 'recent docs' way a-la openoffice? Even when clicking on files?

Changed in kdesdk:
importance: Unknown → Medium
Changed in kdesdk:
status: Confirmed → Fix Released
Ganton (ganton) wrote :

In Kubuntu 11.10 it seems solved, at least it is solved on my computer, using a new installation.

Vibhav Pant (vibhavp) on 2012-04-26
Changed in kate (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.