Umbrello crashes when I use the redo function

Bug #296715 reported by Alex Rampp on 2008-11-11
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KDE Software Development Kit
Invalid
High
kdesdk (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: umbrello

Steps to reproduce the bug:
- Open umbrello and start a new class diagramm.
- Create a few classes, aggregations, whatever.
- Click onto the "Undo" button a few times
- Click onto the "Redo" button a few times
- Umbrello crashes with a segmentation fault.

Used Versions:
Kubuntu 8.10
KDE 4.1.3
Umbrello 2.1.3

I've attached the bug report and a core dump.

Alex Rampp (bitschupser) wrote :
Alex Rampp (bitschupser) wrote :
Sergio Barjola (sbarjola) wrote :

Thank you for taking the time to report this bug.

I have tested too, and it happens the most of times in the "rename object" action, so to reproduce it easily:
 - Create two class in a class diagram.
 - Create a agregation between the two classes.
 - Click "undo" to reach a "rename object" in the history and then click the redo action.

Changed in kdesdk:
status: New → Confirmed
Sergio Barjola (sbarjola) wrote :
Jonathan Thomas (echidnaman) wrote :

Could you install kdesdk-dbg and try to get a new backtrace? (It would also be nice if you could test with KDE 4.2 beta2, if possible) Thanks.

Changed in kdesdk:
status: Confirmed → Incomplete
Sergio Barjola (sbarjola) wrote :

same backtrace with kdesdk-dbg installed with kde 4.2 beta 2.
If is there any other debug package that I need to install, I can get a new bt.

package version:
kdesdk 4:4.1.85-0ubuntu1~intrepid1~ppa1

Changed in kdesdk:
importance: Undecided → Medium
status: Incomplete → Triaged
Changed in kdesdk:
status: Unknown → Confirmed
Alex Rampp (bitschupser) wrote :

The problem still exists with version 2.2.0 on KDE 4.2

Using Umbrello 2.2.1 on KDE 4.2.2.

Clicking "Undo" and "Redo" did *not* cause the SEGV, though it did produce weird symptoms -- undoing caused created objects to vanish (expected), but redoing caused them to show up again in the tree view but remain missing from the canvas (unexpected). Multiple undos and redos did not rectify this, nor did they cause the SEGV.

However, clicking on an item in the "Command history" pane on the lower left *did* cause the SEGV.

Attaching backtrace.

Used Versions:
- Kubuntu 9.04 (Jaunty)
- KDE 4.2.2
- Umbrello 2.2.1

CORRECTION:
- Umbrello 2.2.2

Changed in kdesdk:
importance: Unknown → High
Changed in kdesdk:
status: Confirmed → Unknown
Changed in kdesdk:
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.