KIMPanel is unusable

Bug #475530 reported by Jimhu on 2009-11-05
72
This bug affects 11 people
Affects Status Importance Assigned to Milestone
kdeplasma-addons (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: plasma-widget-kimpanel

KIMPanel shipped with Kubuntu 9.10 is unusable. It has compiled for the scim and fictx backends, but not ibus's which is the default language input method that comes alone with the language support package.

You'd better recompile it with ibus backend enable, and add 'ibus-daemon --panel=/home/username/kimpanel/backend/ibus/panel.py --xim' to the autorun entry.

Jimhu (huyiwei) on 2009-11-05
description: updated
description: updated
Aron Xu (happyaron) on 2009-11-05
Changed in ubuntu-translations:
status: New → Invalid
Yaohan Chen (yaohan-chen) wrote :

I had to do the following to make the kimpanel plasmoid work with ibus:

1. Install kimpanel's ibus backend, which is not included in the Ubuntu package.

wget 'http://websvn.kde.org/*checkout*/trunk/KDE/kdeplasma-addons/applets/kimpanel/backend/ibus/panel.py'
sudo mkdir /usr/share/ibus/ui/kimpanel
sudo cp panel.py /usr/share/ibus/ui/kimpanel

2. Make ibus-daemon use kimpanel. I do this by restarting ibus-daemon with the --panel parameter after KDE starts. There are notes about this at the bottom

cat > ~/.kde/Autostart/reload-ibus-daemon <<EOF
#!/bin/sh
pkill ibus-daemon &&
ibus-daemon --panel=/usr/share/ibus/ui/kimpanel/panel.py --xim
EOF
chmod +x ~/.kde/Autostart/reload-ibus-daemon

3. Symlink /usr/share/icons/hicolor/scalable/apps/ibus.svg to /usr/share/ibus/icons, where kimpanel looks for ibus's icon. The directory was created by ibus's package, but it is empty.

cd /usr/share/ibus/icons
sudo ln -s /usr/share/icons/hicolor/scalable/apps/ibus.svg

Note
Initially I just edited /etc/X11/xinit/xinput.d/ibus to change XIM_ARGS to XIM_ARGS="--xim --panel=/usr/share/ibus/ui/kimpanel/panel.py", and expected ibus to use kimpanel. However, this did not work. I think it is because ibus-daemon is being started before the kimpanel widget is loaded, therefore, I used the workaround of restarting ibus-daemon after KDE starts, based on a Chinese blog post, <http://songlinyi.spaces.live.com/blog/cns!9D1E6496716547EE!238.entry>. If this is actually the cause, maybe ibus needs to be modified to wait for the panel to be loaded, or Ubuntu needs to have a way to delay launching ibus-daemon until KDE is fully loaded?

Aron Xu (happyaron) on 2009-12-24
Changed in ubuntu-translations:
importance: Undecided → Low
status: Invalid → Triaged
tags: added: input-method
Jonathan Thomas (echidnaman) wrote :

The plasma-widget-kimpanel package is now part of the kdeplasma-addons source package.

Changed in plasma-widget-kimpanel (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Jimhu (huyiwei) wrote :

It may still have to be compiled against ibus backend.
I think it would be great if it can be the default input method UI for KDE.

Jonathan Thomas (echidnaman) wrote :

Oops, had meant to move the bug.

affects: plasma-widget-kimpanel (Ubuntu) → kdeplasma-addons (Ubuntu)
Nicolas Piguet (npiguet) wrote :

I can confirm that it still doesn't work out of the box in Lucid Alpha 2. The ibus backend is still not packaged with kimpanel, and not configured to start properly either.

xgong (xgong) wrote :

It seems that Lucid Alpha2 did not fix this bug, and I cannot make it work even I copy what Chen had done.

RK (kubuntu-rk) wrote :

> It seems that Lucid Alpha2 did not fix this bug, and I cannot make it work even I copy what Chen had done.

Note that the panel.py script is installed as /usr/lib/ibus/ibus-ui-kde, so you have to adapt the path. It /kinda/ works with that. Kinda means: if you add the panel widgets, you will have two popups that you can move around, or you will have the whole shebang in the panel plus one popup. The "config" button does nothing at all, not does any config entries show up in systemsettings. The spam icon can be hidden using the "Icon Filter" menu. When no IM is activated, a broken images is shown.

And now I tried around with using -p /bin/echo - a plasma crash later and now I can't select anything at all anymore (unless using the gtk ui). Somehow it cannot reliable communicate. Wierd.

RK (kubuntu-rk) wrote :

I can do:
* log in to KDE
* click away any annoying KDE popup
* open a konsole
* run: ibus-daemon -x -r -d -p /usr/lib/ibus/ibus-ui-kde
* press ctrl-space and it either works, or the konsole hangs; in the latter case, close the konsole and open a new one

Using these packages:

ii ibus 1.2.0.20091215-1 New input method framework using dbus
ii ibus-anthy 1.2.0.20100115-1 anthy engine for IBus
ii ibus-gtk 1.2.0.20091215-1 New input method framework using dbus
ii ibus-m17n 1.2.0.20091217-1 m17n engine for IBus
ii ibus-qt4 1.2.0.20091217-1 qt-immodule for ibus (QT4)
ii plasma-widget-kimpanel 4:4.4.0-0ubuntu1 addons for KDE 4 Plasma - universal input me
ii plasma-widget-kimpanel-backend-ibus 4:4.4.0-0ubuntu1 addons for KDE 4 Plasma - universal input me
(the last two self-compiled from dpkg source as the mirror is not up to date yet)

rk@rk:~> ll .xinput.d/de_DE
lrwxrwxrwx 1 rk rk 28 2010-02-13 22:45 .xinput.d/de_DE -> /etc/X11/xinit/xinput.d/ibus

and in .bashrc:
export XIM_PROGRAM=
export XIM_ARGS=
export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus

I have no idea why it works for me in this combination, why I once had the the ui duplicated (once from ibus-ui-kde and once from the plasma widget; maybe because I had it expanded from the panel at the time I started the other), nor why I can't just use -p /bin/echo with it. Very unreliable, this. In particular since it can easily lock up some or all processes of the session when restarting or stopping the daemon.

Yaohan Chen (yaohan-chen) wrote :

In Lucid, I need to install plasma-widget-kimpanel-backend-ibus, and then still have to create this KDE autostart script to use KIMPanel with ibus:

cat > ~/.kde/Autostart/reload-ibus-daemon <<EOF
#!/bin/sh
ibus-daemon --replace --xim --deamon --panel=/usr/lib/ibus/ibus-ui-kde
EOF
chmod +x ~/.kde/Autostart/reload-ibus-daemon

I can run im-switch -c and choose ibus-kde to start ibus with the correct command now, but KIMPanel does not appear to communicate with ibus, unless ibus-daemon is started after KDE loads, thus the autostart script. I'm doing basically the same thing as RK described in #8, but I am not experiencing the problems he or she described.

David Planella (dpm) wrote :

This seems to be an old bug. Does it still affect Precise?

Changed in ubuntu-translations:
status: Triaged → Incomplete

Yes, kimpanel cannot use anymore on Precise.

Ma Hsiao-chun (mahsiaochun) wrote :

Hi, all.

I just wonder how to make ibus work on 12.04, KDE anyway?

I once considered Kimpanel approach.
But I haven't found alternative ibus panel needed by Kimpanel.

tags: added: kubuntu
Aron Xu (happyaron) on 2012-06-21
Changed in ubuntu-translations:
status: Incomplete → Invalid
Jonathan Riddell (jr) on 2012-07-26
Changed in kdeplasma-addons (Ubuntu):
milestone: none → ubuntu-12.10-beta-1
Changed in kdeplasma-addons (Ubuntu Quantal):
milestone: ubuntu-12.10-beta-1 → ubuntu-12.10-beta-2
Jonathan Riddell (jr) on 2012-09-10
Changed in kdeplasma-addons (Ubuntu Quantal):
milestone: ubuntu-12.10-beta-2 → none
Dennis Schridde (devurandom) wrote :

I think it is still broken in Ubuntu 12.04.

Dennis Schridde (devurandom) wrote :

I cannot figure out how to add Ubuntu Precise (12.04) as an affected distribution. Can someone else please add it?

Adolfo Jayme (fitojb) on 2014-01-11
no longer affects: ubuntu-translations
no longer affects: kdeplasma-addons (Ubuntu Quantal)
summary: - KIMPanel is unusable in Kubuntu 9.10
+ KIMPanel is unusable
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers