KDE Microblogs plasmoid does not show friend timelines nor public timeline

Bug #414572 reported by Efrain Valles on 2009-08-16
82
This bug affects 11 people
Affects Status Importance Assigned to Milestone
kdeplasma-addons (Ubuntu)
High
Harald Sitter
Karmic
High
Harald Sitter

Bug Description

SRU Documentation:

The KDE micro blogging plasmoid in Karmic does not display friend timelines due to an issue in a Kubuntu specific patch. This renders the plasmoid mostly useless and presents a reduction of upstream code quality.

The issue was resolved by fixing a wrongly changed if condition (one case got lost in the process of patching, unfortunately the one responsible for showing friend timelines).

Steps to reproduce the issue:
* Install stock plasma-widgets-addons and plasma-dataengines-addons from Karmic
* Add the microblog widget to a Plasma shell
* Configure the widget to either use identi.ca or Twitter
* Only own timeline will be shown (expected: show friend's and own timeline , unless appropriate setting was unselected in the configure dialog)

This change does not pose any regression potential. The patch only enhances the possible conditions of the affected control structure.

-----------
The KDE microBloggin plasmoid in Karmic Alpha 4 does not display friend timelines and public timelines. The only dents and tweets currently diplayed are those of the user.

the steps to reproduce:

1) Click on the neswpaper tab
2) Add the "Microblogs" Widget
3) configure the account
4) update the timeline

only the user posts are displayed.

What should happen:

The timelines of friends should be displayed along with the user's posts. this is the behaviour of the KDETwitter widget

plasma-netbook:
  Instalados: 0.0~svn1007436-0ubuntu4
  Candidato: 0.0~svn1007436-0ubuntu4
  Tabla de versión:
 *** 0.0~svn1007436-0ubuntu4 0
        500 http://ve.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

Description: Ubuntu karmic (development branch)
Release: 9.10

Michael Ummels (urmel291) wrote :

I can confirm this bug. The plasmoid would be much more useful if it includes friend and public timelines.

Changed in plasma-netbook (Ubuntu):
status: New → Confirmed
affects: plasma-netbook (Ubuntu) → kdeplasma-addons (Ubuntu)
Changed in kdeplasma-addons (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-9.10-beta
D. Wegener (dpwegener) wrote :

This looks to be a problem with the binary build. I tried to debug this problem using gdb. The source code for the package doesn't match the plasma_applet_microblog.so and plasma_engine_microblog.so from the binary packages. Manually building from source produces libraries that work.

angalad (angalad) wrote :

I can confirm this bug too. If the fix is as easy as pointed by D. Wegener, it would be nice to update the packages so there is no need to manually building.
By the way, the repository I'm using is deb http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu jaunty main
(to get KDE 4.3.1 on Jaunty as seen in http://www.kubuntu.org/news/kde-4.3.1 ).

D. Wegener (dpwegener) wrote :

After performing an apt-get -compile on the source package, the resulting plasma-widgets-addons deb package contains a plasma_applets_microblog.so that doesn't work. The packaged library has been stripped as part of the package build process. However, the shared library built in the output directory of the compile works correctly. The difference between these would seem to the stripping process that removes the debug info from the shared libraries. Perhaps, there is something not defined properly for the stripping of this library.

Confirmed. Trunk in Gentoo showed friend updates as well, but the binary Kubuntu version doesn't, even with the, "Show friends' updates" checkbox ticked.

Efrain Valles (effie-jayx) wrote :

this bug can still be reproduced in Kubuntu 9.10 Karmic Beta

D. Wegener (dpwegener) wrote :

Additional information. It seems to have something to do with the kubuntu_02_microblog_default_configuration.diff. This diff appears in revision 29 of the lp:~kubuntu-members/kdeplasma-addons/ubuntu branch. The following code in the downloadHistory method was changed:
+- if (m_includeFriends) {
+- query = QString("TimelineWithFriends:%1@%2");
+- } else {
+ query = QString("Timeline:%1@%2");
+ }

The new code is:
++ if (m_password.isEmpty()) {
++ query = QString("NoAuth:%1@%2");
++ } else if ( m_includeFriends ) {
+ query = QString("Timeline:%1@%2");
+ }

The result is that an empty password results in a NoAuth query, If Include Friends is checked, the query is Timeline when it should be TimelineWithFriends. If Include Friends isn't checked, then no query is set.

The code should probably be changed to:
++ if (m_password.isEmpty()) {
++ query = QString("NoAuth:%1@%2");
++ } else if ( m_includeFriends ) {
+ query = QString("TimelineWithFriends:%1@%2");
+- } else {
+ query = QString("Timeline:%1@%2");
+ }

There also seems to be a bug in setting the Configure... button state. It isn't being cleared. The setAuthRequired method seems to be used to turn this button on and off. My best guess is that the method should be called in the dataUpdated method when the update query was successful.

Changed in kdeplasma-addons (Ubuntu):
milestone: ubuntu-9.10-beta → ubuntu-9.10
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdeplasma-addons - 4:4.3.2-0ubuntu3

---------------
kdeplasma-addons (4:4.3.2-0ubuntu3) karmic; urgency=low

  * Update kubuntu_02_microblog_default_configuration.diff, fix
    setting of when applet needs configuration and fix downloading of
    authenticated accounts timelines. Closes LP: #414572 (also
    https://bugs.kde.org/200475)

 -- Jonathan Riddell <email address hidden> Mon, 12 Oct 2009 14:05:24 +0100

Changed in kdeplasma-addons (Ubuntu):
status: Confirmed → Fix Released
D. Wegener (dpwegener) wrote :

The fix does not solve the problem of missing friend tweets. The wrong query string is still being used in the downloadHistory method in microblog.cpp. The code should look something like this.
if (m_password.isEmpty()) {
    query = Qstring("NoAuth:%1@2");
} else if (m_includeFriends) {
    query = QString("TimelineWithFriends:%1@2");
} else {
    query = QString("Timeline:%1@2");
}

D. Wegener (dpwegener) on 2009-10-17
Changed in kdeplasma-addons (Ubuntu Karmic):
status: Fix Released → Incomplete
Nicolas Réau (kolia) wrote :

It's been corrected in this revision: http://websvn.kde.org/?view=rev&revision=1036051 (16 october)

See https://bugs.kde.org/200475, it was actually not fixed in 4.3 branch, now it is.

Hopefully it will be packaged for Karmic!

--
Bou

D. Wegener (dpwegener) wrote :

It would really be nice for this bug to be fixed prior to the release of Karmic. Kubuntu Karmic is being advertised as social from the start. The twitter support is a integral part of Kubuntu. I've posted the code that fixes the problem a couple of times. Can someone give me some advice on how I can get the fixed code included in the Karmic kdeplasma_addons package. The file that needs to be changed is 02_microblog_default_configuration.diff. The query string in the Microblog::downloadHistory method isn't getting set properly. Currently, the only query strings that are ever set are "NoAuth:" and "Timeline:". The "Timeline:" string is getting set incorrectly. It is getting set after a check to see if include friends is turned on. The correct string for include friends is "TimelineWithFriends:".

As mentioned, the current code only sets one of two strings. No query string is set if include friends is not selected in the configuration. This was the cause of a plasma desktop crash that has since been addressed in the base KDE source. That fix prevented the crash, but had no effect on the display of friend tweets.

Steve Langasek (vorlon) wrote :

D. Wegener,

Sorry, but it's now too late for this bug to be fixed before the 9.10 release. It looks like this is something that would be good to have fixed in SRU, however. Please follow the processes described at https://wiki.ubuntu.com/SponsorshipProcess and https://wiki.ubuntu.com/StableReleaseUpdates if you would like to move this forward.

Changed in kdeplasma-addons (Ubuntu Karmic):
milestone: ubuntu-9.10 → karmic-updates
Martin Pitt (pitti) on 2009-10-27
Changed in kdeplasma-addons (Ubuntu Karmic):
status: Incomplete → In Progress
assignee: nobody → Jonathan Riddell (jr)
D. Wegener (dpwegener) wrote :

I think I'm starting to figure this package thing out a little. I've created a debdiff for the fix. I also have an updated 02_microblog_default_configuration.diff. I'm not sure whether one or both are needed to address the fix, so I'll attach both.

D. Wegener (dpwegener) wrote :
Zaar Hai (haizaar) wrote :

Good day! What is the progress of this bug? Will it arrive to Karmic updates any soon?

Thanks,

goto (gotolaunchpad) wrote :

Updated to KDE 4.3.3 on Karmic from http://ppa.launchpad.net/kubuntu-ppa/ppa/ubuntu it still doesn't seem to be fixed! Pleeease....

Changed in kdeplasma-addons (Ubuntu):
assignee: Jonathan Riddell (jr) → Harald Sitter (apachelogger)
Changed in kdeplasma-addons (Ubuntu Karmic):
assignee: Jonathan Riddell (jr) → Harald Sitter (apachelogger)
Changed in kdeplasma-addons (Ubuntu):
milestone: karmic-updates → ubuntu-10.04
Harald Sitter (apachelogger) wrote :

Fix for 4.3.3 (PPA) waiting for build, moving on to Lucid.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdeplasma-addons - 4:4.3.2-0ubuntu6

---------------
kdeplasma-addons (4:4.3.2-0ubuntu6) lucid; urgency=low

  * Update kubuntu_02_microblog_default_configuration.diff fix
    patched if conditions to properly retrieve friend tweets.
    Closes LP: #414572
 -- David Wegener <email address hidden> Tue, 27 Oct 2009 20:56:53 -0500

Changed in kdeplasma-addons (Ubuntu):
status: In Progress → Fix Released
description: updated
Efrain Valles (effie-jayx) wrote :

Anyway we can have this ported to karmic. It is very early in the release and it is a shame not to be able to use this fine plugin.

Jonathan Riddell (jr) wrote :

Many thanks for the fix.

Uploaded to karmic-proposed, awaiting approval.

Accepted into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in kdeplasma-addons (Ubuntu Karmic):
status: In Progress → Fix Committed
tags: added: verification-needed
Victor C. (victorious-cheng) wrote :

Seems to work -- I can see my friends now.

There is still the issue that when you post, it marks your post as coming from the web, rather than "KDE Twitter," which is what it used to be...but I suppose this is a separate bug?

It works for me!

Great!

2009/11/23 Victor C. <email address hidden>

> Seems to work -- I can see my friends now.
>
> There is still the issue that when you post, it marks your post as
> coming from the web, rather than "KDE Twitter," which is what it used to
> be...but I suppose this is a separate bug?
>
> --
> KDE Microblogs plasmoid does not show friend timelines nor public timeline
> https://bugs.launchpad.net/bugs/414572
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “kdeplasma-addons” package in Ubuntu: Fix Released
> Status in “kdeplasma-addons” source package in Karmic: Fix Committed
>
> Bug description:
> SRU Documentation:
>
> The KDE micro blogging plasmoid in Karmic does not display friend timelines
> due to an issue in a Kubuntu specific patch. This renders the plasmoid
> mostly useless and presents a reduction of upstream code quality.
>
> The issue was resolved by fixing a wrongly changed if condition (one case
> got lost in the process of patching, unfortunately the one responsible for
> showing friend timelines).
>
> Steps to reproduce the issue:
> * Install stock plasma-widgets-addons and plasma-dataengines-addons from
> Karmic
> * Add the microblog widget to a Plasma shell
> * Configure the widget to either use identi.ca or Twitter
> * Only own timeline will be shown (expected: show friend's and own timeline
> , unless appropriate setting was unselected in the configure dialog)
>
> This change does not pose any regression potential. The patch only enhances
> the possible conditions of the affected control structure.
>
>
> -----------
> The KDE microBloggin plasmoid in Karmic Alpha 4 does not display friend
> timelines and public timelines. The only dents and tweets currently diplayed
> are those of the user.
>
> the steps to reproduce:
>
> 1) Click on the neswpaper tab
> 2) Add the "Microblogs" Widget
> 3) configure the account
> 4) update the timeline
>
> only the user posts are displayed.
>
> What should happen:
>
> The timelines of friends should be displayed along with the user's posts.
> this is the behaviour of the KDETwitter widget
>
> plasma-netbook:
> Instalados: 0.0~svn1007436-0ubuntu4
> Candidato: 0.0~svn1007436-0ubuntu4
> Tabla de versión:
> *** 0.0~svn1007436-0ubuntu4 0
> 500 http://ve.archive.ubuntu.com karmic/main Packages
> 100 /var/lib/dpkg/status
>
> Description: Ubuntu karmic (development branch)
> Release: 9.10
>
>
>

--
Antonio José García Lagar
http://aj.garcialagar.es
<email address hidden>

Martin Pitt (pitti) on 2009-11-23
tags: added: verification-done
removed: verification-needed
Zaar Hai (haizaar) wrote :

Works for me as well! Thank you very much!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdeplasma-addons - 4:4.3.2-0ubuntu5.1

---------------
kdeplasma-addons (4:4.3.2-0ubuntu5.1) karmic-proposed; urgency=low

  * Update kubuntu_02_microblog_default_configuration.diff fix
    setting of query string to properly retrieve friend tweets.
    Closes LP: #414572
 -- David Wegener <email address hidden> Tue, 27 Oct 2009 20:56:53 -0500

Changed in kdeplasma-addons (Ubuntu Karmic):
status: Fix Committed → Fix Released
Apoorv Parle (apparle) wrote :

You guys are great.........

A simple 'sudo apt-get upgrade' and all problems solve themselves

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers