Ubuntu

akonadi_mailfilter_agent eats 100% CPU and RAM and then crashes

Reported by Scott Kitterman on 2012-04-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KDE PIM
Fix Released
Medium
Release Notes for Ubuntu
Undecided
Unassigned
kdepimlibs (Ubuntu)
High
Scott Kitterman
Precise
High
Scott Kitterman
Quantal
High
Scott Kitterman
Raring
High
Scott Kitterman

Bug Description

If the user's agent_config_akonadi_mailfilter_agent_changes.dat gets corrupted, the mailfilter_agent becomes unusable. There is, however, a way to recover from this.

RELEASE NOTE:

The new version of the KDE PIM component Kmail in 12.04 introduced a new element to handle mail filtering. In some cases the configuration information for this element, akonadi_mailfilter_agent, can get corrupted. If this happens, the akonadi_mailfilter_agent will stop filtering mail (e.g. messages already sent stay in the outbox) and start to consume large amounts of CPU and RAM. Enough that the entire system may become sluggish. Eventually it usually crashes (and will crash again if restarted). In order to fix this problem, the corrupt configuration file has to be removed (it will be automatically regenerated when things are started again). To accomplish this do the following steps:

1. open a terminal window (using konsole for Kubuntu, other applications for other flavors).
2. cd ~/.config/akonadi
3. akonadictl stop
4. wait until you get a notification that akonadi is fully stopped
5. rm agent_config_akonadi_mailfilter_agent_changes.dat (this removes the corrupt file)
6. akonadictl start

That should restore correct behavior

Created attachment 70435
Corrupted .dat file

Using master.

I suppose the issue appeared because of a short power outage.

The symptoms:
- The mailfilter agent was using 50% cpu after restart,
- The memory usage keeps increasing
- The mailfilter agent appears offline in akonadiconsole (despite having Online=true in agent_config_akonadi_mailfilter_agent)
- The resource doesn't react to dbus calls.

Renaming agent_config_akonadi_mailfilter_agent_changes.dat fixed the issue.
and the issue is back as soon as the corrupted file is restored.

*** Bug 298121 has been marked as a duplicate of this bug. ***

From bug 298121:

Efter logging into KDE4 my system becomes sluggish for at least 10 - 15 minutes. The problem seems to be that akonadi_agent_launcher claims 1.7GB of my 2GB memory.
During the first minute after login akonadi_agent_launcher rapidly claims more and more RAM until 85-90% of my RAM is consumed. During these 10-15 minutes my hard disk is frantically active and my system is in practice not usable.

The parent process to akonadi_agent_launcher is akonadi_control.

--

Deleting the concerned .dat file fixed the issue for the reporter

*** Bug 298626 has been marked as a duplicate of this bug. ***

From bug 298626
-- Information about the crash:
- What I was doing when the application crashed:

My system was completely frozen due to a kernel panic, so I manually powered it down and started again. After boot, I got this crash, restarted the mailfilter_agent, and then got it again.

I saw something similar after upgrading from KDE 4.7 to 4.8. I suspect some kind of data corruption or unexpected condition causes mailfter_agent to crash. When this happened before, it took deleting all the local data and then re-importing it to get mailfilter_agent to work again.

---

Deleting the concerned .dat file also fixed the issue for the reporter.

Changed in kdepim:
importance: Unknown → Undecided
status: Unknown → New
importance: Undecided → Unknown
status: New → Unknown

akonadi_mailfilter_agent is shipped as part of kmail, so I think the product is wrong on this bug.

no, the trick above worked also for other Akonadi resources

Changed in kdepim:
importance: Unknown → Medium
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kdepim (Ubuntu):
status: New → Confirmed
Robajz.info (robert-sevcik) wrote :

Yes, same here with kdepim 4:4.8.2-0ubuntu2, updated today. Removing the corrupt file fixed the problem.

Should be fixed in 4.9.3 with commit b927825 (in kdepimlibs)

Changed in kdepim:
status: Confirmed → Fix Released
Changed in kdepim (Ubuntu Raring):
status: Confirmed → Triaged
Changed in kdepim (Ubuntu Quantal):
status: New → Triaged
Changed in kdepim (Ubuntu Precise):
status: New → Triaged
milestone: none → ubuntu-12.04.2
Changed in kdepim (Ubuntu Quantal):
milestone: none → quantal-updates
Changed in kdepim (Ubuntu Raring):
milestone: none → ubuntu-13.04-beta-1
Changed in kdepim (Ubuntu Precise):
importance: Undecided → High
Changed in kdepim (Ubuntu Quantal):
importance: Undecided → High
Changed in kdepim (Ubuntu Raring):
importance: Undecided → High
assignee: nobody → Scott Kitterman (kitterman)
Changed in kdepim (Ubuntu Quantal):
assignee: nobody → Scott Kitterman (kitterman)
Changed in kdepim (Ubuntu Precise):
assignee: nobody → Scott Kitterman (kitterman)
affects: kdepim (Ubuntu Raring) → kdepimlibs (Ubuntu Raring)
Scott Kitterman (kitterman) wrote :

Fixed in 4.9.3.

Changed in kdepimlibs (Ubuntu Raring):
status: Triaged → Fix Released
Changed in kdepimlibs (Ubuntu Quantal):
status: Triaged → Fix Committed
Changed in kdepimlibs (Ubuntu Raring):
milestone: ubuntu-13.04-beta-1 → ubuntu-13.04-alpha-1
Scott Kitterman (kitterman) wrote :

Fixed in 4.9.3 released to quantal-updates.

Changed in kdepimlibs (Ubuntu Quantal):
status: Fix Committed → Fix Released
Colin Watson (cjwatson) on 2013-02-13
Changed in kdepimlibs (Ubuntu Precise):
milestone: ubuntu-12.04.2 → ubuntu-12.04.3
Pete Graner (pgraner) on 2013-04-22
Changed in ubuntu-release-notes:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.