Kmail folders error

Bug #979211 reported by Julien Aubin on 2012-04-11
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
kdepim (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

I have a POP account with KMail 2. Actually since Ubuntu precise 12.04 this component is completely broken. When fetching emails I get the message : "Unable to store downloaded mail. Unknown error (Append failed)", and I can't receive any email. And when I open Kmail I get the following message : "Kmail Folders: Unknown error (NO PartHelperException: Failed to update database record)".

When I click a message Kmail hangs on "retrieving folder content" message, with nothing happening.

Could you please fix it ASAP, since this bug looks like a showstopper to me for release ?

Rgds

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: kmail 4:4.8.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Uname: Linux 3.2.0-23-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu1
Architecture: i386
Date: Wed Apr 11 20:28:49 2012
ProcEnviron:
 LANGUAGE=
 TERM=xterm
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: kdepim
UpgradeStatus: Upgraded to precise on 2012-04-11 (0 days ago)

Julien Aubin (gojulgarbmail) wrote :
Julien Aubin (gojulgarbmail) wrote :

Okay I've found a workaround for the issue :
0/ Backup your user account !!!
1/ Stop Akonadi, Kontact, and the MySQL process launched by Akonadi.
2/ rm -rf ~/.config/akonadi
3/ rm -rf ~/.local/share/akonadi
4/ Restart Kontact
5/ Reconfigure the apps so that they correctly point to the folders and files where the data is.

Anyway this is not suitable in a production environment, and the fix should be done. I point that the error occured after an upgrade from Oneiric.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kdepim (Ubuntu):
status: New → Confirmed
m4v (m4v) wrote :

I got this after an upgrade of Oneric with kubuntu-backports ppa.

The workaround works, at first I saw all my mail folders empty, after restarting my session akonadi sync'd my email folders. Looks like I got back most of my emails, but one folder has all its emails with "no subject" and "unknown" addresses, and no content, so I probably lost a folder worth of emails.

This shouldn't hit Precise, for all I care, there's data loss.

I also got this after upgrading to oneiric.

I removed the imap resource from akonadi and added it again.
The error message changed to "Unknown Resource" when fetching mails. Also, the akonadi self test revealed that the mysql performance tables had the wrong structure. So it seemed that mysql has also been updated and akonadi didn't like that.

I stumbled upon http://forum.kde.org/viewtopic.php?f=215&t=101004&view=unread which finally solved the issue:
Edited ~/.local/share/akonadi/mysql.conf and add "binlog_format=row" to the first [mysqld] section.
After restarting mysql and akonadi everything worked again.

The workaround worked for me too

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers