Ubuntu

kontact migration to 11.10 fails

Reported by Tom Chiverton on 2011-09-23
138
This bug affects 25 people
Affects Status Importance Assigned to Milestone
KDE PIM
Fix Released
Medium
kdepim (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

After upgrading to 11.10 beta 2, I got a message saying migration failed when trying to start Kontact. It suggested I should try kmail-migrator but:
$ kmail-migrator --interactive
kmail-migrator(5811) main: Migration of kmailrc has already run, not running it again

And trying to start kmail directly (presumably with none of my data) give me a tip of the day and then "KMail encoutered a fatal error and will terminate now. The error was: Failed to fetch the resource collection".

I have backups of my mail and contacts, but if the migration has failed for my very basic and unmodified usage, it probably needs to be looked at.

Download full text (6.6 KiB)

Starting Kmail from Konsole says :
falken@wopr:~/.kde$ kmail
"/usr/bin/kmail(7609)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(7609)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(7609)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(7609)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(7609)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(7609)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(7609)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(7609)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(7609)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(7609)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(7609)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(7609)" Soprano: "Invalid iterator."
"/usr/bin/kmail(7609)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(7609)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(7609)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(7609)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(7609)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(7609)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(7609)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(7609)" Soprano: "Invalid iterator."
"/usr/bin/kmail(7609)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(7609)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(7609)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(7609)" Soprano: "QLocalSocket::connectToServer: Invalid name"
falken@wopr:~/.kde$ "/usr/bin/kmail(7609)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(7609)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(7609)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail...

Read more...

I can get Kmail to start by going into Akondi Console, double clicking 'Local Folders' which has an 'identifier' of akonadi_maildir_resource_0 and filling in the empty path with ~/.kde/share/apps/kmail/mail/

Note sure where my IMAP folders have gone.

Kaddressbook started stand alone doesn't appear to find any of the people in either 'std.vcf' source (/home/falken/.kde/share/apps/kabc/std.vcf) or 'personal contacts' (/home/falken/.local/share/contacts/) identified by Akondi Konsole.

Akregator (started standalone) does appear to have migrated OK.

I went into 'Desktop Search' and turned on 'Nepomuk Semantic Desktop', and the error messages reduced in number, but still no IMAP folders migrated and no addressbook entires:
falken@wopr:~/.kde$ kmail
"/usr/bin/kmail(9125)" Soprano: "org.freedesktop.DBus.Error.UnknownObject - No such object path '/org/soprano/Server'"
"/usr/bin/kmail(9125)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(9125)" Soprano: "org.freedesktop.DBus.Error.UnknownObject - No such object path '/org/soprano/Server'"
"/usr/bin/kmail(9125)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(9125)" Soprano: "org.freedesktop.DBus.Error.UnknownObject - No such object path '/org/soprano/Server'"
"/usr/bin/kmail(9125)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(9125)" Soprano: "org.freedesktop.DBus.Error.UnknownObject - No such object path '/org/soprano/Server'"
"/usr/bin/kmail(9125)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(9125)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(9125)" Soprano: "Invalid iterator."
"/usr/bin/kmail(9125)" Soprano: "org.freedesktop.DBus.Error.UnknownObject - No such object path '/org/soprano/Server'"
"/usr/bin/kmail(9125)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(9125)" Soprano: "org.freedesktop.DBus.Error.UnknownObject - No such object path '/org/soprano/Server'"
"/usr/bin/kmail(9125)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(9125)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(9125)" Soprano: "Invalid iterator."
falken@wopr:~/.kde$ "/usr/bin/kmail(9125)" Soprano: "org.freedesktop.DBus.Error.UnknownObject - No such object path '/org/soprano/Server'"
"/usr/bin/kmail(9125)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(9125)" Soprano: "org.freedesktop.DBus.Error.UnknownObject - No such object path '/org/soprano/Server'"
"/usr/bin/kmail(9125)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(9125)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(9125)" Soprano: "Invalid iterator."
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /home/falken/.config/ibus/bus

No idea what Soprano is or if it's important. Any hints ?

At login I get a popup that says 'nepomuk indexing disabled ... the following problems were detected: calling the nepomuk storage service failed: The name org.kde.nepomukstorage was not provided by any .service failes'.

falken@wopr:/tmp$ akonadictl status
Akonadi Control: running
Akonadi Server: running
Akonadi Server Search Support: not available
falken@wopr:/tmp$

It appears my outgoing mail and identity settings are converted, but all my per-folder and IMAP-related settings are gone, as is whatever makes correctly set up addressbooks fail to list anyone.

These grey'ed messages do not appear when I look at the same IMAP account over webmail

Some of the grey ones have now vanished, and some newly deleted email stays behind as grey'ed out rather than vanishing.
There seems to be no pattern as to which stay and which don't.

One folder had only 1 item in it, and it was grey (and I recall deleting it) but Kmail still showed a blue "(1)" as if it was a new message.

So it seems something is very out of sync somehow

See https://bugs.kde.org/show_bug.cgi?id=276853 for another report of random grey entries in message list.

My filters were not migrated either, it turns out.
Is there a log file somewhere ? Or something I can check to verify what KDE things it has and has not migrated ?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kdepim (Ubuntu):
status: New → Confirmed

Same here, for everything reported on this bug. So far, it's been a total disaster for kmail upgrading to oneiric. The "Failed to fetch the resource collection" seems to affect everyone until you blow away the akonadi config.

+1 for 'total disaster'.

Even after removing and adding the address book sources, neither show up in kadddressbook. That and the 'inbox full of grey deleted message' and 'keep getting pointless conflict prompts' bugs mean I don't feel kmail2 should be inflicted on the masses yet.

m4v (m4v) wrote :

Kmail did import my inbox mail, but not the mails I archive on my other folders. If I look in ~/.kde/share/apps/kmail/mail I can't find any files in them. Lost like 5 years of mail.

m4v (m4v) wrote :

Or so I thought, I copied ~/.kde/share/apps/kmail/mail to ~/mail.bak, and then manually importing them with "kmail folder structure" importer seems to be working in getting back all my stuff.

Version: unspecified (using KDE 4.7.1)
OS: Linux

Migration in Kmail2 failed After update from KDE 4.6.5 to 4.7.1.

Reproducible: Didn't try

Actual Results:
When Kmail2 started first time after update there was error message about failed migration and that need to run "kmail-migrator --interactive" manually.

But when running "kmail-migrator --interactive" I got error message:
Migration of kmailrc has already run, not running it again

I restored backup of ~/.kde and figured out that if run "kmail-migrator --interactive" before first start Kmail2 then migration will be successful.
But if Kmail2 started first then migration will be failed.

Expected Results:
Migration should work when starting Kmail2.

Before update to KDE 4.7.1 I have Kmail 1.13.7 installed with KDE 4.6.5.

Looks like the same problem also in KDE 4.7.2.

Ok and what is the error ????
it's failed ok
but why it failed ?

Created attachment 64384
Kresource Migration Tool

When KDE 4.7.1 started firest time after update opened window "Kresource Migration Tool" with message that Migration of 'resource' succeeded.

Created attachment 64385
KMail Migration

When I started Kmail "Kmail Migration" opened and I pressed "Migrate Now"

Created attachment 64386
Migration Failed

Then appeared this window with error message:
Migration to Kmail 2 failed. In case you want to try again , run 'kmail-migrator --interactive' manually.

But when I tried this command there was message:
Migration of kmailrc has already run, not running it again

And I can reproduce this every time when using saved .kde dir.

it doesn't give me info about failed :)

(In reply to comment #6)
> it doesn't give me info about failed :)

If you tell me what additional information needed and how can I get it then I can provide it here.

So when I running kmail from command line I got this:

$ kmail
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
kmail-migrator(28579) main: Migration of kmailrc has already run, not running it again
kmail2(28576): Akonadi migration failed!
kmail2(28576): command was: ("/usr/bin/kmail-migrator", "--interactive-on-change")
kmail2(28576): exit code: 4
kmail2(28576): stdout: ""
kmail2(28576): stderr: ""

Leo Milano (lmilano) wrote :

Same here. I lost all my email settings. The migration failed in the first login after the upgrade. I got a pop up asking me to run "kmail-migrator --interactive" manually. But if I do, I get the following error:

lmilano@grisell:config$ kmail-migrator --interactive
kmail-migrator(9148) main: Migration of kmailrc has already run, not running it again

removing kmail2rc doesn't help. Quite a showstopper for new users!

Clay Weber (claydoh) wrote :

Delete your ~/.kde/share/config/kmail-migratorrc file, and try running the migrator again. The presence of this file is what prevents it from running again.

Leo Milano (lmilano) wrote :

Thanks, Clay! I removed ~/.kde/share/config/kmail-migratorrc and re-ran "kmail-migrator --interactive". This time I got a the migration tool to complete and show a "succeeded" check mark at the end. The command line showed some errors or warnings. The message notification widget showed a bunch of errors about the different email folders I have, and the 3 cores in the desktop have been churning for 10 minutes, apparently importing my emails (I have email back to 1995 in this machine) into the different email folders I used to have. I will report again when it finishes up.

Below are some typical errors shown in the terminal.
Thanks!
-- Leo

"/usr/bin/kmail-migrator(22850)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail-migrator(22850)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail-migrator(22850)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail-migrator(22850)" Soprano: "Unsupported operation (2)": "Invalid model"
kmail-migrator(22850)/kdeui (Wallet): The kwalletd service has been disabled
kmail-migrator(22850)/kdeui (Wallet): The kwalletd service has been disabled
kmail-migrator(22850)/kdeui (Wallet): The kwalletd service has been disabled

Changed in kdepim:
importance: Unknown → Medium
status: Unknown → New
Leo Milano (lmilano) wrote :

So, here is a summary of the migration (see comment #18 above):

• it completed successfully after a long time (more than one hour for about 20k emails on a 3core fast desktop)
• it added a new IMAP Google account/folder I didn’t have and seemed to slow things down significantly
• it created some Local Folders (besides KMail folders) and placed a few of my “Inbox” emails in the Local Folders’ Inbox. The rest stayed in the right Inbox within “KMail Folders”. This is probably a result of the first failed migration
• I used to have Kontact to autostart on login. I wonder if, after distro upgrade, Kontact started before akonadi and the original migration failed because of that
• KWallet was disabled and that created also lots of errors/grief. I ran KWallet from the menu and activated it for use with KDE. After that, password management got smoother (without that, the second migration worked, but I would have to retype each account’s password after each login to KDE)

Hope this helps!
Leo

KMail write Version=1 to kmail-migratorrc before start kmail-migrator

(In reply to comment #9)
> KMail write Version=1 to kmail-migratorrc before start kmail-migrator

And then kmail-migrator fails because of this commit

https://projects.kde.org/projects/kde/kdepim-runtime/repository/revisions/db0c79245cec967f5af1c94f62ae377dd0eb81a4

Good catch. So I take it that KMail is broken and needs to be fixed (by removing 1 line?), right?

ArdyFalls (afalls) wrote :
Download full text (4.3 KiB)

I deleted the kmail-migratorrc file and ran kmail-migrator --interactive. After doing that kmail still fails... here is the output
"/usr/bin/kmail(6532)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(6532)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(6532)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(6532)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(6532)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(6532)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(6532)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(6532)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(6532)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(6532)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(6532)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(6532)" Soprano: "Invalid iterator."
"/usr/bin/kmail(6532)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(6532)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(6532)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(6532)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(6532)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(6532)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(6532)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(6532)" Soprano: "Invalid iterator."
"/usr/bin/kmail(6532)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(6532)" Soprano: "QLocalSocket::connectToServer: Invalid name"
Object::connect: No such slot KMMainWidget::slotItemNotMovedByFilters( Akonadi::Item )
"/usr/bin/kmail(6532)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(6532)" Soprano: "QLocalSocket::connectToServer: Invalid name"
ardy@earth:~/.config/akonadi$ "/usr/bin/kmail(6532)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(6532)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmai...

Read more...

Created attachment 64509
kdepim-4.7.2-alt-migration.patch

fixes the problem

No it's not good this patch.
You don't want to migrate => you wrote it.

With your patch you can't say no.

So it(s not good.

Created attachment 64515
kdepim-4.7.2-alt-migration.patch

'("Enabled", false)' may be changed to '("Version", targetVersion)' in first hunk

> '("Enabled", false)' may be changed to '("Version", targetVersion)' in first
> hunk

Yes, I think you should change that. When/if there will be another migration of this kind needed, the user might want THAT migration to happen.

Created attachment 64523
kdepim-4.7.2-kmail-migration.patch

This version of the patch disables only this migration permanently and not future ones (with new target versions.)

That said, I'm not convinced that that hunk is correct in the first place. Does a user really expect a "no" to be permanent? I'd expect it to be a "Not now", not a "Never".

(That said, getting prompted again and again with no way to opt out would also be an annoyance, so I guess distros looking for a quick fix should use my patch from comment #16.)

By the way, the commit which caused this regression is this commit by David Faure:
https://projects.kde.org/projects/kde/kdepim-runtime/repository/revisions/60f8c01542f86bd04cafd68b91c2f609d73d4aa2
which added the check preventing running the migration manually when it was already run.

Terry Coles (lp-hadrian-way) wrote :

Well I can add to the cacophony of failure. I downloaded the full release of 11.10 yesterday and immediately got most of the errors that others have seen above. I currently have no email, but can get Contacts. Also, for some reason I cannot get my calendar to work either.

Unless someone has a fix for this pretty darn quick, I'm going to have to seriously consider a clean installation. Since that will mean me recreating all of my accounts, aliases and filters, I am thinking hard about moving to another package, like Thunderbird or Evolution. At the moment, it is mainly Kontact that has kept me with Kubuntu, so the end result of all this might well be (another) lost Kubuntu user.

*Please*; if anyone can offer any hope for a fix in the near future, please say now.

Sorry to rant on, but the decision to leave this bug in the full release was foolhardy in the extreme. It could be very serious for Kubuntu if many others have the same problem as the rest of the people on this list.

Perhaps it's time for radical thought and considering the provision of a roll-back solution?

I did recreate everything from scratch in Kontact.
Still have no auto complete in the mail composer, and an inbox full of grey, non selected, deleted ghosts of messages.

Not release ready. Obvious bugs. Makes you wonder who's been dog fooding this before it went to beta, and why feedback from the beta didn't set alarm bells ringing doesn't it ?

I tested patch from comment #16.
Migration works as expected.

Terry Coles (lp-hadrian-way) wrote :

OK. Things are a little better since I found this: https://wiki.kubuntu.org/OneiricOcelot/Final/Kubuntu/Kmail2. I had to jump through hoops to stop Kontact exiting after the error, but once I was in, I was able to import all my mail manually. However, I spent most of yesterday evening doing it instead of doing something useful (or fun).

I hope that the link and my experience will help people who find their way to this bug, but I have to say again that I suspect there will be legions of people who just give up and move to another suite, like I almost did.

This problem needs fixing fast!

Leo Milano (lmilano) wrote :
Download full text (6.4 KiB)

I just had another crash. Even though I had some success with the migration, KMail sometimes freezes, folders take a long time to refresh and show the contents of the emails, and this is the most recent crash (I will install the debug symbols). Soprano is disabled right now, as it tends to crash or apparently leak memory , and takes over my 3 cpus, although it's been indexing for days now).

Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f878f9787a0 (LWP 3309))]

Thread 4 (Thread 0x7f8770147700 (LWP 3358)):
#0 0x00007f878a8a004c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1 0x00007f8781c52c2c in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2 0x00007f8781c52d59 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3 0x00007f878a89befc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#4 0x00007f878ccf589d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#5 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f876f846700 (LWP 3360)):
#0 0x00007f878cce9773 in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1 0x00007f8785740f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2 0x00007f8785741429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3 0x00007f878d667f3e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4 0x00007f878d63bcf2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5 0x00007f878d63bef7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6 0x00007f878d55327f in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7 0x00007f878d555d05 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8 0x00007f878a89befc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#9 0x00007f878ccf589d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f876c814700 (LWP 3476)):
#0 0x00007f878cce9773 in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1 0x00007f8785740f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2 0x00007f8785741429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3 0x00007f878d667f3e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4 0x00007f878d63bcf2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5 0x00007f878d63bef7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6 0x00007f878d55327f in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7 0x00007f878d61ecbf in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8 0x00007f878d555d05 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9 0x00007f878a89befc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#10 0x00007f878ccf589d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#11 0x000...

Read more...

Leo Milano (lmilano) wrote :
Download full text (43.1 KiB)

And this is the standard output of the previous crash

lmilano@grisell:~$ kmail&
[1] 3308
lmilano@grisell:~$ "/usr/bin/kmail(3309)" Soprano: "org.freedesktop.DBus.Error.NoReply - Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."
"/usr/bin/kmail(3309)" Soprano: "QLocalSocket::connectToServer: Connection refused"
"/usr/bin/kmail(3309)" Soprano: "org.freedesktop.DBus.Error.UnknownObject - No such object path '/org/soprano/Server'"
Object::connect: No such slot KMMainWidget::slotItemNotMovedByFilters( Akonadi::Item )
"/usr/bin/kmail(3309)" Soprano: "SQLExecDirect failed on query 'sparql select * where { graph ?g { ?s <http://www.w3.org/1999/02/22-rdf-syntax-ns#type> <http://www.semanticdesktop.org/ontologies/2007/08/15/nao#Tag> . } . FILTER(?g != <http://www.openlinksw.com/schemas/virtrdf#>) . }' (iODBC Error: [OpenLink][Virtuoso iODBC Driver]CL064: Lost connection to server)"
"/usr/bin/kmail(3309)" Soprano: "SQLExecDirect failed on query 'sparql select * where { graph ?g { ?s <http://www.w3.org/1999/02/22-rdf-syntax-ns#type> <http://www.semanticdesktop.org/ontologies/2007/08/15/nao#Tag> . } . FILTER(?g != <http://www.openlinksw.com/schemas/virtrdf#>) . }' (iODBC Error: [OpenLink][Virtuoso iODBC Driver]CL064: Lost connection to server)"
"/usr/bin/kmail(3309)" Soprano: "SQLExecDirect failed on query 'sparql select * where { graph ?g { ?s <http://www.w3.org/1999/02/22-rdf-syntax-ns#type> <http://www.semanticdesktop.org/ontologies/2007/08/15/nao#Tag> . } . FILTER(?g != <http://www.openlinksw.com/schemas/virtrdf#>) . }' (iODBC Error: [OpenLink][Virtuoso iODBC Driver]CL064: Lost connection to server)"
"/usr/bin/kmail(3309)" Soprano: "SQLExecDirect failed on query 'sparql select * where { graph ?g { ?s <http://www.w3.org/1999/02/22-rdf-syntax-ns#type> <http://www.semanticdesktop.org/ontologies/2007/08/15/nao#Tag> . } . FILTER(?g != <http://www.openlinksw.com/schemas/virtrdf#>) . }' (iODBC Error: [OpenLink][Virtuoso iODBC Driver]CL064: Lost connection to server)"
"/usr/bin/kmail(3309)" Soprano: "Invalid iterator."
local socket error: QLocalSocket::PeerClosedError
kmail2(3309): Error while fetching items. 103 "Unknown error. (Unable to fetch item from backend)"
kmail2(3309): Error while fetching items. 103 "Unknown error. (Unable to fetch item from backend)"
kmail2(3309): Error while fetching items. 103 "Unknown error. (Unable to fetch item from backend)"
"/usr/bin/kmail(3309)" Soprano: "QLocalSocket::connectToServer: Connection refused"
"/usr/bin/kmail(3309)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(3309)" Soprano: "QLocalSocket::connectToServer: Connection refused"
"/usr/bin/kmail(3309)" Soprano: "QLocalSocket::connectToServer: Connection refused"
"/usr/bin/kmail(3309)" Soprano: "QLocalSocket::connectToServer: Connection refused"
"/usr/bin/kmail(3309)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided...

Leo Milano (lmilano) wrote :
Download full text (5.5 KiB)

And this is a new stack trace, now that I installed the debug symbols. By the way, folks, help here is appreciated, but venting is inappropriate. This is not a forum, but a bug tracker.

Thread 1 (Thread 0x7f878f9787a0 (LWP 3309)):
[KCrash Handler]
#6 deref (this=0x7f877f3c2bd8) at /usr/include/qt4/QtCore/qatomic_x86_64.h:133
#7 ~KSharedPtr (this=0x1a3a0c0, __in_chrg=<optimized out>) at ../../kdecore/util/ksharedptr.h:90
#8 ~ParsingData (this=0x1a3a0c0, __in_chrg=<optimized out>) at ../../kdecore/services/ktraderparse.cpp:40
#9 QThreadStorage<KTraderParse::ParsingData*>::deleteData (x=0x1a3a0c0) at /usr/include/qt4/QtCore/qthreadstorage.h:133
#10 0x00007f878d554107 in QThreadStorageData::set (this=0x4f55bb0, p=0x52369f0) at thread/qthreadstorage.cpp:165
#11 0x00007f878ee198a2 in qThreadStorage_setLocalData<KTraderParse::ParsingData> (d=<optimized out>, t=<optimized out>) at /usr/include/qt4/QtCore/qthreadstorage.h:92
#12 setLocalData (t=0x52369f0, this=<optimized out>) at /usr/include/qt4/QtCore/qthreadstorage.h:148
#13 KTraderParse::parseConstraints (_constr=...) at ../../kdecore/services/ktraderparse.cpp:55
#14 0x00007f878ee18e12 in applyConstraints (constraint=<optimized out>, lst=...) at ../../kdecore/services/kservicetypetrader.cpp:59
#15 KServiceTypeTrader::applyConstraints (lst=..., constraint=<optimized out>) at ../../kdecore/services/kservicetypetrader.cpp:53
#16 0x00007f878ee18ffe in KServiceTypeTrader::defaultOffers (this=<optimized out>, serviceType=<optimized out>, constraint=...) at ../../kdecore/services/kservicetypetrader.cpp:127
#17 0x00007f878ee19751 in KServiceTypeTrader::query (this=0x19888b0, serviceType=..., constraint=...) at ../../kdecore/services/kservicetypetrader.cpp:141
#18 0x00007f877f7fb33e in KEmoticonsPrivate::loadServiceList (this=0x5220b30) at ../../kutils/kemoticons/kemoticons.cpp:71
#19 0x00007f877f7fb49a in KEmoticons::KEmoticons (this=0x5220c90) at ../../kutils/kemoticons/kemoticons.cpp:121
#20 0x00007f8786c15128 in operator-> (this=<optimized out>) at ../../kpimutils/linklocator.cpp:56
#21 KPIMUtils::LinkLocator::convertToHtml (plainText=<optimized out>, flags=<optimized out>, maxUrlLen=<optimized out>, maxAddressLen=<optimized out>) at ../../kpimutils/linklocator.cpp:426
#22 0x00007f8786738d54 in MessageViewer::strToHtml (str=<optimized out>, flags=<optimized out>) at ../../messageviewer/headerstyle.cpp:85
#23 0x00007f8786742d9c in MessageViewer::FancyHeaderStyle::format (this=0x1d3fe10, message=0x1a5cd90) at ../../messageviewer/headerstyle.cpp:598
#24 0x00007f878679408f in MessageViewer::ViewerPrivate::writeMsgHeader (this=0x1cd9fb0, aMsg=0x1a5cd90, vCardNode=<optimized out>, topLevel=true) at ../../messageviewer/viewer_p.cpp:907
#25 0x00007f87867a283d in MessageViewer::ViewerPrivate::parseContent (this=0x1cd9fb0, content=0x1a5cd90) at ../../messageviewer/viewer_p.cpp:846
#26 0x00007f87867a5434 in MessageViewer::ViewerPrivate::displayMessage (this=0x1cd9fb0) at ../../messageviewer/viewer_p.cpp:729
#27 0x00007f87867a5ce2 in MessageViewer::ViewerPrivate::updateReaderWin (this=0x1cd9fb0) at ../../messageviewer/viewer_p.cpp:1946
#28 0x00007f87867a918d in MessageViewer::ViewerPrivate::qt_metacall (this...

Read more...

Changed in kdepim (Ubuntu Oneiric):
status: New → Confirmed

Clearly I have the same bug... but currently I have lost all my mail, and every time I try to start kmail I get the error-message that "Failed to fetch the resource collection"

(In reply to comment #19)
> Clearly I have the same bug... but currently I have lost all my mail, and every
> time I try to start kmail I get the error-message that "Failed to fetch the
> resource collection"

Maybe this information can be useful for you
https://wiki.kubuntu.org/OneiricOcelot/Final/Kubuntu/Kmail2

 Partially helpful, thank you... now I no longer have the "Failed to fetch
resource collection" but

1) a collection of error messages during the interactive migration "KMail
folders: unusable configuration".
2) a migration request when i start kmail
3) no mails in the correctly transfered directory/folder structure

On Mon, Oct 24, 2011 at 5:44 PM, nucleo <email address hidden> wrote:

> https://bugs.kde.org/show_bug.cgi?id=283563
>
>
>
>
>
> --- Comment #20 from nucleo <nucleo fedoraproject org> 2011-10-24 15:44:23
> ---
> (In reply to comment #19)
> > Clearly I have the same bug... but currently I have lost all my mail, and
> every
> > time I try to start kmail I get the error-message that "Failed to fetch
> the
> > resource collection"
>
> Maybe this information can be useful for you
> https://wiki.kubuntu.org/OneiricOcelot/Final/Kubuntu/Kmail2
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
>

gonssal (gonssal) wrote :

Is there an ETA for the migration script to work properly? Is it currently planned to fix it or just not in the agenda?

I have arround 200 Kubuntu 11.04 installations in a corporate environment and its just not acceptable to ask all users to backup and import all their PIM data manually, so I've disabled update-notifier for the moment.

Thank you.

Chris Samuel (chris-csamuel) wrote :

Has this been improved with KDE 4.8 ?

The upstream bug report https://bugs.kde.org/show_bug.cgi?id=283563 doesn't appear to have been addressed at all, but it's quite possible that doesn't signify anything.

gonssal (gonssal) wrote :

Just incredible that is isn't fixed with a new LTS release.

My company just decided to stop using KDE due to bosses finding it unacceptable that people loses emails and configurations due to just a update. Back to windows.

Appears not to be fixed in KDE 4.8, at least according to the latest update on the Kubuntu LaunchPad bug entry for this problem:

https://bugs.launchpad.net/bugs/857828

# Just incredible that is isn't fixed with a new LTS release.
#
# My company just decided to stop using KDE due to bosses finding it
# unacceptable that people loses emails and configurations due to just
# a update. Back to windows.

Workaround for 4.8.4:
sudo apt-get -f install kmail=4:4.8.2-0ubuntu2 libkdepim4=4:4.8.2-0ubuntu2 libkleo4=4:4.8.2-0ubuntu2 libkpgp4=4:4.8.2-0ubuntu2 libksieveui4=4:4.8.2-0ubuntu2 libmailcommon4=4:4.8.2-0ubuntu2 libmessagecomposer4=4:4.8.2-0ubuntu2 libmessagecore4=4:4.8.2-0ubuntu2 libmessagelist4=4:4.8.2-0ubuntu2 libmessageviewer4=4:4.8.2-0ubuntu2 libtemplateparser4=4:4.8.2-0ubuntu2 libincidenceeditorsng4=4:4.8.2-0ubuntu2 libcalendarsupport4=4:4.8.2-0ubuntu2 libincidenceeditorsng4=4:4.8.2-0ubuntu2 libkmanagesieve4=4:4.8.2-0ubuntu2 libkdgantt2=4:4.8.2-0ubuntu2 libksieve4=4:4.8.2-0ubuntu2 libkdepimdbusinterfaces4=4:4.8.2-0ubuntu2 libkdepimdbusinterfaces4=4:4.8.2-0ubuntu2 akregator=4:4.8.2-0ubuntu2 kaddressbook=4:4.8.2-0ubuntu2 kdepim-kresources=4:4.8.2-0ubuntu2 knotes=4:4.8.2-0ubuntu2 kontact=4:4.8.2-0ubuntu2 korganizer=4:4.8.2-0ubuntu2 ktimetracker=4:4.8.2-0ubuntu2 libeventviews4=4:4.8.2-0ubuntu2

the "-f" option may not be needed

Git commit 15bd943e1add04435e03f6cdf31b37dd976eb8d1 by Martin Koller.
Committed on 01/08/2012 at 19:19.
Pushed by mkoller into branch 'KDE/4.9'.

Fix for: kmail does never start migration

see also https://git.reviewboard.kde.org/r/105788/
FIXED-IN: 4.9.1

M +4 -4 kmail/kmkernel.cpp

http://commits.kde.org/kdepim/15bd943e1add04435e03f6cdf31b37dd976eb8d1

Git commit 12f1cfa98eb7c8a0d942bcc09c54ce4289ac95fd by Martin Koller.
Committed on 01/08/2012 at 19:19.
Pushed by mkoller into branch 'master'.

Fix for: kmail does never start migration

see also https://git.reviewboard.kde.org/r/105788/
FIXED-IN: 4.9.1

M +4 -4 kmail/kmkernel.cpp

http://commits.kde.org/kdepim/12f1cfa98eb7c8a0d942bcc09c54ce4289ac95fd

Changed in kdepim:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.