Akregator Close Tab Keyboard Shortcut Fails to Close Tab

Bug #80395 reported by Richard Guo on 2007-01-18
8
Affects Status Importance Assigned to Milestone
KDE PIM
Invalid
Medium
kdepim (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: akregator

Summary of reproduction of issue:

1. Open Kontact's Feeds or Akregator
2. Select a feed
3. Select an article from the feed
4. Click on a link in the article to load a konqueror tab

At this point, the problem can be isolated and reproduced many times.

If we close the tab with the close button on the top right, the new tab closes. If we press the keyboard shortcut (Ctrl-W) in my case, the new tab closes too.

However, if we try to close the Articles tab via the keyboard shortcut (the tab does not close), and then try the keyboard shortcut on the new konqueror tab, the tab does not close though it's supposed to. Using the top right close tab icon closes the tab as normal.

The issue can be reproduced every time.

Risto H. Kurppa (risto.kurppa) wrote :

Confirm here, using Feisty, Akregator package version 3.5.6-0ubuntu6

Richard Johnson (nixternal) wrote :

I am closing this report as it is the intended behavior. The Articles tab is the main window for akregator. If this was an issue with previous releases, I can confirm it isn't an issue with 3.5.7. If you believe this is a viable issue and that I have misread this report, I urge you to reopen this report with more information. Thank you.

Changed in kdepim:
status: Unconfirmed → Rejected
Richard Guo (rfguo) wrote :

*sigh* Perhaps you misunderstood what is the bug here.

Closing the articles tab via the keyboard doesn't work, as expected.

The problem is that after *attempting* to close the articles tab via ctrl-w keyboard shortcut (or whatever you've configured), closing any other konqueror tabs launched in akregator with the keyboard shortcut doesn't work.

Richard Guo (rfguo) wrote :

I haven't installed 3.5.7 yet, but I will keep you updated later tonight as to whether this behaviour still exists.

Richard Johnson (nixternal) wrote :

AHHHH! I am glad you responded. You are 110% correct on this one. Totally odd. I will check upstream and file as necessary. I apologize and appreciate your response.

Changed in kdepim:
importance: Undecided → Low
status: Rejected → Confirmed
Richard Johnson (nixternal) wrote :

The error is in 3.5.7 as well :) I went ahead and created and added an upstream report to this. It isn't only Kubuntu, I had an openSUSE user on IRC confirm as well.

Changed in kdepim:
status: Unknown → Confirmed
Richard Johnson (nixternal) wrote :

Requested an upstream status update on this issue.

Risto H. Kurppa (risto.kurppa) wrote :

Seems to be fixed on KDE 3.5.9

Richard Johnson (nixternal) wrote :

This is not fixed in 3.5.9 and more than likely won't be fixed in the 3.5.x branch, however it should get fixed in the KDE 4 branch, but we won't know until we get a kdepim package for KDE 4, which won't be until 4.1.

Jonathan Thomas (echidnaman) wrote :

Is this an issue in Intrepid? (Testing with akregator-kde4 in Hardy would do)

Changed in kdepim:
status: Confirmed → Incomplete
targon (me-pd9e52d26) wrote :

Yes, akregator in Intrepid has the same problem. Pressing the keyboard shortcut will select the "Close Tab" button but not close the tab.

Changed in kdepim:
status: Incomplete → Triaged
Jonathan Thomas (echidnaman) wrote :

Is this still an issue in KDE 4.2 or 4.3?

Changed in kdepim (Ubuntu):
status: Triaged → Incomplete
Jonathan Thomas (echidnaman) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as requested in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the "Status" column, and change the status back to "New". Thanks again!

Changed in kdepim (Ubuntu):
status: Incomplete → Invalid
Changed in kdepim:
status: Confirmed → Invalid
Changed in kdepim:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.