Ubuntu

[kmail] doesn't display a signed message, where the key is unknown

Reported by StefanPotyra on 2006-12-11
4
Affects Status Importance Assigned to Milestone
kdepim (Ubuntu)
Medium
Richard Johnson

Bug Description

Hi,

when I click on the attached mail, its text is neither shown in kmail, nor can I mark it as read. Is most probably related to the fact, that the mail is signed.

Sorry, but I dunno if that's a bug in kdepim itself, or anywhere below.

Side note:
gpg -verify --verbose 1165575164.6848.wUi8Z
gpg: ify: skipped: public key not found
gpg: 1165575164.6848.wUi8Z: encryption failed: public key not found
zsh: exit 2 gpg -verify --verbose 1165575164.6848.wUi8Z

StefanPotyra (sistpoty) wrote :
Daniel Hahler (blueyed) wrote :

I can open the attached mail just fine using KMail 1.9.6 (KDE 3.5.6).

Can you open other signed messages?

Have you tried it using the most recent KMail version?

Changed in kdepim:
status: Unconfirmed → Needs Info
StefanPotyra (sistpoty) wrote :

Just tried it with 3.5.6-0ubuntu6, doesn't work with the original mail in my ubuntu/edgy-changes folder. It works for me to open the attached mail via file->open though.

I've also tried to copy the mail straight to ~/.kde/share/apps/kmail/mail/somedirectory which will result in the mail being displayed correctly. *Strange*.

Side note: I can mark the original mail read/unread now :).

StefanPotyra (sistpoty) wrote :

Richard, not quite sure if this is a duplicate actually. For this particular mail nothing at all is displayed, while the screenshot in bug #59033 displays at least some lock symbol. Also I cannot reply to the mail or view the complete mail headers.

Btw.: currently my kmail version is 4:3.5.7-1ubuntu3.

Anyway I'm not quite sure if this is due to some leftover of the the old version of kmail whith which I received the mail in the first place or a bug that's still present in the current version (which I don't think, because I didn't stumble over any signed messages, which I cannot read since then).

Anyway, feel free to close/reject this bug is in case you think that we won't be able to track down what the real problem is.

Cheers,
     Stefan.

StefanPotyra (sistpoty) wrote :

Interesting, I recently stumbled upon another mail which produces the same result. This time, I also launched kmail from shell and got this output:

kmail: WARNING: Error: Failure modifying /home/stefan/.kde/share/apps/kmail/mail/.ubuntu.directory/.changes.directory/.dapper-changes.index.sorted (No space left on device?)
kmail: WARNING: /build/buildd/kdepim-3.5.7/./kmail/kmheaders.cpp:3337

However:
>> df
[..]
/dev/sdb5 38456308 24580940 11921868 68% /home

ii kmail 4:3.5.7-1ubuntu5 KDE Email client

I also tried to strace kmail, but the results didn't show anything interesting (can't see any accesses to my mail directory in there, any hints how to get a sane strace?)

Cheers,
    Stefan.

StefanPotyra (sistpoty) wrote :

still there with 4:3.5.7-1ubuntu7.

StefanPotyra (sistpoty) wrote :

strace kmail --nofork 2>kmail.strace
bzip2 kmail.strace

StefanPotyra (sistpoty) wrote :

The mail in question this time is 1186880008.7706.STnng.

Launchpad Janitor (janitor) wrote :

[Expired for kdepim (Ubuntu) because there has been no activity for 60 days.]

StefanPotyra (sistpoty) wrote :

setting back to new, still there in kmail 4:3.5.9-0ubuntu1 (just have another mail with this behaviour...)

Changed in kdepim:
status: Invalid → New
StefanPotyra (sistpoty) wrote :

hm... maybe this will give some clue:

kmail: WARNING: FolderStorage::getMsg, message has no sernum, index: 9727
kmail: WARNING: Error: Failure modifying /home/stefan/.kde/share/apps/kmail/mail/.ubuntu.directory/.debian-mentors.index.sorted (No space left on device?)
kmail: WARNING: /build/buildd/kdepim-3.5.9/./kmail/kmheaders.cpp:3402
kmail: WARNING: FolderStorage::getMsg, message has no sernum, index: 9727
[last one repeated another 11 times]

StefanPotyra (sistpoty) wrote :

And yes, though my home folder is now more populated, there is still space left:
>> df | grep home
/dev/sdb5 38456308 28047784 8455024 77% /home

Richard Johnson (nixternal) wrote :

Stefan, is this an IMAP setup at all? I have found 2 upstream reports that provide a similar error and both are dealing with IMAP. Thanks!

Changed in kdepim:
assignee: nobody → nixternal
status: New → Incomplete
StefanPotyra (sistpoty) wrote :

No, it was pop+local mbox, and is now only local mbox.

StefanPotyra (sistpoty) wrote :

Aha. I could mark one of the two mails as read now (I have no clue why, but I noticed a lengthy run of a kio_mbox thread going on, even though that kmail was not launched; maybe that might be related?).

Side note: I haven't seen any *new* mails which show this behaviour since my comment from 2008-03-09.

Richard Johnson (nixternal) wrote :

Ya, I have been talking on IRC with some of the PIM devs trying to get a grasp on this one. I will ask about the kio_mbox threads going insane, as I have noticed this as well, however I keep Kontact/KMail open all of the time.

Daniel T Chen (crimsun) on 2008-09-19
Changed in kdepim:
importance: Undecided → Medium
StefanPotyra (sistpoty) wrote :

as of right now (4:4.1.2-0ubuntu1) the last mails, that I couldn't read/mark read display just fine for whatever reason.

I guess I can't be of much help any longer, and I also don't mind if you close that bug ;).

Changed in kdepim:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers