newer kdepim in lucid than in maverick

Bug #721269 reported by Jonathan Riddell on 2011-02-18
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kdepim (Ubuntu)
Undecided
Unassigned
Maverick
High
Scott Kitterman
kdepim-runtime (Ubuntu)
Undecided
Unassigned
Maverick
High
Scott Kitterman

Bug Description

Binary package hint: kdepim

Following the upgrade of KDE SC packages in lucid there is a newer version of kdepim in lucid than in maverick. 4:4.4.8-0ubuntu0.0.1 vs 4:4.4.6-0ubuntu1. Same for kdepim-runtime.

This breaks lucid->maverick upgrades.

kdepim in maverick should be updated to 4.4.10 the current upstream stable release.

Jonathan Riddell (jr) on 2011-02-18
Changed in kdepim (Ubuntu):
status: New → Invalid
Changed in kdepim-runtime (Ubuntu):
status: New → Invalid
Scott Kitterman (kitterman) wrote :

Actually 4.4.8 or 4.4.9. 4.4.10 has some oddities with kdepimlibs < 4.6.

Changed in kdepim (Ubuntu Maverick):
assignee: nobody → Scott Kitterman (kitterman)
importance: Undecided → High
milestone: none → maverick-updates
status: New → In Progress
Changed in kdepim-runtime (Ubuntu Maverick):
assignee: nobody → Scott Kitterman (kitterman)
importance: Undecided → High
milestone: none → maverick-updates
status: New → In Progress
Scott Kitterman (kitterman) wrote :

kdepim and kdepim-runtime uploaded. Waiting for ubuntu-sru to approve/accept.

Jonathan Riddell (jr) wrote :

TEST CASE: install Kubuntu 10.04, update to latest lucid-updates packages, upgraade to 10.10 following https://help.ubuntu.com/community/MaverickUpgrades/Kubuntu, kdepim packages will be removed due to changed libraries etc

install Kubuntu 10.04, update to latest lucid-updates packages, enable lucid-proposed, upgraade to 10.10 following https://help.ubuntu.com/community/MaverickUpgrades/Kubuntu, kdepim packages will be upgraded

Accepted kdepim-runtime into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in kdepim-runtime (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in kdepim (Ubuntu Maverick):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Accepted kdepim into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Launchpad Janitor (janitor) wrote :
Download full text (3.4 KiB)

This bug was fixed in the package kdepim - 4:4.4.9-0ubuntu0.1

---------------
kdepim (4:4.4.9-0ubuntu0.1) maverick-proposed; urgency=low

  * New upstream release per KDE microversion release exception (LP: #721269)
    - Fix so versions for building with KDE 4.5
    - Downgrade libakonadi-dev, kde-sc-dev-latest & kdepimlibs5-dev

kdepim (4:4.4.8-0ubuntu2) natty; urgency=low

  * Refresh & Add kubuntu_02_kalarm_kstatusnotifieritem.diff
    - Patch applied in trunk, not 4.4.8

kdepim (4:4.4.8-0ubuntu1) natty; urgency=low

  [ Rohan Garg ]
  * New upstream release
    - Drop kubuntu_02_kalarm_kstatusnotifieritem.diff, applied upstream
    - Add kalarm-disabled.png to kalarm.install

  [ Scott Kitterman ]
  * Drop unneeded build-depend on kdepim-runtime-dev
  * Update KUBUNTU-DEBIAN-DIFFERENCES
  * Merge from Debian Unstable. Remaining Ubuntu changes:
    - Update debian/patches/30_debianize_akregator_default.diff for Ubuntu
      defaults and rename to kubuntu_30_debianize_akregator_default.diff
    - Remove kleopatra and akdonadiconsole from kdepim metapackage due to
      their being in Universe
    - Simplify kmail and kleopatra pinentry recommends:
      - Remove pinentry-x11 since it does not exist
      - Remove pinentry-qt since this package has been removed from Ubuntu
    - Adjust other kmail recommends/suggests:
      - Move procmail to suggests from recommends
      - Drop Suggests on f-prot-installer and annoyance-filter since they are
        not in the archive
    - Consolidate all documentation in kdepim-doc for all packages in kdepim
      - Add kdepim-doc.install
      - debian/akregator,kaddressbook,kalarm,kjots,kmail,knode,knotes,kontact,
      ktimetracker,korganizer{.install}, do not add documentation
    - Add kdepim-dev package (it is not stable, but we rebuild the reverse
      build-depends to account for this)
      - Add to debian/control
      - Add kdepim-dev.install
    - Provide debian/kalarm-icons and adjust debian/rules to install
    - Do not build-depend on libgnokii-dev because it is in Universe
    - Build against version of Boost in Main, libboost1.42-dev and
      libboost-graph1.42-dev
    - Add libindicate-qt-dev, libxml2-dev, sharutils to build-deps
    - Add kdepim-runtime to depends in kdepim, knode, knotes, konsolekalendar,
      kontact, and korganizer
    - Add kjots depends on akonadi-server
    - Adjust version requirements for Ubuntu packages for conflict/replaces
    - Adjust build-depends and so versions in library .install files for
      Ubuntu KDE versions

kdepim (4:4.4.7-2) unstable; urgency=low

  * Release to unstable.

kdepim (4:4.4.7-1) experimental; urgency=low

  * New upstream release.

kdepim (4:4.4.7-0ubuntu2) natty; urgency=low

  * Rebuild against KDE 4.6 beta and and Akonadi 1.5 beta
    - Bump so version to 4.6.0 in akregator.install, kaddressbook.install,
      kalarm.install, kdepim-groupware.install, kdepim-kresources.install,
      kmail.install, knode.install, kontact.install, korganizer.install,
      libkdepim4.install, libkleo4.install, libkpgp4.install,
      libksieve4.install, libmessagecore4.install, libmessagelist4.install, and
      libmimelib4.install
  * Bum...

Read more...

Changed in kdepim (Ubuntu Maverick):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdepim-runtime - 4:4.4.9-0ubuntu0.1

---------------
kdepim-runtime (4:4.4.9-0ubuntu0.1) maverick-proposed; urgency=low

  * New upstream release per KDE microversion update exception (LP: #721269)
    - Fix so versions for building with KDE 4.5
    - Bump down kde-sc-dev-latest and kdelibs5-dev to 4.5.1 to build for maverick

kdepim-runtime (4:4.4.6-1ubuntu1) natty; urgency=low

  * Merge with Debian unstable remaining changes:
    - Bump soname in kdepim-runtime.install
    - Keep versioned boost build-depends
    - Build against kdelibs5-dev 4.5.2-0ubuntu1 for libkutils4 transition

kdepim-runtime (4:4.4.6-1) unstable; urgency=low

  * New upstream bugfix release.
  * Point debian/control Vcs fields to the new Git repository.
  * Fix a race between akonado_nepomuk_*_feeder_automoc and
    autogeneration of ontology headers (nie.h). (Closes: #596908)
 -- Scott Kitterman <email address hidden> Fri, 18 Feb 2011 12:45:11 -0500

Changed in kdepim-runtime (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers