KMail immediately exits without opening the main window

Bug #718341 reported by Davor Cubranic on 2011-02-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kdepim (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdepim

When I try to run KMail, it immediately exits after printing a couple of lines
of warning messages:

$ kmail
Connecting to deprecated signal
QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
"/usr/bin/kmail(1868)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown -
The name org.kde.nepomuk.services.nepomukstorage was not provided by any
.service files"
"/usr/bin/kmail(1868)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(1868)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown -
The name org.kde.nepomuk.services.nepomukstorage was not provided by any
.service files"
"/usr/bin/kmail(1868)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(1868)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown -
The name org.kde.nepomuk.services.nepomukstorage was not provided by any
.service files"
"/usr/bin/kmail(1868)" Soprano: "QLocalSocket::connectToServer: Invalid name"
kmail(1868) KMFolder::updateIndicatorIcon: Could not read image from ""
kmail(1868) KMFolder::updateIndicatorIcon: Could not read image from ""
kmail(1868) KMFolder::updateIndicatorIcon: Could not read image from ""
kmail(1868) KMFolder::updateIndicatorIcon: Could not read image from ""
QMetaObject::invokeMethod: No such method
KUniqueApplication::loadCommandLineOptionsForNewInstance()
kmail(1868)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
kmail(1868)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
<unknown program name>(1867)/: Communication problem with "kmail" , it
probably crashed.
Error message was: "org.freedesktop.DBus.Error.NoReply" : " "Did not receive a
reply. Possible causes include: the remote application did not send a reply,
the message bus security policy blocked the reply, the reply timeout expired,
or the network connection was broken." "

My guess is either Akonadi or KMail's config/indexes got corrupted, and now it stops everything from working. If that's the case, are there any files or directories that I can delete that will fix the problem without losing my data?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers