Kontact crashs at startup

Bug #67744 reported by Stéphane Magnenat on 2006-10-23
10
Affects Status Importance Assigned to Milestone
kdepim (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kontact

Kontact crashs at startup. I'm currently running edgy RC, but I think I got the same problem during the two days I was using KDE 3.5.5 under Dapper.

I'm using pim stuff over dimap. kmail alone works fine.

Here is the output of the command line :
nct@nct-laptop:~$ kontact
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
ConditionalOffset: 1.0.106, condition=0
Date is a 7
ConditionalOffset: 25.11.106, condition=0
Date is a 1
ConditionalOffset: 1.7.106, condition=0
Date is a 2
*** KMail got signal 11 (Crashing)

Here is the backtrace:
(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
About 40 lines of (no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1241711824 (LWP 6896)]
[New Thread -1280525408 (LWP 6900)]
[New Thread -1272132704 (LWP 6899)]
[New Thread -1263740000 (LWP 6898)]
[New Thread -1255347296 (LWP 6897)]
About 70 lines of (no debugging symbols found)
[KCrash handler]
#6 0x00000000 in ?? ()
#7 0xb324cfcf in KCal::ResourceKolab::sendKMailUpdate ()
   from /usr/lib/libkcalkolab.so.0
#8 0xb324da3f in KCal::ResourceKolab::incidenceUpdated ()
   from /usr/lib/libkcalkolab.so.0
#9 0xb3251343 in KCal::ResourceKolab::addIncidence ()
   from /usr/lib/libkcalkolab.so.0
#10 0xb325213e in KCal::ResourceKolab::addIncidence ()
   from /usr/lib/libkcalkolab.so.0
#11 0xb325298f in KCal::ResourceKolab::loadSubResource ()
   from /usr/lib/libkcalkolab.so.0
#12 0xb32530f7 in KCal::ResourceKolab::doLoadAll ()
   from /usr/lib/libkcalkolab.so.0
#13 0xb32532d1 in KCal::ResourceKolab::loadAllEvents ()
   from /usr/lib/libkcalkolab.so.0
#14 0xb32534f0 in KCal::ResourceKolab::doLoad ()
   from /usr/lib/libkcalkolab.so.0
#15 0xb669309a in KCal::ResourceCalendar::load () from /usr/lib/libkcal.so.2
#16 0xb66934ee in KCal::CalendarResources::load () from /usr/lib/libkcal.so.2
#17 0xb59daacb in TodoSummaryWidget::TodoSummaryWidget ()
   from /usr/lib/kde3/libkontact_todoplugin.so
#18 0xb59dab73 in TodoPlugin::createSummaryWidget ()
   from /usr/lib/kde3/libkontact_todoplugin.so
#19 0xb5a8bcea in SummaryViewPart::updateWidgets ()
   from /usr/lib/kde3/libkontact_summaryplugin.so
#20 0xb5a8cc28 in SummaryViewPart::initGUI ()
   from /usr/lib/kde3/libkontact_summaryplugin.so
#21 0xb5a8d4a9 in SummaryViewPart::SummaryViewPart ()
   from /usr/lib/kde3/libkontact_summaryplugin.so
#22 0xb5a8d8b1 in SummaryView::createPart ()
   from /usr/lib/kde3/libkontact_summaryplugin.so
#23 0xb7e2d1b2 in Kontact::Plugin::part () from /usr/lib/libkpinterfaces.so.1
#24 0x08061160 in ?? ()
#25 0x082a9540 in ?? ()
#26 0x00000000 in ?? ()

Today I restarted my computer from a cold start and it works again. I will test for some days and if things are ok I will makr this bug as invalid.

Steph

Today I got this problem again. I had freshly started my computer, same as yesterday. I'll try to find any specific reasons that could trigger crash and update bug report.

Thanks,

Steph

Today I got the problem again, but before crash kontact displayed 4 times a "Copy file box" that was saying "Copying event n of 22366" (with n going from 1 to 22366). Of course I've not so much event in my agenda, I even doubt that I've that much mails.

I suspect it is an upstream bug that happens when some strange state arise in dimap resources. I'm also accessing the same resources from another computer also running kontact and there might be some messing somewhere. Nevertheless the fact kde pim is so unstable is frustrating and kills user experience.

Steph

Ritesh Raj Sarraf (rrs) wrote :

I too am seeing the exactly same issue.
I too use dimap (for MS Exchange) but don't think its a dimap issue because then kmail, when started standalone, should also have had this issue.

I noticed that (when I was using Debian) when using kontact 3.5.4, this issue was not seen.

Am wondering why this bug is still "Unconfirmed".

Hi,

I think you have got the wrong email. I use Ubuntu which is based on
Gnome. So probably you've got the wrong person. :)

Have a nice day.

Regards,
Ash

--
Be yourself, not what everyone want's you to be.

Geek Wrestler - Spotlighting technology.
www.actofwar.wordpress.com

On 12/5/06, Ritesh Raj Sarraf <email address hidden> wrote:
> I too am seeing the exactly same issue.
> I too use dimap (for MS Exchange) but don't think its a dimap issue because then kmail, when started standalone, should also have had this issue.
>
> I noticed that (when I was using Debian) when using kontact 3.5.4, this
> issue was not seen.
>
> Am wondering why this bug is still "Unconfirmed".
>
> --
> Kontact crashs at startup
> https://launchpad.net/bugs/67744
>

HPNadig (hpnadig) wrote :

Folks, I'm not sure how, but updates on this bug are being mailed to some of us even though we haven't subscribed for it.

Launchpad bug, eh?

Baishampayan Ghose (b.ghose) wrote :

HPNadig,
Not really, somebody subscribed Ubuntu India Local Community to this bug report. I will see if I can remove it.

Toufeeq Hussain (toufeeqh) wrote :

I haven't subscribed to a single bug on launchpad and I'm being
spammed by it (maybe as punishment).

Please make it stop.

-Toufeeq

On 12/5/06, HPNadig <email address hidden> wrote:
> Folks, I'm not sure how, but updates on this bug are being mailed to
> some of us even though we haven't subscribed for it.
>
> Launchpad bug, eh?
>
> --
> Kontact crashs at startup
> https://launchpad.net/bugs/67744
>

--
blog @ http://toufeeq.net

Ritesh Raj Sarraf (rrs) wrote :

I might be the culprit, not sure though.

I subscribed myself to this bug but don't remember how a group would also have been added.

Ritesh

Rajath (y-s-rajath) wrote :

dont mail me either

On 12/5/06, Toufeeq Hussain <email address hidden> wrote:
> I haven't subscribed to a single bug on launchpad and I'm being
> spammed by it (maybe as punishment).
>
> Please make it stop.
>
> -Toufeeq
>
> On 12/5/06, HPNadig <email address hidden> wrote:
> > Folks, I'm not sure how, but updates on this bug are being mailed to
> > some of us even though we haven't subscribed for it.
> >
> > Launchpad bug, eh?
> >
> > --
> > Kontact crashs at startup
> > https://launchpad.net/bugs/67744
> >
>
>
> --
> blog @ http://toufeeq.net
>
> --
> Kontact crashs at startup
> https://launchpad.net/bugs/67744
>

Ritesh Raj Sarraf (rrs) wrote :

Seems fixed in 3.5.6

Myriam Schweingruber (myriam) wrote :

Stéphane, did this occur again since your last post or is it fixed as Ritesh suggests? I'd love to close this bug :-)

I've had it again with 3.5.5, I deleted kontactrc and the bug disappeared. Until it reappears I can't tell you if it's still there on 3.5.6 (I was in a hurry I did not backuped kontactrc sorry)

I'll keep this bug informed if I find any other problem.

Steph

Scott Beamer (angrykeyboarder) wrote :

It's crashing for me in Feisty. I just reported it upstream. I attached 3 backtraces to that report.

See http://bugs.kde.org/show_bug.cgi?id=145663

Richard Johnson (nixternal) wrote :

It seems after speaking with users of this same config they do not have the issue and seeing as you have seemed to rid the issue I am going to fix release this. If you feel you are still experiencing these same issues, I urge you to reopen this report. Thank you.

angrykeyboarder, the issue you posted is not the same issue as reported here, yours has to do with Basket.

Changed in kdepim:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers