libkdepim4 and kmail circular depends

Bug #544765 reported by Micah Gersten
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kdepim (Ubuntu)
Fix Released
High
Unassigned
Lucid
Fix Released
High
Unassigned

Bug Description

Binary package hint: kdepim

For some reason, libkdepim4 which is needed by akregator (My RSS feed reader) pulls in kmail. This doesn't seem right. If kmail has a library needed by libkdepim4, I would suggest breaking it out into another package.

ProblemType: Bug
Architecture: amd64
Date: Mon Mar 22 22:23:28 2010
DistroRelease: Ubuntu 10.04
Package: libkdepim4 4:4.4.1a-0ubuntu2
ProcEnviron:
 PATH=(custom, no user)
 LANG=C
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: kdepim
Uname: Linux 2.6.32-16-generic x86_64

Related branches

Revision history for this message
Micah Gersten (micahg) wrote :
summary: - libkdepim4 pulls in kmail on lucid upgrade
+ libkdepim4 and kmail circular depends
Changed in kdepim (Ubuntu):
status: New → Confirmed
importance: Undecided → High
milestone: none → ubuntu-10.04-beta-2
Changed in kdepim (Ubuntu Lucid):
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdepim - 4:4.4.1a-0ubuntu3

---------------
kdepim (4:4.4.1a-0ubuntu3) lucid; urgency=low

  * Move usr/lib/libmessagelist.so* and usr/lib/libmessageviewer.so* from
    kmail to libkdepim4 to fix circular depends (LP: #544765)
    - Bump libkdepim4 replaces kmail version to match
 -- Scott Kitterman <email address hidden> Thu, 25 Mar 2010 11:13:43 -0400

Changed in kdepim (Ubuntu Lucid):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers