KMail does not store sent messages in IMAP folder as configured

Bug #502096 reported by Nico R. on 2010-01-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KDE PIM
Confirmed
Wishlist
kdepim (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: kdepim

In one of my users’ accounts, there is a single identity in KMail. KMail is configured to store all sent mails in a dedicated IMAP folder for this identity.

Whenever a mail is sent by the user, KMail stores it in the “sent messages” folder within “Local Folders”. This is wrong. I expect the message to be stored in the “sent messages” folder within the IMAP account, as set in the identity configuration.

ProblemType: Bug
Architecture: i386
Date: Fri Jan 1 16:56:25 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/kontact
Package: kontact 4:4.3.2-0ubuntu6
ProcEnviron:
 LANGUAGE=de_DE:de:en_GB:en
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
SourcePackage: kdepim
Uname: Linux 2.6.31-17-generic i686

Version: 1.11.4 (using 4.2.4 (KDE 4.2.4) "release 2", KDE:42 / openSUSE_11.1)
Compiler: gcc
OS: Linux (x86_64) release 2.6.27.23-0.1-default

When one sends an email over IMAP, the email is copied to the local sent-items folder. It should be stored in the corresponding IMAP-folder (too?).

Reproduce:
Add an IMAP email.
Send an email.
Check IMAP sent-items, the email is not there.
Check local sent-items, the email is stored here.

Nico R. (n-roeser) wrote :
Nico R. (n-roeser) wrote :

I should add that sending emails is done by using an SMTP server configured in the preferences.

Could this be KDE bug 198620 <URL:https://bugs.kde.org/show_bug.cgi?id=198620>?

Changed in kdepim (Ubuntu):
status: New → Confirmed
Jonathan Kolberg (bulldog98) wrote :

I noticed this behaviour, too, and think it would be usefull if that would be done.

Changed in kdepim:
status: Unknown → New

You have to configure that with you identity. That normally works :)

Changed in kdepim:
status: New → Invalid

But shouldn’t it be at least a default setting?

Then lets make this a which

*** Bug 206460 has been marked as a duplicate of this bug. ***

Changed in kdepim:
status: Invalid → New
Philip Muškovac (yofel) wrote :

Upstream: You have to configure that with your identity.
The bug is now about using the IMAP sent folder by default instead of the local one.

Changed in kdepim (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Triaged
Harald Sitter (apachelogger) wrote :

Closing in favor of KDE bug report, please refer there for updates. Thanks.

Changed in kdepim (Ubuntu):
status: Triaged → Invalid
Changed in kdepim:
importance: Unknown → Wishlist

Thank you for your feature request. Kmail1 is currently unmaintained so we are closing all wishes. Please feel free to reopen a feature request for Kmail2 if it has not already been implemented.
Thank you for your understanding.

Instead of creating a new feature request, please confirm here if the wishlist is still valid for kmail2.

Changed in kdepim:
status: New → Unknown

This is very much still the case in Kmail 4.14.6.

I can select a sent mail folder in the New Message window, and I can make it sticky, but it is not per-identity. There should be a per-identity setting for this.

Changed in kdepim:
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.