kontact / kadressbook creates duplicate contacts

Bug #47919 reported by magdalen on 2006-06-01
18
Affects Status Importance Assigned to Milestone
KDE PIM
Invalid
Medium
kdepim (Ubuntu)
Medium
Unassigned

Bug Description

I'm running Kubuntu dapper, and I've been having multiple problems with kontact and kadressbook. This is close to a stock install with the address book vcf stored locally in my user profile. I searched bug reports here and with google but did not find this posted, please forgive if it is a duplicate.

I've been adding contacts to my address book by right-clicking on the email address in the kontact window and choosing Add to Address Book. It's listing some of the names twice in the Contacts list, but if I delete one of them it deletes them both so there's really kind of only one entry.

I have three Address Books configured in the Contacts window, and thought maybe a contact is listed multiple times because it's in more than one Address Book. I tried to right-click on the contact and choose Store Contact In to assign, and just get the message "The resource '/home/magdalen/.kde/share/apps/kabc/stdvcf' is locked by application 'kontact'."

For a moment I got around this by closing Kontact and on a commandline using the command kaddressbook & but sometimes I still get the locked vcf message and i'm not having much luck assiging my contacts to one and only one address book. I'm not even sure which ones are crosslisted at this point, or if that's even the cause of this.

Please email me if you want me to send you screenshots or you want more information. Thanks! And thanks to all developers for making this FREE and wonderfully useful software. I'm so glad I'm not dependant on trying to crack WinXP anymore, what a crapjob that is considering how expensive it is, and that you guys do this in your spare time because you love it truly shows . . . . Ubuntu and KDE are great products! It's to the point where it's as easy to install and use Kubuntu as it is to install and use M$ Windoze, at least for someone unfamiliar wtih either. Mad props!

Amber

<email address hidden>

just noticed . . . . poking around in .kde/share/apps/kabc and I notice the ones in teh stdvcf folder that have their own files are the ones duplicated multiple times . . . . the ones stored in the main vcf files are fine, or so it looks. I backed it up so I'm going to try hacking the vcf files and get rid of the stdvcf folder for now if I can figure out how my vcf files have three different address books in them and which ones are the main ones in teh rotation . . . . this could totally break it or who knows I could get lucky so wish me luck!

Richard Johnson (nixternal) wrote :

I also have the multiple contact issue and like you I was unable to find a posted bug concerning this. I went into the #kde channel on freenode, and even the people in there stated that if I found a fix to let them know. I believe everybody using Kontact has the duplicate issue.

It occurs only when I goto send and email, I press the "Select" button to the right of the address line in the new mail window. This opens up the "Recipient List" and in there everyone of my contacts are listed twice. Now this only occurs when you have "All" selected as the address filter in the "Recipient List" window. If I select the drop down from there, You will see my address book in there twice. If I select one of the duplicate address books, then the issue goes away.

I created at bug one the KDE bug list:
http://bugs.kde.org/show_bug.cgi?id=129607

Changed in kdepim:
status: Unconfirmed → Confirmed
Richard Johnson (nixternal) wrote :

## VERSIONS ##

 * Kubuntu Dapper 6.06 LTS
 * KDE Version: 3.5.3
 * Kontact Version: 1.2.3
 * Kmail Version: 1.9.3
 * KAddressBook Version: 3.5.3

Changed in kdepim:
status: Unknown → Unconfirmed
Geoff Hoff (gahoff) wrote :

I have the exact problem described by Rich. I thought I might be unique because I installed Ubuntu and have installed assorted kde apps rather than doing the Kubuntu installation.

On Friday 23 June 2006 11:06, Geoff Hoff wrote:
> I have the exact problem described by Rich. I thought I might be unique
> because I installed Ubuntu and have installed assorted kde apps rather
> than doing the Kubuntu installation.
I just reinstalled Kubuntu Dapper 6.06 LTS on a new system, and started up
Kontact for the first time. I added one contact and sure enough it shows up
twice in the recipient list. I did get an email back from the KDE bug tracker
stating something along the lines of it is just me. Obviously it isn't, and
plus it is on 3 of my machines now doing the same exact thing. As a matter of
fact the machine I just reloaded is as default as it can get. I installed
from disk, and as soon as it completed, I fired up Kontact. I can stop this
from happening however by selecting just one of the multiple addressbooks
showing up in the recipient list. Thanks for the replies everyone and thanks
for helping confirm this!!!
--
Rich Johnson (nixternal)
"The best thing about democracy is that it gives every voter a chance to do
something stupid."

Kenny Duffus (kduffus) wrote :

I'd never used the select option before or i'd have noticed aswell, entries that are in the address book are there twice entries that are recently sent to are once (the duplicates are not all just recently sent to)

However the normal way I'd send is to just start typing part of the address and it only autolists one of the appropriate address

Ken, your "normal way" is fine for one-off email messages, but I run a couple of businesses, which have to stay seperate, and I have a personal list too, I make mail lists and send out bulk messages sometimes. KMail *is* capable of this and is very full featured, this bug makes things confusing though and it's making me afraid of losing something important. I suppose I shouldn't be doing something so important with a testing release . . . . I just couldn't get the wifi cards to work well for kismet with 5.10. I hope this KMail bug and the one about losing mail are cleared up soon. I don't want to switch aps if I can help it becuase I love Kontact and KDE in general. I'm going to stick it out and hope for the best, and probably back up my mail files a littlemore often ;)

Kenny Duffus (kduffus) wrote :

sorry I was just making excuses about why I hadn't noticed rather than saying anything about the way of using "select" and narrowing down the bug :-)

Geoff Hoff (gahoff) wrote :

I found the problem. The k/ubuntu kdepim source package applies the patch named kubuntu_09_kmail_addressbook.diff. This was necessary in kdepim-3.5.1 per this bug http://bugs.kde.org/121337 because kmail wasn't displaying address book entries. This was fixed in 3.5.2 and now the patch causes each addressbook to show up twice. I have verified that if you remove the patch, rebuild kdepim and then install the newly built version of kmail, the address book in kmail works as expected. This is an ubuntu specific problem and is not caused by upstream.

Mark Florian (markrian) wrote :

'Me too'

Thanks Geoff for finding the source of the problem. Since I'm comfortable with dpkg/building from source I'm able to fix this for myself, but others might not be. Since this is so easy a fix perhaps it could be done quickly?

Rocco Stanzione (trappist) wrote :

Is it silly to attach a debdiff to remove a patch?

Geoff Hoff (gahoff) wrote :

Can someone fix the package? Bug is still present in Edgy. Fix is outlined above in comment 9.

Jonathan Riddell (jr) wrote :

Patch removed and uploaded as kdepim_3.5.4-0ubuntu7, thanks for tracking that down.

Changed in kdepim:
status: Confirmed → Fix Released
Changed in kdepim:
status: Unconfirmed → Rejected
AaronPeterson (alpeterson) wrote :

still a problem in edgy (updated to current on 2/15/07)

also manifests itself in the TODO component.

wierd that it's still here.

AaronPeterson (alpeterson) wrote :

it's there again in kontact 4.3.5.5-0ubuntu1

Almost every bug I've seen listed here, comes back when a new small version release comes out! same with the acx wifi firmware in dapper... closed fixed, then it never actually propagates to the end users. .. I guess fix released is not fix-commited

Changed in kdepim:
status: Fix Released → Confirmed
TyphoonX (typhoonx) wrote :

Seems to be still present in Feisty

appears to be fixed.

It's certainly not that patch, as it hasnt been in there since edgy. please reopen if this bug is not fixed with kde 3.5.7 in gutsy.

Changed in kdepim:
status: Confirmed → Fix Released
Changed in kdepim:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.