Unable to close KMail

Bug #366628 reported by Del on 2009-04-25
2
Affects Status Importance Assigned to Milestone
kdepim (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdepim

This bug was encountered on final release of Kubuntu 9.04.

The unwanted behaviour is Kmail window popping up again right after I close it. It has two manifestations that I guess are connected. The first I find reproducible: You can reproduce the behaviour simply by starting Kontact, then close Kontact, and left-click the tray icon. This will open KOrganizer in one window and KMail in a second. If you try to close the KMail window it will only pop up again (at least on my machine). Only after closing KOrganizer will you be able to close KMail.

The second more serious manifestation is that after some use, I will not be able to close KMail at all. My best guess so far is that this is connected to suspend/resume, i.e., that suspend/resume somehow triggers the unable-to close KMail problem in the tray icon even under normal operation. It will then open up KMail in a separate window when I open Kontact, and closing Kontact and/or tray process will not help, the KMail window will just pop up again whenever closed.

Del (delonly) wrote :

I have done another round on this issue, and it seems to be triggered by the KDE Groupware Wizard. I have a Kolab 2.2 server that I sync with. Once I have run the wizard (which works fine and syncs with the server), I see the reported behaviour. This is on Kubuntu 9.04 with all current updates.

Del (delonly) wrote :

I have no tested Kontact quite extensively with KDE 4.3 beta 2, and am happy to inform that the bug is resolved. Now that release candidate of KDE 4.3 is out, upgrading to 4.3 version should be a viable fix for others with the same issue.

Just add the following ppa repository to /etc/apt/sources.list or with Synaptic:
deb http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu jaunty main
Then upgrade Kontact or the entire KDE.

Changed in kdepim (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers