Kmail /akonadi not working - kmail: symbol lookup error:

Bug #322209 reported by Adrenaline on 2009-01-28
36
This bug affects 2 people
Affects Status Importance Assigned to Milestone
kdepim (Ubuntu)
Undecided
Unassigned

Bug Description

After downloading the juanty updates, kmail will not start.

ed@ed-desktop:~$ kmail
kmail(11325) Sonnet::Loader::loadPlugin: Successfully loaded plugin: "kspell_hspell.desktop"
kmail(11325) Sonnet::Loader::loadPlugin: Successfully loaded plugin: "kspell_enchant.desktop"
ed@ed-desktop:~$ kmail: symbol lookup error: /usr/lib/kde4/kabc_akonadi.so: undefined symbol: _ZN4KABC12ContactGroup8mimeTypeEv

ed@ed-desktop:~$ apt-cache policy kmail
kmail:
  Installed: 4:4.1.96-0ubuntu2
  Candidate: 4:4.1.96-0ubuntu2
  Version table:
 *** 4:4.1.96-0ubuntu2 0
        500 http://gb.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

Peter Antoniac (pan1nx) wrote :

Is regarding the kdepim...

ZhengPeng Hou (zhengpeng-hou) wrote :

due to the incomplete upload of kde-4.2, will be fixed soon

Changed in kdepim:
status: New → In Progress
Papadakos Panagiotis (papadako) wrote :

I think that somehow the process of uploading KDE packages should be changed. No package should be available
until everything has been uploaded. Else every KDE update means a broken system for a while.

David Heidelberg (okias) wrote :

Kopete stopped working, with same error :-( 9 hours are gone and still no solution.

As noted in a previous comment this is caused by an incomplete upgrade. This is normal for a development release where the archive is a state of rapid change. There isn't really anyway of blocking the release until all packages are ready without freezing the repository which is something we only do for alpha/beta milestones.

If you run the development release please wait until you have a complete upgrade before reporting bugs. Unless of course you are getting a bug that prevents you completing the upgrade. If you have a fully upgraded 4.2 and you still find bugs then those are the ones we want to hear about.

Thanks

Changed in kdepim:
status: In Progress → Invalid
max (chombier-gmail) wrote :

A workaround for this is to enable kubuntu-experimental repository for *intrepid*, then upgrade to get up-to-date packages. It worked for me.

see http://www.kubuntu.org/news/kde-4.2 for details.

pzy (pzychofaze) wrote :

i know it's not the best way, especially as i don't know what /usr/lib/kde4/kabc_akonadi.so is for but, here it worked to rename it (i just said foo.so) and tried to start kopete again, i did not restart kde but as a workaround it's okay for me

Luis Silva (lacsilva) wrote :

removing akonadi-server and akonadi-kde and then reinstalling them along with kmail solved the problem for me.

Giuseppe Pennisi (giupenni78) wrote :

I have update today and kopete work.

gp

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers