libkpilot_akonadibase missing

Bug #312771 reported by noyaoq on 2008-12-31
4
Affects Status Importance Assigned to Milestone
kdepim (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kpilot

As libkpilot_akonadibase is missing, the conduits Calendar, Todo, and Contacts can not be used with

Jaunty kpilot 4:4.1.85-0ubuntu1.

Changed in kdepim:
status: New → Fix Committed

Ugh. Yes, absolutely correct. I'm the KPilot developer/maintainer and I've spent the last 2 days trying to debug what's going on with a Kubuntu user who is getting this error from kpilotDaemon:

! Library [ "kpilot_conduit_contacts" ] has version 4294967295

That sure looks like a red herring because of this missing base library. http://packages.ubuntu.com/jaunty/i386/kpilot/filelist also confirms that there's no /usr/lib/libkpilot_akonadibase.so being shipped. Can we get this fixed quickly? KPilot is useless for Ubuntu users without it.

Thanks!

Jonathan Thomas (echidnaman) wrote :

The fix is set to be released with the 4.1.96 packages. :-)
Sorry for the bug...

Ah. Heh. I was just looking at what the fix might be. Looks like maybe the simple fix would be to remove this line:

kdepim-4.1.85/debian/not-installed:
./usr/lib/libkpilot_akonadibase.so

and add this one:

kdepim-4.1.85/debian/kpilot.install:
usr/lib/libkpilot_akonadibase.so

? Jonathon, thanks for the quick reply. When will 4.1.96 be out, so I can tell my users?

Jonathan Thomas (echidnaman) wrote :

Yeah, that's essentially what was done: http://bazaar.launchpad.net/~kubuntu-members/kdepim/ubuntu/revision/7

We're planning on releasing 4.1.96 when the KDE 4.2 RC1 release embargo is lifted. (The official release of RC1)

Jonathan Thomas (echidnaman) wrote :

Fix released to Jaunty. Intrepid packages should be coming in the next day or so.

Changed in kdepim:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers