boost -> boost1.35 transition / demote gcc-4.1 and gcc-4.2 to universe

Bug #297152 reported by Martin Pitt on 2008-11-12
10
Affects Status Importance Assigned to Milestone
asio (Ubuntu)
Undecided
Unassigned
Jaunty
Undecided
Unassigned
boost (Ubuntu)
Undecided
Martin Pitt
Jaunty
Undecided
Martin Pitt
enigmail (Ubuntu)
Undecided
Unassigned
Jaunty
Undecided
Unassigned
gcc-4.1 (Ubuntu)
Undecided
Unassigned
Jaunty
Undecided
Unassigned
gcc-4.2 (Ubuntu)
Undecided
Martin Pitt
Jaunty
Undecided
Martin Pitt
kdenetwork (Ubuntu)
High
Unassigned
Jaunty
High
Unassigned
kdepim (Ubuntu)
High
Unassigned
Jaunty
High
Unassigned
kdepimlibs (Ubuntu)
High
Unassigned
Jaunty
High
Unassigned
kdeplasma-addons (Ubuntu)
High
Unassigned
Jaunty
High
Unassigned
kdesdk (Ubuntu)
High
Unassigned
Jaunty
High
Unassigned
klibc (Ubuntu)
High
Colin Watson
Jaunty
High
Colin Watson
linux-ports (Ubuntu)
High
Dan Munckton
Jaunty
High
Dan Munckton
openbabel (Ubuntu)
Undecided
Martin Pitt
Jaunty
Undecided
Martin Pitt
openoffice.org (Ubuntu)
High
Chris Cheney
Jaunty
High
Chris Cheney
openoffice.org-l10n (Ubuntu)
High
Chris Cheney
Jaunty
High
Chris Cheney

Bug Description

Binary package hint: gcc-4.1

We need to get rid of old compilers and clean up stuff in main which still needs them.

gcc-4.1: klibc and linux-ports (build dependencies)
gcc-4.2: enigmail and boost (build dependencies)

boost itself is obsolete, too, the newer boost1.35 is in main. So we should transition the current boost reverse dependencies to boost1.35, too:

asio
kdenetwork
kdepim
kdepimlibs
kdeplasma-addons
kdesdk
openbabel
openoffice.org
openoffice.org-l10n

Martin Pitt (pitti) on 2008-11-12
Changed in gcc-4.2:
assignee: nobody → pitti
status: New → In Progress
Colin Watson (cjwatson) wrote :

According to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=501653, klibc is fixed in Debian experimental. I'll merge that after jaunty alpha 1.

Changed in klibc:
assignee: nobody → kamion
importance: Undecided → High
status: New → In Progress
Changed in linux-ports:
assignee: nobody → munckfish
importance: Undecided → High
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package klibc - 1.5.14-1~exp1ubuntu1

---------------
klibc (1.5.14-1~exp1ubuntu1) jaunty; urgency=low

  * Resynchronise with Debian (gcc unhardcoding fixes LP: #297152).
    Remaining changes:
    - Add lpia to the architecture list for klibc-utils-floppy-udeb.

klibc (1.5.14-1~exp1) experimental; urgency=low

  * New upstream version
    - nuke merged 11_klibc-Default-signal-3-to-bsd_signal-3.patch
    - no longer hardcode gcc

 -- Colin Watson <email address hidden> Sat, 22 Nov 2008 11:38:17 +0000

Changed in klibc:
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

gcc-4.1 demoted.

Changed in gcc-4.1:
status: New → Fix Released
Martin Pitt (pitti) wrote :

Seems that enigmail got fixed, demoting gcc-4.2. Now we just need to finish the boost transition.

Changed in gcc-4.2:
status: In Progress → Fix Released
Changed in enigmail:
status: New → Fix Released
Martin Pitt (pitti) wrote :

We won't fix boost itself, but we need to fix its reverse dependencies.

Changed in boost:
status: New → Won't Fix
Martin Pitt (pitti) wrote :

Whoops, we still need the boost task because it needs to be demoted.

Changed in boost:
assignee: nobody → pitti
status: Won't Fix → Triaged
Martin Pitt (pitti) wrote :

asio already has alternate build-deps.

Changed in asio:
status: New → Fix Released
Martin Pitt (pitti) wrote :

Boost demoted.

Changed in boost:
status: Triaged → Fix Released
Changed in openbabel:
assignee: nobody → pitti
status: New → Triaged
Changed in openoffice.org:
assignee: nobody → ccheney
status: New → Triaged
Changed in openoffice.org-l10n:
assignee: nobody → ccheney
importance: Undecided → High
status: New → Triaged
Changed in openoffice.org:
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openbabel - 2.2.0-2ubuntu1

---------------
openbabel (2.2.0-2ubuntu1) jaunty; urgency=low

  * debian/control: Build against boost 1.35, so that we can drop the
    older boost (1.34). (LP: #297152)

 -- Martin Pitt <email address hidden> Tue, 27 Jan 2009 16:59:03 +0100

Changed in openbabel:
status: Triaged → Fix Released
Steve Langasek (vorlon) on 2009-01-28
Changed in kdenetwork:
importance: Undecided → High
status: New → Confirmed
Changed in kdepim:
importance: Undecided → High
status: New → Confirmed
Changed in kdepimlibs:
importance: Undecided → High
status: New → Triaged
Changed in kdeplasma-addons:
importance: Undecided → High
status: New → Confirmed
Changed in kdesdk:
importance: Undecided → High
status: New → Triaged
Chris Cheney (ccheney) on 2009-01-28
Changed in openoffice.org:
milestone: none → jaunty-alpha-4
Martin Pitt (pitti) wrote :

I verified that kdepim(libs) build fine against 1.35 and that korganizer still works fine. It even works well in "skewed" libraries, i. e. kdepimlibs built against 1.35 and kdepim built against 1.34.

Thus I demoted boost back into universe, and uploaded boost1.35 with a Provides so that component-mismatches.txt should be satisfied:

boost1.35 (1.35.0-8ubuntu2) jaunty; urgency=low

  * Have libboost1.35-dev Provides: libboost-dev, to aid with the 1.34
    -> 1.35 transition (LP #297152)

 -- Martin Pitt <email address hidden> Wed, 28 Jan 2009 08:11:05 +0100

Thus we do not need immediate rebuilds for those remaining packages, but eventually their build dependencies should still be updated.

Martin Pitt (pitti) wrote :

kdepim (4:4.2.0-0ubuntu3) jaunty; urgency=low

  * Build-dep on libboost1.35-dev, libboost-graph1.35-dev,
    unversioned boost has been moved to universe for some reason

Date: Tue, 27 Jan 2009 18:42:11 +0000
Changed-By: Jonathan Riddell <email address hidden>

Changed in kdepim:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openoffice.org-l10n - 1:3.0.1-1ubuntu1

---------------
openoffice.org-l10n (1:3.0.1-1ubuntu1) jaunty; urgency=low

  * Copy of the openoffice.org source.
    - debian/changelog: Change source name.
    - debian/control.in: Change source name.
    - debian/control: Regenerate control file.

  * Resynchronise with Debian (r1395). Remaining changes:
    - Add Launchpad integration support.
    - Add Launchpad translations support.
    - Add package openoffice.org-style-human.
    - Add some Ubuntu-specific bitmaps. Adjust broffice diversions for these.
    - Add support for compressing debs with lzma.
    - Add support for shared /usr/share/doc directories.
    - Add support to build l10n as a separate source.
    - Add support to build on lpia.
    - Add support to turn off building on sparc.
    - Add Xb-Npp-xxx tags according to "firefox distro add-on suport" spec.
    - Set startcenter.desktop to not display in the menu.
    - Use imagemagick instead of graphicsmagick.
    - openoffice.org-help switch to internal copy of lucene.
    - Add Depends openoffice.org-math to openoffice.org-writer.
      Closes LP: #223476
    - Remove extra ooo-build changelog. Closes LP: #262579
    - boost1.35 transtition. Closes LP: #297152
    - Add & to ooo87965.execute.sh. Closes LP: #313495
    - OOo needs stlport on i386 for extension compatibility.
      Closes LP: #322188
    - calc needs depends on lp-solve since it links to it.
      Closes LP: #322189
  * Resynchronise with ooo-build-3-0-1 (r15230).
    - Update launchpad-integration menu entries. Closes LP: #41694
    - Add indentation to flat odt files. Closes LP: #226075
    - Change code from Err:529 to Err:519. Closes LP: #226457

 -- Chris Cheney <email address hidden> Thu, 29 Jan 2009 01:00:00 -0600

Changed in openoffice.org-l10n:
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openoffice.org - 1:3.0.1-1ubuntu1

---------------
openoffice.org (1:3.0.1-1ubuntu1) jaunty; urgency=low

  * Resynchronise with Debian (r1395). Remaining changes:
    - Add Launchpad integration support.
    - Add Launchpad translations support.
    - Add package openoffice.org-style-human.
    - Add some Ubuntu-specific bitmaps. Adjust broffice diversions for these.
    - Add support for compressing debs with lzma.
    - Add support for shared /usr/share/doc directories.
    - Add support to build l10n as a separate source.
    - Add support to build on lpia.
    - Add support to turn off building on sparc.
    - Add Xb-Npp-xxx tags according to "firefox distro add-on suport" spec.
    - Set startcenter.desktop to not display in the menu.
    - Use imagemagick instead of graphicsmagick.
    - openoffice.org-help switch to internal copy of lucene.
    - Add Depends openoffice.org-math to openoffice.org-writer.
      Closes LP: #223476
    - Remove extra ooo-build changelog. Closes LP: #262579
    - boost1.35 transtition. Closes LP: #297152
    - Add & to ooo87965.execute.sh. Closes LP: #313495
    - OOo needs stlport on i386 for extension compatibility.
      Closes LP: #322188
    - calc needs depends on lp-solve since it links to it.
      Closes LP: #322189
  * Resynchronise with ooo-build-3-0-1 (r15230).
    - Update launchpad-integration menu entries. Closes LP: #41694
    - Add indentation to flat odt files. Closes LP: #226075
    - Change code from Err:529 to Err:519. Closes LP: #226457

 -- Chris Cheney <email address hidden> Thu, 29 Jan 2009 01:00:00 -0600

Changed in openoffice.org:
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdeplasma-addons - 4:4.2.0-0ubuntu2

---------------
kdeplasma-addons (4:4.2.0-0ubuntu2) jaunty; urgency=low

  * Rebuild for boost transition (LP: #297152)
  * Changed build-dep in debian/control libboost-dev -> libboost1.35-dev

 -- Richard Birnie <email address hidden> Sun, 01 Feb 2009 16:30:32 +0000

Changed in kdeplasma-addons:
status: Confirmed → Fix Released
Jonathan Thomas (echidnaman) wrote :

Fix committed in bzr for kdesdk by Richard Birnie.

Changed in kdesdk:
status: Triaged → Fix Committed
Jonathan Thomas (echidnaman) wrote :

Scott Kitterman just fixed this for kdenetwork.

Changed in kdenetwork:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdesdk - 4:4.2.0-0ubuntu2

---------------
kdesdk (4:4.2.0-0ubuntu2) jaunty; urgency=low

  [ Jonathan Thomas ]
  * Make libkrosspython0, kdesdk-strigi-plugins and gettext recommends of
    lokalize as per lokalize/PACKAGING (LP: #323439)

  [ Richard Birnie ]
  * Rebuild for transition boost -> boost1.35 (LP: #297152)
  * Changed build-dep in debian/control libboost-dev -> libboost1.35-dev

 -- Scott Kitterman <email address hidden> Thu, 05 Feb 2009 19:14:58 -0500

Changed in kdesdk:
status: Fix Committed → Fix Released
Jonathan Thomas (echidnaman) wrote :

Adn Riddell took care of kdepimlibs on the 28th.

Changed in kdepimlibs:
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-ports - 2.6.28-1.1

---------------
linux-ports (2.6.28-1.1) jaunty; urgency=low

  [ Luke Yelavich ]

  * SAUCE: Add rebase-ports and retag-ports scripts based on the scripts
    used for the lpia kernel
  * Remove build depends on gcc 4.1 for powerpc and ia64
    - LP: #297152
  * Enable CONFIG_PPC_PASEMI on powerpc64-smp
    - LP: #213668
  * Add the fec_mpc52xx network driver to the nic-modules udeb
    - LP: #201346
  * Changed default TCP congestion algorithm to 'cubic' on i386 and powerpc
    - LP: #278801
  * Enable ALSA subsystem and drivers for i386
    - LP: #308058
  * Turn off abi/module checks for hppa, ia64, and sparc
  * linux-headers packages should depend on, and be symlinked against
    linux-ports-headers
    - LP: #291487

 -- Luke Yelavich <email address hidden> Sat, 07 Feb 2009 03:27:42 +1100

Changed in linux-ports:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.