When Akregator tray icon is clicked when Akregator is open, it does not minimize

Bug #276880 reported by 1cewolf on 2008-10-01
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KDE PIM
Fix Released
Medium
kdepim (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: akregator

I'm running Kubuntu Intrepid.

I believe that the tray icon for Akregator is incorrectly configured. In other applications which have a tray icon, clicking the tray icon when the application is open minimizes the application. When I do this for Akregator, the window disappears for a split-second and then re-appears again. I believe that this behavior may be the result of Akregator trying to "restore" the window again rather than minimize it.

Harald Sitter (apachelogger) wrote :

Very true.
Report needs to be forwarded to http://bugs.kde.org

Changed in kdepim:
importance: Undecided → Low
status: New → Triaged
Giorgos Kylafas (gekylafas) wrote :

Maybe this has something to do with this commit (just guessing here): http://websvn.kde.org/?view=rev&revision=864309

Harald Sitter (apachelogger) wrote :

Good catch, in fact it seems like this change only introduced this issue. Then again apparently before it didn't show the window when it was minimized to tray.
Report still needs to be forwarded, maybe whoever does it can also mention this.

Harald Sitter (apachelogger) wrote :
Changed in kdepim:
status: New → Invalid
assignee: nobody → apachelogger
Giorgos Kylafas (gekylafas) wrote :

According to http://bugs.kde.org/show_bug.cgi?id=171642#c13, r864309 was just reverted for branch 4.1.

Harald Sitter (apachelogger) wrote :

Won't be in 8.10 then :S

Changed in kdepim:
importance: Undecided → Unknown
status: Invalid → Unknown
assignee: apachelogger → nobody
Changed in kdepim:
status: Unknown → Fix Released
Rocco Stanzione (trappist) wrote :

I can confirm this in 8.10. Also the tray icon does nothing when I click it, when it's expected to restore the app.

Giorgos Kylafas (gekylafas) wrote :

I do not experience this bug anymore after an upgrade to the newest intrepid packages for KDE 4.1.3.

Jonathan Thomas (echidnaman) wrote :

Reported fixed.

Changed in kdepim:
status: Triaged → Fix Released
Simon Ruggier (simon80) wrote :

The fixed version is in intrepid-backports, rather than intrepid-updates, so it isn't actually fixed.

Changed in kdepim:
status: Fix Released → Confirmed
Jonathan Thomas (echidnaman) wrote :

Fix committed at least, since the fix has been made upstream and will get in to Jaunty soon enough.

Changed in kdepim:
status: Confirmed → Fix Committed
Giorgos Kylafas (gekylafas) wrote :

Packages for KDE 4.2 beta1 from kubuntu-experimental (http://www.kubuntu.org/node/58) exhibit the same wrong behavior as before: clicking on the system tray icon does not hide akregator to system tray if it is restored, and does not restore it if it is hidden in the system tray.

Giorgos Kylafas (gekylafas) wrote :

Same problem in KDE 4.2 beta 2.

Edmundo (eantoranz) wrote :

Seems like you have said it all, except for this:
If the application is minimized, a click on the tray icon DOES restore it.. and then (inmediately) minimizes it again. As least I do see a flash on my desktop that I'd associate with an application being restored/minimized in a fast succession.

Giorgos Kylafas (gekylafas) wrote :

Problem appears fixed in KDE 4.2 rc1, though.

Harald Sitter (apachelogger) wrote :

Closing. Thank you.

Changed in kdepim:
status: Fix Committed → Fix Released
Sciamano (sciamano72) wrote :

I'm still affected by this bug. :-(
Running Kubuntu Jaunty 9.04
kdepim installed version: 4:4.2.2-0ubuntu1.1

Changed in kdepim:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.