Ubuntu

Help functions return error message when help isn't installed

Reported by Eric Drechsel on 2008-09-24
62
This bug affects 5 people
Affects Status Importance Assigned to Milestone
kdepim (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: kdepim

should kmail perhaps recommend kdepim-doc? For someone looking for a small install without extra bells and whistles (ie kalarm [sic]) installing the whole kdepim package is overkill, but it is a bit shocking when going to the help menu and getting an error message. I understand that this is part of the overall strategy for packaging kde docs, but is it good? Shouldn't installing an application package result in the help for that application being installed as well?

I can see your point so I'll confirm this bug and add it to the wishlist then we can leave it to someone with more experience to decide if this is something that should be changed

Changed in kdepim:
importance: Undecided → Wishlist
status: New → Confirmed
Jonathan Thomas (echidnaman) wrote :

Recommending it would bring it in on the CD, which we unfortunately don't have space for. :(

Changed in kdepim:
status: Confirmed → Won't Fix

One way to handle this would be for kmail to check if the docs are installed. If they aren't it could tell the user which package to install or even better offer him to install the right package. The current situation is just bad in terms of usability (the users most likely needing help or also the users most likely not figuring out the they must install kde-pim-doc by hand).

Jonathan Thomas (echidnaman) wrote :

Might want to reconsider, now that we have the disk space.

Changed in kdepim (Ubuntu):
status: Won't Fix → New
Ralph Janke (txwikinger) on 2010-06-03
Changed in kdepim (Ubuntu):
status: New → Triaged
Matthew Paul Thomas (mpt) wrote :

The problem is not that kmail doesn't include online help; the problem is that it pretends it does. Installing the help is one way to fix the problem, but not the only way.

summary: - kmail doesn't include online help
+ Help functions return error message when help isn't installed
Maarten Bezemer (veger) wrote :

Is this issue still valid?

When I open help (Help -> Kontact Handbook or F1) the KDE Help Center opens, with a page telling 'Documentation not Found'. Including instructions how to find/install the documentation. To me that seems reasonable?

Could you try this as well with a new(er) version installed, and if it solves your issue (or not) let us know?

Changed in kdepim (Ubuntu):
status: Triaged → Incomplete
Robert Simmons (rsimmons0) wrote :

The issue is still valid. The problem is that kdepim is part of the Kubuntu OS, and a fresh install does not include kdepim-doc. In an earlier post echidnaman had said that there is disk space now and to reconsider. I propose looking into making the kdepim package recommend kdepim-doc. This would fix the problem completely. Another suggested solution is to prompt for document installation the first time kontact or any part of the kdepim set of applications is run.

Changed in kdepim (Ubuntu):
status: Incomplete → Triaged
Rohan Garg (rohangarg) wrote :

Hi
Unfortunately for 14.04 we don't have enough disk space again. Maybe post 14.04 we can evaluate a way to install docs if they're not present when a user launches the help section of an application.

tags: added: kubuntu
Rohan Garg (rohangarg) wrote :

Hi
After a bit of discussion this should be resolved upstream rather than in Kubuntu itself. Please file a wishlist bug at https://bugs.kde.org against kdepim.

Thank you!

Changed in kdepim (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers