Kontact crashes if started while already running

Bug #24286 reported by David Johnson on 2005-10-19
22
Affects Status Importance Assigned to Milestone
kdepim (Ubuntu)
Medium
Jonathan Riddell

Bug Description

If 'kontact' is executed while Kontact is already running, around 25% of the
time the existing Kontact instance will simply be maximised and brought to the
front. However, the other 75% of the time the running instance of Kontact
crashes (a new instance doesn't actually start, it just gives an error on the
commnad line).

When this happens, the already running instance of Kontact gives the following
command line output:
FAILURE (KCmdLineArgs):
Application requests for isSet("module") but the "module" option
has never been specified via addCmdLineOptions( ... )

And the command line output from the second instance is:
ERROR: Communication problem with kontact, it probably crashed.

For some reason, this crash isn't caught by the KDE Crash Handler, so I don't
have a backtrace (but can get one, if someone would kindly tell me how to do it
manually).

I'm running Breezy on AMD64 (the bug was also present in Hoary).

Yuriy Kozlov (yuriy-kozlov) wrote :

This bug is not present on my machine running kubuntu dapper amd64. This has probably been fixed for dapper.

Doesn't happen on my machine either (i686).

Yuriy Kozlov (yuriy-kozlov) wrote :

Closing, please reopen if you can reproduce this bug in dapper.

Changed in kdepim:
status: Unconfirmed → Fix Released
Rocco Stanzione (trappist) wrote :

I'm reopening this bug because it is reproducible in dapper with 3.5.4 packages.

Changed in kdepim:
status: Fix Released → Unconfirmed
Rocco Stanzione (trappist) wrote :

This crash is caught by the crash handler, so I'm going to build a -dbg kdepim and try to get a backtrace.

Rocco Stanzione (trappist) wrote :

Bah. I can't reproduce it with freshly built debug packages! It just restores the window as if I'd clicked the kmail icon in the system tray.

Andres Mujica (andres.mujica) wrote :

i've got this problem also, tomorrow i'll put some info (the problem occurrs at the office, where i use kontact)

David Johnson (dj-david-web) wrote :

Just to mention that I'm still seeing this bug (running Edgy on i386).

Piero Ottuzzi (ottuzzi) wrote :

Hi there,

it happens here too: if I open kontact that is already running it crashes immediately.
I'm using Kubuntu EDGY 6.10 with KDE 3.5.5.

Please ask for more info if you need them.

Bye
Piero

John Vivirito (gnomefreak) wrote :

Marking as confirmed.

Changed in kdepim:
status: Unconfirmed → Confirmed

i cant seem to reproduce this on feisty...odd.

Tomasz Czapiewski (xeros) wrote :

I can't reproduce this bug on Feisty, either.

Changed in kdepim:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.