kmail on wily doesnt follow http links

Bug #1500333 reported by Hans-Peter on 2015-09-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KDE PIM
Fix Released
Medium
kdepim (Ubuntu)
Undecided
Unassigned

Bug Description

On wily werewolf: When clicking a http link, mkail says

The file or folder http://...... does not exist.

If I click a link eg. contained in bugzilla mails from the KDE bugtracker, an error dialog appears:

"The file or folder https://bugs.kde.org/show_bug.cgi?id=352015 does not exist."

Reproducible: Always

Steps to Reproduce:
1. Open a mail from the KDE bugzilla.
2. Click a contained link.

Actual Results:
An error dialog with the message:

"The file or folder <URL> does not exist."

Expected Results:
The default browser (or protocol handler, for that matter) opens and shows the clicked URL.

I can't confirm it.
I use all the time it and it works fine.

Mh, ok... It does not work for me. :-( I'm still getting the error dialog only.

Is there anything I could do to debug it / determine the cause?

This look like a race condition:

* Sometimes it works, sometimes it does not.

* The behaviour is independent of the email, ie. using the same email it sometimes works and sometimes fails.

* Even opening a mail and repeatedly clicking the same link contained therein will alternate between opening the link and causing the error dialog.

Just for reference: My machine has an SSD, in case there really is a race condition which could be influenced by disk perfmance.

(In reply to Gunter Ohrner from comment #3)
> This look like a race condition:
> * Sometimes it works, sometimes it does not.

Mh, not really - today it does not work at all, so it somehow seems to be somewhat arbitratily if it always fails or if it randomly fails and sometimes works...

How do I debug something like this?

(In reply to Gunter Ohrner from comment #4)
>
> How do I debug something like this?

You may try running KMail from a console and look at the console output.

if you run `kcmshell5 componentchooser` and look at the web browser section, is the selected browser correct ?

I already checked this, the current setting is

Open http and https URLs
[*] in an application based on the contents of the URL
[ ] in the following Browser: [_______________________________________]

How can I check which application is chosen for what contents? I've not had problems invoking my browser (chromium) from KDE applications so far however and the few times it *does* work from within kMail, chromium is used.

(In reply to Christophe Giboudeaux from comment #5)
> > How do I debug something like this?
> You may try running KMail from a console and look at the console output.

I get the same output that is also shown in the error dialog:

KRun(0xd965c0) ERROR (stat): 111 "The file or folder https://bugs.kde.org/show_bug.cgi?id=352165 does not exist."
KRun(0xd753770) ERROR (stat): 111 "The file or folder https://bugs.kde.org/show_bug.cgi?id=352165 does not exist."

(I clicked twice, one error was logged per click.)

(In reply to Gunter Ohrner from comment #7)
> How can I check which application is chosen for what contents? I've not had
> problems invoking my browser (chromium) from KDE applications so far however
> and the few times it *does* work from within kMail, chromium is used.

`kcmshell5 filetypes` and look at text/html

(In reply to Christophe Giboudeaux from comment #9)
> `kcmshell5 filetypes` and look at text/html

Ok, difficult to say if there may be a problem - "Chromium-Browser" is the configured html viewer, but I cannot display details about this viewer assignment - whenever I click on "edit", no details are shown in the editor dialog, but this happens for all viewer assignments of all mime types. Does this editor even work in KDE 5?

Created attachment 94395
Property editor for MIME viewers/assignments

Stephen Anthony (sa666666) wrote :

This also affects me, under the exact same system. Also, I don't know if it's related, but kmail crashes on any emails containing an attachment.

I'm also getting this bug all the time.

'kcmshell5 componentchooser' says "in an application based on the contents of the URL"

'kcmshell5 filetypes' says it's (allegedly) using Konqueror.

In my .xsession-errors I also see:

KRun(0xedace10) ERROR (stat): 111 "The file or folder http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=802048 does not exist."

Stephen Anthony (sa666666) wrote :

After more research, this now works for me if I enable what application to use to open HTML links in the system settings. However, there is a related bug, in that external images won't load at all within Kmail.

It isn't just restricted to KMail here. If I try to open a URL in Konsole,
KRun(0x2923390) ERROR (stat): 111 "The file or folder http://dl.google.com/ does not exist."

Hans-Peter (hanspeterg) wrote :

Hi Guys, It's 2016 and this annoying bug still exists. It is not even triaged.
And the workaround mentioned by Stephen doesn't work for me. Most links don't have the html suffix (like in https://bugs.launchpad.net/bugs/1500333)

Changed in kdepim:
importance: Unknown → Medium
status: Unknown → New

Seems to work for me now at least with the following software stack:

kMail Version 5.0.3
Unter:
KDE Frameworks 5.18.0
Qt 5.5.1 (kompiliert gegen 5.5.1)
Das xcb Fenstersystem

I will reopen the bug if it re-appears - if any of you still see this with the latest Frameworks and PIM releases, please notify me.

(In reply to Gunter Ohrner from comment #14)

> Seems to work for me now at least with the following software stack:

It's sort of better, but I wouldn't consider it fixed - what is opened is actually (for example using the link for this bug in the email that was triggered by your comment):

/home/chris/.cache/kioexec/krun/3830_0_show_bug.cgi

rather than the proper URL, consequently the page is not rendered correctly.

> I will reopen the bug if it re-appears - if any of you still see this with
> the latest Frameworks and PIM releases, please notify me.

I'm on the latest version from Kubuntu (via their backports PPA which was updated only a few days ago) which is:

KMail 5.0.2
KDE Frameworks 5.18.0
Qt 5.5.1 (built against 5.5.1)
The xcb windowing system

They don't appear to have KMail 5.0.3 yet, when was that released?

thanks!
Chris

(In reply to Chris Samuel from comment #15)
> (In reply to Gunter Ohrner from comment #14)
> > Seems to work for me now at least with the following software stack:
> It's sort of better, but I wouldn't consider it fixed - what is opened is
> actually (for example using the link for this bug in the email that was
> triggered by your comment):
>
> /home/chris/.cache/kioexec/krun/3830_0_show_bug.cgi
>
> rather than the proper URL, consequently the page is not rendered correctly.

I'm currently not observing this.

> > I will reopen the bug if it re-appears - if any of you still see this with
> > the latest Frameworks and PIM releases, please notify me.
> I'm on the latest version from Kubuntu (via their backports PPA which was
> updated only a few days ago) which is:

I'm also using Kubuntu and currently am experimenting with the KDE Applications Staging PPA:

https://launchpad.net/~kubuntu-ppa/+archive/ubuntu/staging-kdeapplications/

Changed in kdepim:
status: New → Fix Released
Hans-Peter (hanspeterg) wrote :

Had to change in System Settings -> Default Applications -> Web Browser

Open http and https Urls

from "in an application based ...."
to "in the following browser" <choose firefox>

I consider this as a workaround. But it is working at least ...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.