Error when creating IMAP Folder for ressources

Bug #128643 reported by wywid on 2007-07-27
6
Affects Status Importance Assigned to Milestone
KDE PIM
Fix Released
Medium
kdepim (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdepim

When I use Kontact with my IMAP provider for storing calendar and contact ressource I have an error (in french) :

"
KMail a trouvé les dossiers de travail en groupe suivants dans « INBOX » et doit effectuer les opérations suivantes :
Agenda : aucun dossier trouvé. Il sera créé.
Tâches : aucun dossier trouvé. Il sera créé.

Si vous ne souhaitez pas effectuer cela, annulez simplement cette opération, et la ressource IMAP sera désactivée.
"

In english, it say that he have found groupware folders in "INBOX" but that "Agenda" and "Tâches" folders doesn't exists. It's wrong ! I saw this folder in my webmail clients !

When I click to "continue" nothing happen, but when I launch Kontact another time, it report me the same error.

Perhaps I've forgotten anything ?

Thanks !

Note 1 : My provider is OVH one of the leading providers in france

Note 2 : Here's the console output if it can help ! (:))

kmail: WARNING: bodyDecoded: unknown encoding 'us-ascii'. Assuming binary.
kmail: WARNING: bodyDecoded: unknown encoding 'us-ascii'. Assuming binary.
kmail: WARNING: bodyDecodedBinary: unknown encoding 'us-ascii'. Assuming binary.
kmail: WARNING: bodyDecoded: unknown encoding 'us-ascii'. Assuming binary.
kmail: WARNING: bodyDecoded: unknown encoding 'us-ascii'. Assuming binary.
kmail: WARNING: bodyDecodedBinary: unknown encoding 'us-ascii'. Assuming binary.
kmail: WARNING: bodyDecoded: unknown encoding 'us-ascii'. Assuming binary.
kmail: WARNING: bodyDecoded: unknown encoding 'us-ascii'. Assuming binary.
kmail: WARNING: bodyDecodedBinary: unknown encoding 'us-ascii'. Assuming binary.

Michael Gliwinski (tzeentch-gm) wrote :

Having the same problem here. I'm using kmail 1.9.6 with kontact 1.2.4 with KDE 3.5.6 on kubuntu-feisty 7.04 amd64. This problem exists at least since edgy as I've been experiencing the same then. I'm using m$ exchange in disconnected imap mode with groupware functionality enabled and resources for contacts, calendar and todo set to use 'IMAP server via Kmail'.

What happens is when kontact/kmail is opened it rewrites the config file `$KDEDIR/share/config/kmailrc' but does not save the `ImapPath' property for Contacts and Journal (actually saves an empty string). When you reopen kmail it will think these paths don't exist and will display the message and try to create them (which obviously fails). Only solution I've found is to manually fix `ImapPath' for Contacts dir (e.g. to `/Contacts/') and Journal (to `/Journal/') before starting kmail.

Also sometimes (can't pin it down exactly) kmail removes entries for Contacts dir and Journal dir and entries from `[GroupwareFolderInfo]' related to Contacts and Journal from its config file. Reopening kmail usually recreates them but then you have to close it again and fix the above mentioned ImapPaths manually.

I'll be happy to provide more information if needed.

Michael Gliwinski (tzeentch-gm) wrote :

OK, I've found when kmail removes the dir entries for Contacts and Journal and entries from [GroupwareFolderInfo]. It does that every time you go to Settings -> Configure Kontact and change some setting (regardless of component, e.g. it can be in calendar or notes).

Then it will recreate all those next time you open kontact but with blank `ImapPath' entries for Contacts dir and Journal dir.

Richard Johnson (nixternal) wrote :

Confirming due to response, and I kind of guessed it was due to encoding before I even read the command line copy you supplied. I will check upstream on this, however I know there are a lot of encoding bugs reported.

Can you confirm this issue is still around in both Gutsy and Hardy? Thanks everyone!

Changed in kdepim:
assignee: nobody → nixternal
status: New → Confirmed
Changed in kdepim:
status: Unknown → New
Changed in kdepim (Ubuntu):
assignee: Richard Johnson (nixternal) → nobody
Michael Gliwinski (tzeentch-gm) wrote :

Just a note that this no longer happens on Lucid (KMail 1.13.2) for me.

Harald Sitter (apachelogger) wrote :

Marking fixed then.

Changed in kdepim (Ubuntu):
status: Confirmed → Fix Released
Changed in kdepim:
status: New → Fix Released
Changed in kdepim:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.