[Oneiric] Kdenlive configuration vizard doesn't founding MLT SDK

Bug #863186 reported by Attila Hammer on 2011-09-30
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
kdenlive (Debian)
Fix Released
Unknown
kdenlive (Ubuntu)
Medium
Unassigned

Bug Description

Hy,

I newer use Kdenlive, but because in Oneiric begin part of the QT a11y bridge, I would like try this application for screen reader.
I simple installed kdenlive package.
When I first launch the application, in configuration vizard window I see only a message, with Kdenlive doesn't found with MLT SDK.

I attaching a screenshot with the actual window.
I installed all upgrades with my Oneiric system.
I want try Kdenlive, because I would like doing from some .jpg files with a video with are containing both the images and sound tracks, and hear good thinks this application.

Attila

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: kdenlive 0.8-4build1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu2
Architecture: i386
Date: Fri Sep 30 13:00:06 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110921.2)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=hu_HU.UTF-8
 LC_MESSAGES=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: kdenlive
UpgradeStatus: No upgrade log present (probably fresh install)

Attila Hammer (hammera) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kdenlive (Ubuntu):
status: New → Confirmed
Sergey Snitsaruk (narren96c) wrote :

Same thing happened to me.
Then I used my old .kde/share/config/kdenliverc and kdenlive starts fine now. It seems config wizard could not detect mlt lib.

Sergeis, temporary what can I need write this file with you wrote?

Attila

Sergey Snitsaruk (narren96c) wrote :

If you want to bypass configuration wizard, you need a proper configuration file inside .kde/share/config/ in your home directory.
If somehow you have a backup of this file, use it, or I can send you mine.

Attila Hammer (hammera) wrote :

If not a big request, please send me this file, because prewious I
doesn't use Kdenlive.
If you are better would like, enough to attach this file with this report.

Attila

Nicksha (nicksha) wrote :

For me, the workaround that worked was to create an empty ~/.kde/share/config/kdenliverc file, and add just the following two lines:

[version]
version=0.8

Julian Clark (julian.clark) wrote :

I read elsewhere (see: <http://kdenlive.org/forum/cant-start-kdnlive-sdl-module-missing-mlt>) that the reason why the error comes up with the Kdenlive configuration wizard is that the current version of MLT outputs to stdout, and that the version of Kdenlive in question here looks for MLT to output to stderr. The code for the wizard has been adjusted in Kdenlive trunk (upcoming version 0.8.2) to account for the change in MLT (instead of using a command-line tool, Kdenlive will tap directly into the API of MLT). Basically, this will be fixed in 0.8.2 -- once one other last lingering bug in that version gets resolved.

Philip Muškovac (yofel) wrote :

Fixed in precise.

kdenlive (0.8+svn5945-1) unstable; urgency=low

  * New upstream svn snapshot.
    - Fixed MLT 0.7.4 incompatibility.
      Closes: #636933
    - Also install new documentations.
  * Add missing makefile targets build-arch and build-indep.
 -- Ubuntu Archive Auto-Sync <email address hidden> Mon, 17 Oct 2011 11:01:17 +0000

Changed in kdenlive (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Fix Released
Changed in kdenlive (Debian):
status: Unknown → Fix Released

It is not fixed in Oneric.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.