Ubuntu

kdenlive crashes with SIGSEV 11 upon starting

Reported by Michael Chalvatzis on 2009-04-18
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
kdenlive (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdenlive

I just upgraded to the latest version of MLT (03.8) via aptitude. I'm running kubuntu jaunty 9.04.
kdenlive ran fine yesterday but now after this update I get only crashes upon the starting of kdenlive.
I installed the dbg version of kdenlive, but still no useful backtrace.

Any ideas or help?

Thanks, Michael

This backtrace appears to be of no use.
This is probably because your packages are built in a way which prevents creation of proper backtraces, or the stack frame was seriously corrupted in the crash.

[Thread debugging using libthread_db enabled]
[New Thread 0x7f873a865750 (LWP 7139)]
0x00007f8736707cf0 in __nanosleep_nocancel () from /lib/libc.so.6
[Current thread is 0 (process 7139)]

Thread 1 (Thread 0x7f873a865750 (LWP 7139)):
#0 0x00007f8736707cf0 in __nanosleep_nocancel () from /lib/libc.so.6
#1 0x00007f8736707b47 in __sleep (seconds=<value optimized out>) at ../sysdeps/unix/sysv/linux/sleep.c:138
#2 0x00007f8739c43b1f in KCrash::startDrKonqi (argv=0x7fff4289a1a8, argc=17) at /build/buildd/kde4libs-4.2.2/kdeui/util/kcrash.cpp:412
#3 0x00007f8739c4442a in KCrash::defaultCrashHandler (sig=11) at /build/buildd/kde4libs-4.2.2/kdeui/util/kcrash.cpp:337
#4 <signal handler called>
#5 0x00007f8726db283d in ?? () from /lib/libselinux.so.1
#6 0x00007f8726da52ff in ?? () from /lib/libselinux.so.1
#7 0x000000000247a208 in ?? ()
#8 0x0000000000000000 in ?? ()
#0 0x00007f8736707cf0 in __nanosleep_nocancel () from /lib/libc.so.6

summary: - kdenlive crashes with SIGSEV 11 opun starting
+ kdenlive crashes with SIGSEV 11 upon starting
description: updated

happens to me too.

here's the console output:

kdenlive(6890) MainWindow::parseProfiles: RESULTING MLT PATH: "/usr/share/mlt/profiles/"
kdenlive(6890) initEffects::parseEffectFiles: // INIT EFFECT SEARCH
kdenlive(6890) Render::Render: ////////// USING PROFILE: dv_pal
kdenlive: symbol lookup error: kdenlive: undefined symbol: _ZN3Mlt8ConsumerC1ERNS_7ProfileEPcS3_

Changed in kdenlive (Ubuntu):
status: New → Confirmed
Olivier Banus (sunab) wrote :

same problem here,

 the new package version of mlt (0.3.8-0ubuntu2) seem to be the cause of the crash, with the previous package version all was ok.

Rob van den Berg (rghvdberg) wrote :

this is what I get when I lauch kdenlive from the command line

~$ kdenlive
kdenlive(15546) MainWindow::parseProfiles: RESULTING MLT PATH: "/usr/share/mlt/profiles/"
kdenlive(15546) initEffects::parseEffectFiles: // INIT EFFECT SEARCH
kdenlive(15546) Render::Render: ////////// USING PROFILE: hdv_1080_50i
kdenlive: symbol lookup error: kdenlive: undefined symbol: _ZN3Mlt8ConsumerC1ERNS_7ProfileEPcS3

running (testing) jaunty 2.6.28-3-rt amd64

Olivier Banus (sunab) wrote :

kdenlive new package version 0.7.3-0ubuntu2 is in the repos and solves the crash on startup, at least on my computer...

someone else can confirm it? and then this bug will be closed.

Changed in kdenlive (Ubuntu):
status: Confirmed → Fix Committed
lemmy (lemmyg) wrote :

Solved for me. Thanks

Rob van den Berg (rghvdberg) wrote :

Solved for me too. Thnks

Olivier Banus (sunab) on 2009-04-18
Changed in kdenlive (Ubuntu):
status: Fix Committed → Fix Released
Michael Chalvatzis (glykos) wrote :

hmmm,

unfortunately on my machine the new version of the package does not fix the problem. maybe I miss something more in general.

if I look at my startup of kdenlive I miss your entries like:
(...)
kdenlive(xxx) initEffects::parseEffectFiles: // INIT EFFECT SEARCH
kdenlive(xx) Render::Render: ////////// USINGÂ PROFILE: hdv_1080_50i
kdenlive: symbol lookup error: kdenlive: undefined symbol: _ZN3Mlt8ConsumerC1ERNS_7ProfileEPcS3
(...)

my startup looks like this:
~$ kdenlive
kdenlive(5498) MainWindow::parseProfiles: RESULTING MLT PATH: "/usr/share/mlt/profiles/"
KCrash: Application 'kdenlive' crashing...
sock_file=/home/chalvatz/.kde/socket-shining/kdeinit4__0

why do I not reach the point of the initEffects row? Did I delete something? How can I restore or cleanup correctly?

Thanks for your ideas and help,

cheers, Michael

Olivier Banus (sunab) wrote :

Thanks a lot to Anthony Mercatante, the packager of kdenlive and mlt packages for Jaunty.

Olivier Banus (sunab) wrote :

 hi michael,

Try to clean all references of kdenlive in the .kde hidden directory of your Home directory.
and if you are working with Gnome desktop you can clean the entire .kde directory, all needed files will be recreated after the next application start.

personnally I work under gnome and I don't have any ".kde/socket-shining" directory ...

hoping it sloves your problem.

Michael Chalvatzis (glykos) wrote :

well, I cleaned up everything up and it still does not work.

I use kubuntu and maybe this problem is kubuntu specific. can someone confirm that the new package fixes the problem on kubuntu, too?

Olivier Banus (sunab) wrote :

I think about one thing,

try to create a new user on your system, to have a clean home directory. Log in this new session and launch kdenlive to see if it works ...

if it does work you have a configuration problem on your first session
if it does not there is a kubuntu specific problem to identify

Michael Chalvatzis (glykos) wrote :

well, done so and still no success.

here the output of the console:
testuser@shining:~$ kdenlive
kdenlive(14818) MainWindow::parseProfiles: RESULTING MLT PATH: "/usr/share/mlt/profiles/"
KCrash: Application 'kdenlive' crashing...
sock_file=/home/testuser/.kde/socket-shining/kdeinit4__0

and just for your verification:
testuser@shining:~$ dpkg --list |grep kdenlive
ii kdenlive 0.7.3-0ubuntu2 a non-linear video editor
ii kdenlive-data 0.7.3-0ubuntu2 a non-linear video editor (data files)

what else can I do to help finding the solution.

the new kdenlive package makes it start again also for me (didn't test anything else but starting it so far).
Michael probably you can open another bug for your problem :-(

Anthony Mercatante (tonio) wrote :

Michael,

Your cmdline output indicates you are using version 0ubuntu1 of kdenlive package, with an up to date mlt.
I bet your problem will be fixed when you'll get 0ubuntu2 version of kdenlive.

Can you confirm this to me pasting the result of this command please:
apt-cache policy kdenlive

Thanks

Anthony Mercatante (tonio) wrote :

Another option would we to purge and reinstall your kdenlive package, I guess...

Michael Chalvatzis (glykos) wrote :

Hi Anthony,

thanks for your reply. I'm affraid that I did already everything that you suggested.
Here is the output of the apt-cache command
~$ apt-cache policy kdenlive
kdenlive:
  Installed: 0.7.3-0ubuntu2
  Candidate: 0.7.3-0ubuntu2
  Version table:
 *** 0.7.3-0ubuntu2 0
        500 http://de.archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

what I just found out is the following:
I miss the package "frei0r" in my repositories. Is this a mandatory package for kdenlive?
And why do I miss this package?
I just ran the command suggested on the website "http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/pre-compiled-packages/ubuntu-packages":
sudo apt-get install kdenlive dvgrab frei0r swh-plugins libfaad0

and I get the following message:
sudo apt-get install kdenlive dvgrab frei0r swh-plugins libfaad0
Reading package lists... Done
Building dependency tree
Reading state information... Done
kdenlive is already the newest version.
dvgrab is already the newest version.
Package frei0r is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package frei0r has no installation candidate

What I have installed is the package "frei0r-plugins" !!! Is this the same?
I do not get the package "frei0r" offered.

As I said before I run kubuntu. Can someone confirm that the new package works with kubuntu?

I attached my sources.list. Maybe I miss an important repository.

Thank you all for your help

Michael Chalvatzis (glykos) wrote :

guys,

finally I found the trick that worked for me too. it is described by C.A.B. in this bug report:
https://bugs.launchpad.net/ubuntu/+source/kdenlive/+bug/363430

one exception I still have on the description. reinstalling the frei0r-plugins package makes kdenlive still to crash.
so I will leave frei0r-plugins deinstalled until it is really necessary receommended by kdenlive...

Maybe someone fixes the entry on the webpage "http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/pre-compiled-packages/ubuntu-packages" with the wrong and non-existent package name "frei0r".

cheers, Michael

solved for me too now.

I had the same Michael problem, and i solved it unistalling frei0r-plugins.
I'm using kubuntu 9.04 jaunty.

Thanks Michael and others!!!.

Regards, Maximiliano

Gnurou (gnurou) wrote :

I confirm this workaround too. I was unable to use kdenlive for weeks because of this problem. Uninstalling frei0r-plugins did the trick. Thanks a lot!

Murz (murznn) wrote :

Confirm solving this bug after unistalling frei0r-plugins on Kubunty Jaunty i686!
Before uninstalling I see at startup:
$ kdenlive
KCrash: Application 'kdenlive' crashing...
sock_file=/home/murz/.kde/socket-mesh/kdeinit4__0

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments