Ubuntu

[Wish]Please include Kdenlive 0.7 for kde4 in the repo´s

Reported by Wesley Velroij on 2008-09-11
88
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Intrepid Ibex Backports
Undecided
Unassigned
kdenlive (Ubuntu)
Wishlist
Scott Kitterman

Bug Description

Hello, i like it that kubuntu included the Showfoto beta, but i also would wish to see the kdenlive beta as soon as they release it in kubuntu 8.10.

Kdenlive is on off the better non linear video editing tools under kde and it would be nice if its already in kubuntu 8.10 that would make kubuntu more complete.

Related branches

Jeremy Wilkins (wjeremy) wrote :

I second that. Kdenlive brings an impressive feature set for KDE video editing, and I think the app will mature best under the new KDE4 platform. Currently however, I can't even get it to load in intrepid. It just crashes when it reaches the main display. Other than the Intel network NIC NVM wipe blunder of kernel 2.6.27, I have found Intrepid more workable and more stable in alpha on all my systems than Hardy is even now and I expect many will ditch Hardy as a result (I have already). However, Intrepid ONLY has KDE4 now. If kdenlive is not included, it may drift into obscurity and be forgotten as some other apps take its place.

Wesley Velroij (velroy1) wrote :

The Kdenlive beta is released and the final version is exspected to be released end October. Please include it in Intripid, and if someone wants to create a ppa i would very much like that.

Samuel J Sarette (lunarcloud) wrote :

Give us a ppa for use in intrepid to debug it for inclusion in Jaunty?

Throwing it in the repos for intrepid would be awesome, but I'll settle for anything deb that works.

Javier Jardón (jjardon) wrote :

Kdenlive 0.7 for KDE4 was released.
Debian packages are available on Christian Marillat repositories. (http://debian-multimedia.org/dists/unstable/main/binary-i386/package/kdenlive.php)

Please add this to *any* repo so we can debug it for Jaunty! As above, PPA's would be amazing, but even just deb's available would be great.

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
There is a known issue just discovered where the debian-multimedia.org packages don't run properly on Ubuntu (although Kubuntu's fine) without backports enabled and updated. We need *Ubuntu deb's!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

After games, video editing is the number 1 reason I hear people say that they still need Windows / Mac. I'm using Kdenlive 0.7 compiled from source and it's great.

It's here now and would benefit Linux Video Editing hugely.

Thankyou!

ChrisLees (christopher-lees) wrote :

It's probably not appropriate to raise a bug report for this, but I think it's important to put the new Kdenlive into the Ubuntu 8.10 Backports repository, at least. Or if you're concerned about it, just keep it in Proposed. Kdenlive 0.6 is not very usable due to the crashes.

p1ngu1n (vincent-barberet) wrote :

Compared to previous version, kdenlive 0.7 is more stable and fully usable (daily use !).

Bellegarde (laurent-bellegarde) wrote :

Hi everyone,

It should be an excellent idea to package in deb kdenlive 0.7 as the software is now completly stable.

I understand that the wish is for Intrepid but i think a deb package for Hardy and Intrepid is a better way, because we are doing our best to improve first hardy release as the LTS.

We left a good/stable and easy install package for this software.

Thank's for the packaging work,

Laurent, lprod.org team

easily video editing under gnu/Linux : www.lprod.org

piksi (piksi) wrote :

I second all the previous posts suggesting kdenlive 0.7 into the repo. It's an awesomely easy and useful editing tool and a great addition for kde4. Please include it!

Dan MacDonald (allcoms) wrote :

KDEnlive 0.7.x being available in the official Ubuntu repos would be a massive step forward for not only Linux multimedia production but the free software movement as a whole as 0.7 represent a huge step (complete re-write) of KDEnlive and finally we have the fast, easy to use, well-designed and capable FOSS NLE that everyone has wanted since the dawn of desktop Linux.This is major stuff indeed!

The other big two massive boosts to the multimedia capability of Ubuntu tat COULD make it into Jaunty are the inclusion of winff for easy video conversion (very nearly in now I hear) and LMMS 0.4, which has also undergone a significant overhaul since its 0.3 series and is comparable to KDEnlive in its scope, importance and development whilst having a closely related purpose (easy FOSS music production)

+10!

danboid

Dmitriy Volk (dmitriy-volk) wrote :

Please, please, please!

Shaved Wookie (shavedwookie) wrote :

Because Intrepid's been released already, we can only get it into Backports on Intrepid, which requires having it in Jaunty Universe first. This requires someone packaging it for Ubuntu, which seems to be underway over at https://bugs.launchpad.net/getdeb.net/+bug/279738 .Adding your voice, subscribing and clicking "Affects Me" just under the "Importance" column at the top of the screen may help encourage them . :)

buu700 (buu700) wrote :

For what it's worth, I recently used Kdenlive under Sid for a project, and it was simply brilliant. However, it did crash a lot, so I had to be paranoid and save constantly, though I can't tell if this was because of something in Sid or just because the new Kdenlive is unstable.

Kellogs (jm-poure) wrote :

Dear Friends,

I am part of Kdenlive team.

Kdenlive recommended version is 0.7.
Previous kdenlive versions are unstable and deprecated.
We will not support them any more.

Until Ubuntu provides Kdenlive 0.7,
we recommend users to migrate to Debian SID.

Read:
http://www.kdenlive.org/link/ubuntu-gnulinux

Maybe Ubuntu is not a multimedia system.
If not, do not include Kdenlive 0.7 in your repos.
Otherwize, make the minimum efforts of looking at Christian Marillat packages.

The Debian packages can be suited to Ubuntu needs quite easily.
So there is no reason why Ubuntu users should wait ages before using Kdenlive 0.7

Kind regards,
Jean-Michel

Didier Roche (didrocks) wrote :

Jean-Michel,

Please undertand also the Ubuntu release process and that we can't ship a new version on a stable release, unless it fixes a very unusable version.

Kdenlive 0.7 has been shipped few days ago intrepid release, far far away from our freeze process were we only fix bugs. The same happened for OOo 3.

Well… the road is opened for jaunty and I will take a look at it in the few weeks coming.

PS: I must admit I do not appreciate the "do it… or we will told everyone to use debian…". Debian is great, but you use the marilla repos, not debian official one (from which, kdenlive would be automatically merged into Ubuntu…)

Changed in kdenlive:
assignee: nobody → didrocks
Didier Roche (didrocks) on 2008-12-13
Changed in kdenlive:
status: Confirmed → In Progress

I'm not in agree with Jean-Michel Pouré about Debian vs, Ubuntu issue...
but it is true kdenlive 0.7 is a very good software.

Then, I think is very important to put kdenlive in jaunty and backport it in Intrepid very soon.

Shaved Wookie (shavedwookie) wrote :

Hey Didier,

Please don't take the previous comment as representative of the whole Kdenlive project. While Kdenlive 0.7 does, in fact, fix a very unusable previous version (just Google "Kdenlive" with the word "unstable"), Ubuntu's release schedule is understandable. Some kind of PPA for Intrepid though would respect this schedule and allow users to debug Kdenlive for Jaunty inclusion. Best of all, packages for Intrepid (including dependencies) are already available at:
http://ubuntuforums.org/showthread.php?p=6367391

From a happy Kdenlive 0.7 *and* Kubuntu user. :)

Didier Roche (didrocks) wrote :

No problem Shaved & Guido ;)

I put some hard work on the entire Saturday and it seems that the package is almost ready for jaunty. Just a little thing to fix up and I think it will be ready within this week (for jaunty).

Shaved Wookie (shavedwookie) wrote :

Hail to the King, Baby!

Hey Didier, FYI, and at the risk of getting lynched by other impatient users wanting Kdenlive 0.7, I'm wondering if it's worth holding off juuuust a little given that Kdenlive 0.7.1 is due to come out in only 10 days.

They've added a number of new features such as the spacer tool, improved screen capture and a substantial number of bugfixes. I'm not sure this is any harder than packaging 0.7 or not, and obviously *any* 0.7.x version is better than none, but if we may not see an updated package after this for a while, and it *isn't* any harder, it would be nice to have people using the most stable version possible.

Didier Roche (didrocks) wrote :

Hi Shaved,

That's not really no problem. We are in syncing from debian (but as I told previously, as this package is not in the official debian repos, we cannot sync automatically and all is manual) and there is no problem to upload one version, and then, seek for a new one.

But even if I upload this version, we can see then if the new one can be synced after (the delta of work will be very little, I hope, once kdenlive0.7 properly packaged).
So, just keep me in touch (in opening a new bug and subscribing me, if this one is first uploaded) and I will take a look about it

Shaved Wookie (shavedwookie) wrote :

Awesome.

Thanks Didier, it's appreciated. I'll make sure you're kept up to date on 0.7.1. Enjoy the holidays.

Didier Roche (didrocks) wrote :

Done, here is the debdiff with debian marillat's version:
  * Merge from debian-multimedia (LP: #269191). Remaining changes:
    - debian/copyright: add some copyright information
    - Suggest ffmpeg (needed for firewire capture)
    - added quilt patches system in debian/rules and .pc/.version
  * 01_desktop_file.patch: delete deprecated entries from kdenlive.desktop
    (LP: #173754)
  * Adapt version number for libmlt++-dev, libavcodec-dev and libavformat-dev
    dependencies
  * Add libmlt-dev dependency

Didier Roche (didrocks) wrote :

marillat's version available at http://debian-multimedia.org/pool/main/k/kdenlive/kdenlive_0.7-0.0.dsc

(I don't attach ubuntu2ubuntu debdiff version takes more than 19 MiB)

Changed in kdenlive:
assignee: didrocks → nobody
status: In Progress → Confirmed
Didier Roche (didrocks) wrote :

New debdiff with some fixes, as conflicts/replaces as now -data package is removed.
Tested successfully on an ubuntu jaunty VM

kdenlive (0.7-0.0ubuntu1) jaunty; urgency=low

  * Merge from debian-multimedia (LP: #269191). Remaining changes:
    - debian/copyright: add some copyright information
    - Suggest ffmpeg (needed for firewire capture)
    - added quilt patches system in debian/rules
  * 01_desktop_file.patch: delete deprecated entries from kdenlive.desktop
    (LP: #173754)
  * Add Conflicts/Replaces fields against kdenlive-data dropped package
  * Adapt version number for libmlt++-dev, libavcodec-dev and libavformat-dev
    dependencies
  * Replace mlt by libmlt-data and add inigo needed dependency

Changed in kdenlive:
assignee: nobody → kitterman
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdenlive - 0.7-0.0ubuntu1

---------------
kdenlive (0.7-0.0ubuntu1) jaunty; urgency=low

  * Merge from debian-multimedia (LP: #269191). Remaining changes:
    - debian/copyright: add some copyright information
    - Suggest ffmpeg (needed for firewire capture)
    - added quilt patches system in debian/rules
  * 01_desktop_file.patch: delete deprecated entries from kdenlive.desktop
    (LP: #173754)
  * Add Conflicts/Replaces fields against kdenlive-data dropped package
  * Adapt version number for libmlt++-dev, libavcodec-dev and libavformat-dev
    dependencies
  * Replace mlt by libmlt-data and add libmlt-dev, inigo dependencies

kdenlive (0.7-0.0) unstable; urgency=low

  * New upstream release.
  * Add frei0r in Recommends.

kdenlive (0.5.svn20080420-0.2) unstable; urgency=low

  * Recommends dvgrab (>= 3.1)
  * rebuild against latest libmlt.

kdenlive (0.5.svn20080420-0.1) unstable; urgency=low

  * Should depends on mtl.
  * Install the documentation by hand cmake don't do that.

kdenlive (0.5.svn20080420-0.0) unstable; urgency=low

  * New svn release (1919) for new mlt and ffmpeg packages.

 -- Didier Roche <email address hidden> Sat, 20 Dec 2008 01:03:28 +0100

Changed in kdenlive:
status: In Progress → Fix Released
Shaved Wookie (shavedwookie) wrote :

Thanks for your work on this!

I noticed the part that says "-Suggest ffmpeg (needed for firewire capture)". My understanding is that FFMPEG is actually mandatory for rendering anything in Kdenlive and was wondering if this was supposed to refer to DVgrab, which is optional, but required if firewire capture is needed?

If you like, I'd be happy to confirm this on the Kdenlive development mailing list?

Scott Kitterman (kitterman) wrote :

It's easier to keep the upgrade and backports requests separate for us, so I'm marking this invalid for backports. You can follow the backports requst in Bug #298084.

Changed in intrepid-backports:
status: New → Invalid
Steve Stalcup (vorian) wrote :

@Shaved Wookie,

Thanks for bringing that up. After discussing the situation with Scott Kitterman on IRC (and a bit of testing and research) the decision was made to move ffmpeg from a Suggests to a Depends.

Thanks for your help!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions