no icons on ubuntu 15.10. ; program freezes often "clip couldn't be updated"

Bug #1519099 reported by Jörg Arndt on 2015-11-23
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Kdenlive
Fix Released
High
kdenlive (Ubuntu)
Medium
Unassigned

Bug Description

Xubuntu 15.10

Could not lock file: "/home/jwarndt/.local/share/stalefiles/kdenlive/_untitled.kdenliveiLzfile_%2Fhome%2Fjwarndt%2FArndt-Daten%2FVideosVxzB7iLz"
Invalid playlist
Removing cache at "/home/jwarndt/.cache/kdenlive-thumbs.kcache"
Invalid playlist
QCursor: Cannot create bitmap cursor; invalid bitmap(s)
Invalid playlist
Invalid playlist
Invalid playlist
[swscaler @ 0x7f770831ff20] Warning: data is not aligned! This can lead to a speedloss
+ ++ INSERT DROP: 0 / QPointF(2587.08,6)
// DROP 2: ("1")
+ ++ INSERT DROP: 1 / QPointF(0,67)
// DROP 2: ("1")
"Clip kann nicht aktualisiert werden (Zeit: 0, Spur: 3)"

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: kdenlive 4:15.08.2.1~really15.08.1-0ubuntu2
ProcVersionSignature: Ubuntu 4.2.0-18.22-generic 4.2.3
Uname: Linux 4.2.0-18-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
CurrentDesktop: XFCE
Date: Mon Nov 23 22:02:12 2015
InstallationDate: Installed on 2015-06-22 (154 days ago)
InstallationMedia: Xubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422.1)
SourcePackage: kdenlive
UpgradeStatus: Upgraded to wily on 2015-11-10 (12 days ago)

Kdenlive 15.08.2

Cannot move or resize any picture clip in the timeline.

Reproducible: Always

Steps to Reproduce:
- Open a new project
- Add a picture to the resources (via drag and drop or via the menu)
- Move the picture to any time line
- Try to resize or move the picture in the time line

Actual Results:
- Deadlock happens (see backtrace)

Expected Results:
- I can move or resize the clip

Created attachment 95007
Deadlock backtrace

*** Bug 354045 has been marked as a duplicate of this bug. ***

Wow :(
A race condition was fixed in master, and backported to release branch... but incompletely!
15.8.2 got released in this broken state.
I just completed the patch, available in git "Applications/15.08" branch, let's see now how to distribute / propagate this fix to users...
Sorry for that poor situation,
Vincent.

Jörg Arndt (noebian) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kdenlive (Ubuntu):
status: New → Confirmed
Patola (patola) wrote :

The icons do not appear in Unity, but they show up if you are in Plasma Desktop.

Patola (patola) wrote :

Same version of KDENlive with the same source file. I just logged out of plasma and logged in to Unity, I didn't even reboot, and now the icons do not appear.

Patola (patola) wrote :

Just an info to whoever is subscribed to this bug: this problem does not occur on the kdenlive version of ppa:vpinon/kdenlive-testing - and it also has not crashed yet as I have tested, whilst the official ubuntu wily version crashes almost every time I am doing or selecting a title clip (shame on you, canonical! This software should not be unstable, you should be more diligent on ensuring stability for your users; the fact that a voluntary-compiled 'testing' version of the same software works better than yours is testimonial to your sloppy testing procedure. Or maybe you are bad in getting feedback from your users, my own bug requests are left unattended for a long period).

Jörg Arndt (noebian) wrote :

that works!!!
Thank you so much!

Teo Romera (teoromera) wrote :

Great info, thanks!

Changed in kdenlive (Ubuntu):
importance: Undecided → Medium

@ patola: It's always better to quote the public adress of the ppa in addition, since things may change:

https://launchpad.net/~vpinon

Thanks Patola, I go to try the PPA vpion. I install UbuntuStudio 15.10 and kdenlive not has icons, however dolphin not has icons I don't understant why

Bugs have been taken care of upstream: https://kdenlive.org/node/9449

Changed in kdenlive:
importance: Unknown → High
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.