Kopete overloads system

Bug #82799 reported by Joel Mulligan on 2007-02-02
4
Affects Status Importance Assigned to Milestone
KDE Network
New
Wishlist
kdenetwork (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: kopete

If a contact attempts to send the user a large number of files kopete will continue opening "Accept File Transfer?" windows to the point where it begins to use enormous amounts of memory and cpu time. This isnt really a bug more a feature request I guess, there should be some way to stop a malicious contact from attempting to crash your msn session by sending large numbers of files (it ends up fully crashing/hanging kde/the system because kopete handles file transfers differently to the native msn client).

Changed in kdenetwork:
status: Unknown → Unconfirmed
Ralph Janke (txwikinger) wrote :

Thanks for reporting this issue and helping to make Ubuntu better.

Set to confirm due to existing upstream report.

Thanks again.

Changed in kdenetwork:
importance: Undecided → Wishlist
status: New → Confirmed
Jonathan Thomas (echidnaman) wrote :

Should be fixed in KDE 4.2.

Changed in kdenetwork (Ubuntu):
status: Confirmed → Fix Released
Changed in kdenetwork:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.