Ubuntu

Kopete unable to find jasper after fresh install of natty

Reported by iclestu on 2011-06-02
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
kdenetwork (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kopete

Everything works fine in preview but when trying to view or send cam on yahoo network kopete complains:

Unable to find the Jasper image conversion program.
Jasper is required to render Yahoo webcam images.
Please see http://userbase.kde.org/Kopete/Webcam_Support for further information.

despite the jasper package being installed correctly.

Kubuntu 11.04

kopete:
  Installed: 4:4.6.2-0ubuntu3
  Candidate: 4:4.6.2-0ubuntu3
  Version table:
 *** 4:4.6.2-0ubuntu3 0
        500 http://gb.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status

libjasper1:
  Installed: 1.900.1-7ubuntu2
  Candidate: 1.900.1-7ubuntu2
  Version table:
 *** 1.900.1-7ubuntu2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status

libjasper-runtime:
  Installed: 1.900.1-7ubuntu2
  Candidate: 1.900.1-7ubuntu2
  Version table:
 *** 1.900.1-7ubuntu2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
        100 /var/lib/dpkg/status

iclestu (iclestu) wrote :

Downloading the previous version of Kopete from :

http://packages.ubuntu.com/maverick/i386/kopete/download

 then installing with:

 sudo dpkg -i kopete_4.5.1-0ubuntu2.2_i386.deb

rolls back to previous version where it works flawlessly.

Unfortunately upgrading to the current version via

sudo apt-get upgrade

makes it not work again :). Therefore the bug seems to only affect the latest version....

(I assume there is a way to stop the application updating somehow without deselcting it manually every time but I have not found it yet and such issues are for support forums not bug reports! ;) )

Clay Weber (claydoh) on 2011-06-19
affects: kopete (Ubuntu) → kdenetwork (Ubuntu)
Changed in kdenetwork (Ubuntu):
status: New → Confirmed
Harald Sitter (apachelogger) wrote :

Apparently the patch that makes jasper a runtime dependency is kaput.

<apachelogger> dpkg-source: info: applying kubuntu_07_kopete_libjasper_optional.diff
<apachelogger> claydoh: libjasper-runtime is installed?
<claydoh> hmm I didn't look so deep
<apachelogger> might be that the patch is kaput
<claydoh> sure is
<claydoh> installed that is
-*- claydoh haz webcamz now, discovers many new things :)
<apachelogger> lolwut?
<apachelogger> is it working now or what?
<claydoh> if i use a maverick kopete package
<claydoh> it does
<apachelogger> ah
<apachelogger> patch kaputt then

Harald Sitter (apachelogger) wrote :

Incidentally enough the jasper-runtime suggestion is on kdenetwork not on kopete, wonder why that is.

iclestu (iclestu) wrote :

Is it appropriate to ask here why the bug should be filed under 'kdenetwork' rather than kopete? I am wondering if I filed the bug report wrongly when I submitted it?

I'm just a little bit lost and want to learn for next time :-)

Clay Weber (claydoh) wrote :

I f I have this right, its because kopete is actually part of kdenetwork. Kdenetwork source is patched and built, the separate pieces (Such as Kopete) are then put into their own individual packages.

You didn't file the bug incorrectly at all, it was just refined a little to target where the origin of the problem is.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers