Kopete ICQ plugin broken due to login server change

Bug #676663 reported by Martin Konrad on 2010-11-17
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KDE Network
Fix Released
Medium
kdenetwork (Ubuntu)
Medium
Harald Sitter
Karmic
Medium
Harald Sitter
Lucid
Medium
Harald Sitter
Maverick
Medium
Harald Sitter

Bug Description

=== SRU ===

0) Description: AOL recently sold ICQ, as a result of this change the ICQ login server got changed from login.oscar.aol.com to login.icq.com. Kopete needs to be updated to support this change and allow users to use the ICQ service.

1) Impact: Every user who wishes to use Kopete with ICQ will currently get an error message on login because the old login server does not exist anymore. This applies to all new as well as existing users.

2) The bug has been resolved upstream by replacing all occurances of the old login server address with the new one [1]. Additionally existing kopete configuration files (of existing users) will be updated accordingly using a kconf_update script [2]. The changes will be landing in 11.04 along with at least KDE 4.6.

3) Patches for Karmic, Lucid and Maverick are attached

4) How to reproduce the issue:
 - Create an ICQ account or make sure the right login credentials of an existing one are known to you
 - Open Kopete
 - Configure an ICQ account
 - Try connecting to the newly created account
 - Note how an error will prevent you from login, while the ICQ web client works just fine
(same applies to existing accounts, just that they only need to connect)

 - With the patch applied, connecting should work without errors, given correct login data were provided.

5) No known regression potential exists.

[1] http://websvn.kde.org/?view=rev&revision=1197797
[2] http://websvn.kde.org/?view=rev&revision=1197954

=== Original Report ===

Binary package hint: kdenetwork

Since a few days the ICQ plugin of kopete is unusable because it contains a hard-coded server name that is not valid any more. This issue has already been fixed upstream:

http://bugs.kde.org/show_bug.cgi?id=257008#c8

Please provide a fixed package because this seems to affect a lot of users.

Harald Sitter (apachelogger) wrote :

Required changes are:

Change to default:
  http://websvn.kde.org/?view=rev&revision=1197797

Migration script for existing config files:
http://websvn.kde.org/?view=rev&revision=1197954

Changed in kdenetwork (Ubuntu Karmic):
status: New → Triaged
Changed in kdenetwork (Ubuntu Lucid):
status: New → Triaged
Changed in kdenetwork (Ubuntu Karmic):
importance: Undecided → Medium
Changed in kdenetwork (Ubuntu Maverick):
importance: Undecided → Medium
status: New → Triaged
Changed in kdenetwork (Ubuntu Lucid):
importance: Undecided → Medium
Changed in kdenetwork (Ubuntu):
importance: Undecided → Medium
status: New → Fix Committed
assignee: nobody → Harald Sitter (apachelogger)
summary: - kopete: ICQ plugin unusable ("password wrong")
+ Kopete ICQ plugin broken due to login server change
Harald Sitter (apachelogger) wrote :
description: updated
Changed in kdenetwork (Ubuntu Maverick):
assignee: nobody → Harald Sitter (apachelogger)
Harald Sitter (apachelogger) wrote :
Changed in kdenetwork (Ubuntu Lucid):
assignee: nobody → Harald Sitter (apachelogger)
Harald Sitter (apachelogger) wrote :
Changed in kdenetwork (Ubuntu Karmic):
assignee: nobody → Harald Sitter (apachelogger)
Jonathan Riddell (jr) on 2010-11-18
tags: added: kubuntu
Harald Sitter (apachelogger) wrote :

All uploaded to their respective proposed queues. For natty I was going to wait for KDE 4.6 beta1, which is going to be tagged today and released next Wednesday.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdenetwork - 4:4.5.3-0ubuntu2

---------------
kdenetwork (4:4.5.3-0ubuntu2) natty; urgency=low

  * Add kubuntu_05_fix_icq.diff transiting from old login.oscar.aol.com to new
    login server login.icq.com (LP: #676663)
 -- Harald Sitter <email address hidden> Wed, 17 Nov 2010 21:56:16 +0100

Changed in kdenetwork (Ubuntu):
status: Fix Committed → Fix Released
Changed in kdenetwork:
status: Unknown → Fix Released

Accepted kdenetwork into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in kdenetwork (Ubuntu Karmic):
status: Triaged → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted kdenetwork into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in kdenetwork (Ubuntu Lucid):
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

Accepted kdenetwork into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in kdenetwork (Ubuntu Maverick):
status: Triaged → Fix Committed
Jonathan Riddell (jr) on 2010-11-22
Changed in kdenetwork (Ubuntu Maverick):
milestone: none → maverick-updates
Jonathan Riddell (jr) wrote :

I tested the maverick packages. With 4:4.5.1-0ubuntu2 it did not connect to ICQ. After installing 4:4.5.1-0ubuntu2.1 from maverick-proposed it did connect

marking as verification-done for maverick
v-needed for lucid and karmic

Jonathan Riddell (jr) wrote :

I set up a karmic EC2 machine, installed Kopete 4:4.3.2-0ubuntu4.1, added an ICQ account, it did not connect. I installed 4:4.3.2-0ubuntu4.2 from karmic-proposed, started kopete and it did connect.

Jonathan Riddell (jr) wrote :

I set up a lucid EC2 machine, installed Kopete 4:4.4.2-0ubuntu4.1, added an ICQ account, it did not connect. I installed 4:4.4.2-0ubuntu4.2 from lucid-proposed, started kopete and it did connect.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdenetwork - 4:4.3.2-0ubuntu4.2

---------------
kdenetwork (4:4.3.2-0ubuntu4.2) karmic-proposed; urgency=low

  * Add kubuntu_05_fix_icq.diff transiting from old login.oscar.aol.com to new
    login server login.icq.com (LP: #676663)
 -- Harald Sitter <email address hidden> Wed, 17 Nov 2010 22:37:12 +0100

Changed in kdenetwork (Ubuntu Karmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdenetwork - 4:4.5.1-0ubuntu2.1

---------------
kdenetwork (4:4.5.1-0ubuntu2.1) maverick-proposed; urgency=low

  * Add kubuntu_05_fix_icq.diff transiting from old login.oscar.aol.com to new
    login server login.icq.com (LP: #676663)
 -- Harald Sitter <email address hidden> Wed, 17 Nov 2010 21:56:16 +0100

Changed in kdenetwork (Ubuntu Maverick):
status: Fix Committed → Fix Released
Changed in kdenetwork (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in kdenetwork:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.