Ubuntu

Kopete won't login yahoo

Reported by Bob on 2009-06-24
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
KDE Network
Invalid
Medium
kdenetwork (Ubuntu)
High
Unassigned
Nominated for Hardy by Richard
Jaunty
Undecided
Unassigned

Bug Description

 Pidgin wouldn't login also. Found this fix for Pidgin. They found around june 19th 2009 Yahoo just change login method. Here is a link for pidgin fix. http://news.softpedia.com/news/How-to-Fix-Yahoo-problem-in-Pidgin-114754.shtml . It worked great. Just need one for Kopete. Thank you (upstream comments about upgrade can be found here: http://mattr.info:8080/blog/2009/06/24/kopete-and-yahoo/)

Bob (jomcfadden) wrote :

 I got Kopete to work by going to account preferences and setting it to override default settings.

  server: cn.scs.msg.yahoo.com port : 5050

Changed in kopete (Ubuntu):
status: New → Confirmed
SLerman (smlerman) wrote :

This has been fixed upstream. The Kopete bug report is here: https://bugs.kde.org/show_bug.cgi?id=197104. The SVN revision for it is 986796. There's a comment at/near the end (comment 35) of someone who has the patch in a PPA.

affects: kopete (Ubuntu) → kdenetwork (Ubuntu)
Changed in kdenetwork (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in kdenetwork:
status: Unknown → Fix Released
Peter Antoniac (pan1nx) wrote :

There is a PPA package available to fix the problem:

http://ppa.launchpad.net/kachristmas/ppa/ubuntu/pool/main/k/kdenetwork/

tags: added: upgrade
description: updated
Jonathan Riddell (jr) wrote :

fix uploaded to jaunty-proposed, waiting in queue

Changed in kdenetwork (Ubuntu Jaunty):
status: New → In Progress
Jonathan Riddell (jr) wrote :

TEST CASE: start kopete, connect to a Yahoo Messenger account. It will only work with the new version.

Jonathan Thomas (echidnaman) wrote :

Fixed in Karmic. (But please note that the jaunty task is still open. And needs testing.)

Changed in kdenetwork (Ubuntu):
status: Triaged → Fix Released
SLerman (smlerman) wrote :

It's been working for me in jaunty since upgrading to KDE 4.2.96 (4.3RC2). Not sure how valid a test that qualifies as, but at least it's one data point.

Martin Pitt (pitti) wrote :

Accepted kdenetwork into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in kdenetwork (Ubuntu Jaunty):
status: In Progress → Fix Committed
tags: added: verification-needed
Richard (rd1) wrote :

This bug also affects Hardy, with latest updates - Kopete version 0.12.7 on KDE 3.5.10.

There's also a 'warning only' variant of this bug: I have been getting warnings from Yahoo Admin on this version, though I can still log in for now. Presumably Yahoo will stop warning at some point and simply turn off the old authentication mechanism.

I have managed to compiled Kopete from KDE 4.3.1 and bundled it together with the required KDE and Qt dependencies as a tarball - quite a big download but for those who don't want to switch to Pidgin or upgrade from Hardy, it might provide a temporary solution.

See http://ubuntuforums.org/showthread.php?p=7937521 for more about this tarball and a download link.

Since this bug is affecting people on Hardy, I would like to propose this is backported to Hardy - though it might be more efficient to simply backport the patch to KDE 3.5.10 rather than build KDE 4.3.1. Worth checking if SUSE has done a backport already.

Steve Beattie (sbeattie) wrote :

I have reproduced the inability to log into Yahoo's IM service with kopete from jaunty, 4:4.2.2-0ubuntu2, and confirmed that the version in jaunty-proposed, 4:4.2.2-0ubuntu2.1, fixes the issue. I also verified that I was able to continue authenticating to other messaging services and saw no sign of regressions. Marking verification-done.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdenetwork - 4:4.2.2-0ubuntu2.1

---------------
kdenetwork (4:4.2.2-0ubuntu2.1) jaunty-proposed; urgency=low

  * Add kubuntu_07_yahoo_login_fix.diff from upstream, closes LP: #391763
    "Kopete won't login Yahoo"

 -- Jonathan Riddell <email address hidden> Wed, 22 Jul 2009 19:15:04 +0100

Changed in kdenetwork (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Richard (rd1) wrote :

Is there any chance of a backport of this fix to Hardy? There must be quite a lot of Yahoo+Kopete users out there. Yahoo is now almost unusable, as it's disconnecting my session every few seconds when using the Hardy version of Kopete, details mentioned above.

Doru (blue-line) wrote :

Hello,

I wrote a small backport patch for Kopete 0.12.7/KDE 3.5.10.
This should fix yahoo protocol problem in that version....
Hope it works for Hardy...

D.

Richard (rd1) wrote :

Doru, Thanks very much for the patch. I will try to get some time to test it, though I don't have a KDE 3.5.10 build environment. If you felt like applying the patch to the Hardy version of Kopete/KDE and building a kopete .deb it would be greatly appreciated by many people, I'm sure!

Or even a tarball with the kopete executable as that's presumably the only thing that is changed by this patch.

Changed in kdenetwork:
status: Fix Released → Invalid

I am highly upset because Kopete will not log into my Yahoo account.
This really gets under my skin as I cannot keep up with my family and
friends. Kopete has always been a cut above Pidgin and it is what made
Linux better than windows. Now I find myself not being able to use Kopete.
This is insane! All of my friends and family use Yahoo chat. ICQ, AIM, ect..
is straight garbage. Guess I will be confined to my web based yahoo webmail
account in order to chat with everyone.

Changed in kdenetwork:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.