Ubuntu

Khelpcenter missing docs list

Reported by Dave Morley on 2008-10-17
132
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Adept Manager
Unknown
Wishlist
KTorrent
Unknown
Wishlist
adept (Ubuntu)
Low
Unassigned
Declined for Jaunty by Jonathan Thomas
amarok (Ubuntu)
Undecided
Unassigned
Declined for Jaunty by Jonathan Thomas
cdbs (Ubuntu)
Medium
Harald Sitter
Declined for Jaunty by Jonathan Thomas
digikam (Ubuntu)
Low
Unassigned
Declined for Jaunty by Jonathan Thomas
k3b (Ubuntu)
Undecided
Unassigned
Declined for Jaunty by Jonathan Thomas
kdelibs (Ubuntu)
Medium
Harald Sitter
Declined for Jaunty by Jonathan Thomas
kdenetwork (Ubuntu)
Low
Unassigned
Declined for Jaunty by Jonathan Thomas
kdepimlibs (Ubuntu)
Low
Unassigned
Declined for Jaunty by Jonathan Thomas
kde-runtime (Ubuntu)
Low
Harald Sitter
Declined for Jaunty by Jonathan Thomas
kde-workspace (Ubuntu)
Low
Unassigned
Declined for Jaunty by Jonathan Thomas
konversation (Ubuntu)
Low
Unassigned
Declined for Jaunty by Jonathan Thomas
ktorrent (Ubuntu)
Low
Unassigned
Declined for Jaunty by Jonathan Thomas

Bug Description

Binary package hint: khelpcenter

Missing Doc modules in helpcenter list:

Kubuntu Docs:
All Present

Welcome to KDE:
All Present

KDE User's Manual:
All Present

Application Manuals:
Find Files/Folders:
All Present

Graphics:
All Present

Help:
All Present

Internet:
Akregator = Missing
Kmail = Missing
Konversation = Appears twice and is Missing
Ktorrent = Missing

Multimedia:
Amarok = Appears Twice and is Missing
K3b = Appears Twice and is Missing

Office:
All Missing

System:
KsystemLog = Missing

Utilities:
Knotes = Missing
KTimeTracker = Missing

Control Center Modules:
Fonts = Appears Twice has different info in both
Sound = Missing
Keyboard Layout = Missing
Solid = Missing
Mouse = Missing
Window Behaviour = Missing
Desktop Effects = Missing
Window-Specific = Missing

KinfoCenter Modules:
Processor Information = Missing
IEEE 1394 Devices = Missing

Kioslaves:
ar = Missing
audiocd = Missing
mbox = Missing
scalix = Missing
scalixs = Missing
zip = Missing

Scrollkeeper:
Seems to be empty

Plasma Manual:
All Present

Tutorials:
All Present

UNIX manual pages:
(9) Kernel = Missing
(n) New = Missing

Browse Info Pages:
All Present

The KDE FAQ:
All Present

Contact Info:
All Present

KDE on the Web:
All Presnt

Supporting KDE:
All Present

Version: 2.0 Destroyer (using KDE 3.5.3, Kubuntu Package 4:3.5.3-0ubuntu0.1 dapper)
Compiler: Target: i486-linux-gnu
OS: Linux (i686) release 2.6.15-23-386

Well, this is not a real bugreport, but somehow I feel I want this to be documented...
Adept improved a lot in the last year, but the version in Dapper is missing one seriously important thing: Documentation!

There is not a single QWhatThis I found
... no QToolTip
... no man-page
... no manual
... the homepage of the author is not giving any information
... http://web.ekhis.org/adept.html is dead

I installed Dapper on the computers of two others, both are users and have no clue about things like "apt", "shell" and so on. The didn't understand the concept of Adept at all and finally gave up because they found no documentation whatsoever. This if for me a showstopper-bug, nothing less.
There is no "usability"-section in this bugtracker, this is why I filed it as a wish... Adding tooltips on the 20 most important widgets would help *a lot*.

Version: (using KDE KDE 3.5.5)
Installed from: SuSE RPMs
Compiler: gcc 4.1.0 (it varies depending what version of OpenSuse is installed) Using 10.1 and 10.2 beta 4 OpenSuse Linux - installed via 64 bit(x86-64) rpm eg ktorrent-2.0.3-7.1
OS: Linux

I am using KTorrent 2.0.2 using KDE 3.5.4 that comes with 10.2 Alpha 4(64 bit)
When I goto Help | Ktorrent Handbook I get an error message which says "There
is no documentation available for /ktorrent/index.html." in the helpsystem.
Can some documentation be put in place ?, especially howto open up a port when you
use a firewall and help-documentation on setting up KTorrent in Suse and howto run a simple test to
check it can get a file and others accessing a file you provide. Perhaps provide a short tutorial.

Also I get this message on an updated Suse 10.1 (64bit) system using KTorrent 2.0.3 using KDE 3.5.5.
Any help is appreciated. Thankyou.

Documentation is being worked on for the 2.1 release.

I just downloaded the source code for ktorrent-2.2.2, but I still cannot find the (source of) the documentation.
Which file/folder is it supposed to be in?

Has the documentation actually been started?

It has been started, but I don't know the current status.

Good afternoon,

Just curious if any work has been down on this manual or not? I would be willing to help out on this.

Jonathan

I know someone has written something, but he is keeping what he has for himself on his usb stick or something like that (according to a comment I remember seeing in the ktorrent forum).

Check the ktorrent forums, find the guy and bit him up until he confesses and hand over the goods ;)

Yeah, he was going to send me what he had. I better check up on him, so we can include this with 2.2.3

Perhaps a dummy file can be added stating that documentation is forthcoming along with the link to the site and the fora.

Yes, well, this is true. However, I have as little time as it gets, so help with documentation would be welcome. I have been working on a 3.0 for some time now, which should address at least some of the usability issues, but there are probably quite some left, and there's still too little documentation.

I believe the situation has much improved with Adept 3. However, this is mostly a perpetual issue -- I'm marking it as needs volunteer, so people are encouraged to step up with help text improvements.

Ralph Janke (txwikinger) wrote :

I can confirm that the Khelpcenter is missing this information.

Changed in kdebase:
importance: Undecided → Low
status: New → Triaged
Harald Sitter (apachelogger) wrote :

KDEPim is difficult to address, the documentation is moved to a different package, which is not installed by default, the definition for the availability however is part of the default desktop files shipped along the applications. Only a minor issue really, because from a packaging standard point of view, the docs aren't essential and thus don't require a dependency.
Only sensible solution would be to either have KHC ensure docs are really available before adding the application nodes to the tree, or that KHC should show a message stating the missing documentation and how to install them (should be implemented upstream in a distribution generic manner).

KTorrent's desktop file seems to be wrong, at least I can't find any real docs.

Amarok and K3b's twice appearance is fixed already, the missing is however caused by them using completely different paths for their translations. Acceptable solutions would be to either not list the documentation at all (which doesn't prevent either of these apps to reference it) or to move them to /usr/share/doc/kde4/HTML (instead of kde/HTML). Latter is preferred, I am not sure we should do this at this point though. Same applies for Konversation.

KSystemlog's desktop file is wrong
> DocPath=ksystemlog/mainWindow.html
should be
> X-DocPath=ksystemlog/index.html

I am not sure we can do something about the doubleness of Fonts, the associated KControlModules have the same names, so... needs investigation.
All other Control Center Modules have wrong desktop files (shouldn't list docs at all).

Same for Info Center

Same for KIO

Scrollkeeper is not empty if GNOME stuff is installed, but it doesn't work

Manpages are reproducible, I am not sure how it creates the nodes though (pretty sure it is an ubuntu specific problem).

According to this affected packages are:
* kdebase-runtime (KHC glitches)
* konversation (KDE 3 doc path not searched by KHC - later K3)
* amarok (K3)
* k3b (K3)
* ktorrent (wrong desktop file - later wdf)
* kdebase-runtime-data (wdf)
  + kcm_phonon.desktop
  + ar.protocol
  + zip.protocol
* kdebase-workspace-data (wdf)
  + keyboard_layout.desktop
  + kcm_solid.desktop
  + mouse.desktop
  + kwinoptions.desktop
  + kwincompositing.desktop
  + kwinrules.desktop
  + kcmsolidproc.desktop
  + kcmview1394.desktop
kdemultimedia-kio-plugins (wdf)
  + audiocd.protocol
kdepimlibs-data (wdf)
  + mbox.protocol

Changed in kdebase:
assignee: nobody → apachelogger
status: Triaged → Confirmed

In my opinion, if you don't have documentation to distribute, you should at least create a custom helpmenu (considering there is no way to get it not to show the Handbook item, as far as I know there is not ;-) and the documentation key should be removed from the desktop file.
Having no documentation is not as bad as having no documentation but still claiming there should be one. :)

FYI: "The file or folder help:/ktorrent/index.html does not exist" is what I get when I press F1 in 3.1.2.

Perhaps an HTML file pointing out the existence of ktorrent.org and its fora could be a quick stop-gap solution. Just a thought.

Jonathan Thomas (echidnaman) wrote :

Also affects kdenetwork via the rdp kio slave.

Jeff Trull (jetrull) wrote :

Not having the kmail handbook available once you've installed kmail is frustrating. Is there some way to obtain it by installing a different package?

Daniel Hahler (blueyed) on 2009-01-06
Changed in konversation:
importance: Undecided → Low
status: New → Triaged
Harald Sitter (apachelogger) wrote :

In order to make KDE 3 docs available we will join the documentation paths of KDE 3 and KDE 4. The only conflicts should appear in kdelibs (common theming), because the application would clash anyway (so whether their documentation does that as well, doesn't really matter).
Once kdelibs is deployed kde4.mk in CDBS needs to be changed to use /usr/share/doc/kde/HTML as HTML_INSTALL location for cmake.
After that all KDE 4 apps need to be rebuilt (for core KDE this will happen for 4.2.0 or a bit later), once this is done rebuilds on other KDE 4 apps can be started ... we'll coordinate via the kubuntu-devel list most likely.

Changed in cdbs:
assignee: nobody → apachelogger
importance: Undecided → Medium
status: New → Triaged
Changed in kdelibs:
assignee: nobody → apachelogger
importance: Undecided → Medium
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdelibs - 4:3.5.10.dfsg.1-1ubuntu7

---------------
kdelibs (4:3.5.10.dfsg.1-1ubuntu7) jaunty; urgency=low

  * Don't install anything to usr/share/doc/kde/HTML, this path will now be
    used by KDE 4 (drop all content in favor of KDE 4) (LP: #284915)
  * Drop the package kdelibs4-doc completely. It contained API documentation
    which is now obsolete, but still available via api.kde.org.

 -- Harald Sitter <email address hidden> Sun, 18 Jan 2009 20:37:31 +0100

Changed in kdelibs:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cdbs - 0.4.52ubuntu11

---------------
cdbs (0.4.52ubuntu11) jaunty; urgency=low

  * Change HTML_INSTALL_DIR from usr/share/doc/kde4/HTML to ..doc/kde/HTML
    this enables KDE 4's KHelpcenter to use KDE 3 and KDE 4 documentation
    (LP: #284915)

 -- Harald Sitter <email address hidden> Sun, 18 Jan 2009 20:21:42 +0100

Changed in cdbs:
status: Triaged → Fix Released
Changed in k3b:
status: New → Fix Released
Changed in konversation:
status: Triaged → Fix Released
Changed in ktorrent:
importance: Undecided → Low
status: New → Triaged
Changed in ktorrent:
status: Unknown → Confirmed
Changed in adept:
importance: Undecided → Low
status: New → Triaged
Changed in adeptmgr:
status: Unknown → In Progress
skierpage (skierpage) wrote :

I noticed the missing KInfoCenter Modules > IEEE 1394 Devices docs in Kubuntu 9.04 , but you can still run `kcmshell4 kcmview1394` to run the IEEE 1394 Devices KDE Control Module.

So yes the immediate fix is to remove the X-DocPath line from kcmview1394.desktop , but removing that won't stop the control module from having a broken [Help] button; it just winds up invoking help:/ which doesn't exist. (Try this with `kcmshell4 kcmsolidproc`.)

Is the underlying bug that the view1394 lacks documentation (an upstream bug in kdebase) or that it is obsolete (a Kubuntu packaging bug)?

Changed in amarok (Ubuntu):
status: New → Confirmed
Changed in kdebase-workspace (Ubuntu):
status: New → Confirmed
Changed in kdepimlibs (Ubuntu):
status: New → Confirmed
Changed in kdemultimedia (Ubuntu):
status: New → Confirmed
Changed in kdenetwork (Ubuntu):
status: New → Confirmed
Changed in kdemultimedia (Ubuntu):
importance: Undecided → Low
Changed in kdepimlibs (Ubuntu):
importance: Undecided → Low
Changed in kdenetwork (Ubuntu):
importance: Undecided → Low
Changed in digikam (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Changed in kdebase-workspace (Ubuntu):
importance: Undecided → Low
Bas Roufs (basroufs) wrote :

Hereby I confirm that documentation is still missing in KMAIL, Digikam and several other KDE applications in Kubuntu 9.04.

Problem still exists with KDE 4.5.1.

This is probably a very dumb question, but which repository should I check out if I want to add the manual page to the package?

This one?
http://websvn.kde.org/trunk/extragear/network/ktorrent/

That is the one and only repository for ktorrent.

So you have a manual ?

No. I fixing some Ubuntu and KDE packages at work from time to time and I also spent hours of hours on working on the KDE Help Center.

I want to contribute some of the patches I already created for a company to the original packages. So I would like to do it myself: write the manual and then commit.

I would very much welcome somebody putting in the effort to create a manual.

So go ahead, I will proofread it for you, just let me know when you have something to commit.

SVN commit 1190768 by lueck:

add help file with online ressources
@Valentin: if you'd like to join the kde documentation team subscribe to <email address hidden>
BUG:212931
CCBUG:136994

 M +1 -0 CMakeLists.txt
 A ktorrent (directory)
 A ktorrent/CMakeLists.txt
 A ktorrent/index.docbook

WebSVN link: http://websvn.kde.org/?view=rev&revision=1190768

Changed in adeptmgr:
importance: Unknown → Wishlist
Changed in ktorrent:
importance: Unknown → Wishlist

At present I am working at Kubuntu 10.10. The missing documentation
problem is still relevant. So, it is good to put the issue at the
"whish list".

Respectfully yours,

Bas Roufs.

2011/2/27 Bug Watch Updater <email address hidden>:
> ** Changed in: adeptmgr
>   Importance: Unknown => Wishlist
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/284915
>
> Title:
>  Khelpcenter missing docs list
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/adeptmgr/+bug/284915/+subscribe
>

demilord (demilord) wrote :

Still lots of documentation missing in Kubuntu 10.10
Here is the list with missing, duplicate documentation

akregator
kmail
ktorrent
rekonq

amarok appears 2 times
k3b loads external documentation in browser external
kadressbook
kontact
kontact administration
korganizer
knotes

demilord (demilord) wrote :

may i correct myself i installed kdepim-docs and its solved :(

affects: kdebase-workspace (Ubuntu) → kde-workspace (Ubuntu)
affects: kdebase-runtime (Ubuntu) → kde-runtime (Ubuntu)
no longer affects: kdemultimedia (Ubuntu)
Changed in adept (Ubuntu):
status: Triaged → Won't Fix

I dont understand if the documentation has been provided by Burkhard Lueck and I can see the documentation in my ktorrent 4.1.3 then why has this bug not been closed.

Changed in ktorrent:
status: Confirmed → Unknown

Adept has been in the unmaintained state for a few years. Use muon[1] as replacement .

[1] https://launchpad.net/muon

Changed in adeptmgr:
status: In Progress → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.